Tech Support Forum banner
Status
Not open for further replies.
1 - 19 of 19 Posts

·
TSF Team Emeritus, Microsoft Support
Joined
·
15,478 Posts
Discussion Starter · #1 ·
I have found that ZA is not allowing me to use VNC-SC, it blocks internet servers. Does anyone know how I can allow permissions for this to work?
 

·
Registered
Joined
·
2,752 Posts
In ZoneAlarm, under Program Control, allow (green checkmark) Access and Server for both Trusted and Internet for the VNC executable.

Make sure to reboot your machine after putting the new settings - if you do not shutdown properly ZA tends to "forget" your new settings.

If it still does not work, you may need to increase ZA's Trust Level with the VNC executable, which can be changed in Program Control.

See if this helps.
 

·
Registered
Joined
·
1,645 Posts
Which end of the connection are you on? Are you the one launching the Single Click app created for remote assistance or are you the assistance provider?

I use Single Click alot to help my family with computer issues but none of them use a Software firewall. They are all behind NAT'd routers as I am. I just forward the VNC port on my router to my pc on my lan.
 

·
TSF Team Emeritus, Microsoft Support
Joined
·
15,478 Posts
Discussion Starter · #4 ·
I am the provider
Port 5500 is already forwarded

In ZoneAlarm, under Program Control, allow (green checkmark) Access and Server for both Trusted and Internet for the VNC executable.
They are all checked as "allow"
 

·
Global Moderator
Joined
·
51,346 Posts
Try forwarding port 5900, which is the correct port for screen 0 for UltraVNC. :1angel:
 

·
Registered
Joined
·
2,752 Posts
Try setting the Trust Level, in Program Control for the executable, to Super which should work (anything ZA finds as a suspicious activity with the program will be ignored). If it still doesn't work, try No Enforcement, though that will be just as good as having ZA off for protection when it comes to activities for the executable.

ZoneAlarm, especially if you have the Pro version, has peculiar granularity for its settings.
 

·
Global Moderator
Joined
·
51,346 Posts
Or try another firewall. :smile:
 

·
TSF Team Emeritus, Microsoft Support
Joined
·
15,478 Posts
Discussion Starter · #11 ·
I have no issues if I turn off ZA but whats the use of having a firewall if I cant use it to protect my system.
Whats the chances of something happening while I am giving a 1 hour service with it shut off?

I'm on hold on this anyhow, I sent her my application zipped via email and she for some reason cannot execute the program. .....sigh..... I will need to go to her house and use my thumbdrive and put the app on her desktop personally. I was hoping to avoid this type of set back hence the use of remote assistance :tongue:

Will play with ZA when I get her setup. I know I can make this work, it will just take me longer than expected......I am a persistant person :1angel:
 

·
TSF Team Emeritus, Microsoft Support
Joined
·
15,478 Posts
Discussion Starter · #13 ·
Update:
I have successfully established connectionn via VNC-SC and my customer, but with ZA totally shutoff. My next step is to look into resolving this issue.

This will now help me greatly in providing services to my existing customers and hopfully their friends, and their friends and so on and so on :tongue:
 

·
Registered
Joined
·
1,645 Posts
I personally see no need to run a software firewall if you are behind a NAT'd router. I know what everyone is going to say, you don't know what is going out on your computer then. Well, I can tell you for sure that I am probably the most anal person when it comes to installing stuff on my pc and surfing the web. I even have my wife pretty well trained. Worst case secenario, I can look at my router logs if I think something suspicious is going on or fire up WireShark.

This isn't good advice for the average PC user. This is advice for the average I.T. person.
 

·
Roaming To Help
Joined
·
5,667 Posts
Usually its mouse clicks/keyboard access that is blocked and granting the permissions will allow this connectivity.

For that it would be:
- Open ZA control window
- Click the 'Firewall' tab
- Click the 'Advanced' button near the bottom of the tab window
- In the 'Advanced Settings' window, turn on the option titled 'Disable
Keyboard and Mouse Protection'.
- Click 'OK'.

AND/OR

-In the Overview section, goto the Preferences tab.
-Uncheck the 'Protect the ZoneAlarm client'

This usually allows full access w/VNC. But ZA is known to have this issue and since SF is a must for users, just get another better one like Comodo.
 

·
Global Moderator
Joined
·
51,346 Posts
FWIW, I've run for years with no firewall except for the router's firewall, it's never been an issue. It's also much simpler to get stuff like file/print sharing working on my network. :grin:
 

·
Global Moderator
Joined
·
51,346 Posts
I've had it for a long time, but when someone used it over at TSG, I remembered I still had it around. :smile:
 
1 - 19 of 19 Posts
Status
Not open for further replies.
Top