Tech Support banner

Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
1,393 Posts
Discussion Starter · #1 ·
Maybe someone could help me ... ;)

Wife's old PC - Sony Vaio. Win 98 SE. I'm trying to add a 3Com NIC and the @#[email protected]#$ thing won't take.

Device manager has a yellow ? with the PCI Serial Controller with a yellow exclamation mark.

I suspect the NIC won't take because of the yellow! PCI Serial Controller. How do I make it go away?

I've already reloaded Win'98. I've also downloaded and installed the latest NIC driver.
 

·
Registered
Joined
·
178 Posts
You probably need to download a driver for the PCI Serial Controller here onto a floppy. Then remove the PCI Serial Controller in the device manager, then update driver using the floppy.
 

·
Registered
Joined
·
1,393 Posts
Discussion Starter · #3 ·
Thanks for replying. Before I read your post, I removed the modem because I didn't need it, and the NIC. Removed both from device manager.

Rebooted several times and now trying to add the NIC back in. Box is seeing the NIC but not letting me specify the driver and add it in. I told it to " show me a list of all devices" blah blah blah and then was able to specify the driver location. But then Windoze pops up "Windows was unable to install the 3Com OfficeConnect ..."

:upset:

By taking out the modem and the nic - the PCI Serial Controller thing went away.
 

·
Registered
Joined
·
1,393 Posts
Discussion Starter · #4 ·
After clicking OK on the error box above, I get this one:

Windows encountered an error while trying to install the driver for this device.

Error code: 1F6
 

·
Registered
Joined
·
1,691 Posts
a for as much help as this is gonna be that error code means "Incorrect Function"

Have you tried going to the motherboard makers website and updating everything?
 

·
Registered
Joined
·
1,393 Posts
Discussion Starter · #7 ·
I haven't upgraded the MOBO. It's a Sony Vaio - anyone have experience with their drivers? Are they available?

I took out the Modem and I moved the NIC to a different PCI slot. Didn't help. The Yellow ? is gone for the PCI controller but the OS WILL NOT TAKE the NIC.
 

·
Registered
Joined
·
1,393 Posts
Discussion Starter · #9 ·
That did it!

Cabana, that site you linked to had another link to an older driver which did the trick!

Thanks for your help!

I'm going to "donate" some points to you!

:thmbup:
 

·
Registered
Joined
·
18 Posts
You'll need the driver/controller for the PCI Bridge for that particular system. Check Sony's web site for you particualr model and download system board/controller drivers and that should resolve the problem (after a reboot of course)

Hope that helps.......

NetEngineer......

www.wsbconsulting.com
 

·
Registered
Joined
·
1,393 Posts
Discussion Starter · #12 ·
Hey thanks. However, I had already fixed it by installing an older driver for the NIC.

:)
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top