Tech Support banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
21 Posts
brewster66 said:
I have an XFX GeForce 5600 AGP 128 (not the ultra)

The fan is making a lot of noise. I removed the card and blew all the dust out with compressed air, but it is still making the noise. Can I replace the fan on it?

This is a fairly good photo of what I have:

http://tienda.baluma.com/images/productos/t_graficas/xfx_5600xt.jpg
I have the exact same card, umm do u get any wierd shadow effects or anything?

http://www.techsupportforum.com/showthread.php?t=69523

please read
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
freak_jock said:
I have the exact same card, umm do u get any wierd shadow effects or anything?

http://www.techsupportforum.com/showthread.php?t=69523

please read
Yes, I see what you mean from your thumbnail images. For a while I was trying to play Serious Sam and then the game would freeze and the frozen image became all jagged. It was a hard freeze of the entire machine, I had to press the power button to restart the computer.

I got a gaming box now I just use the 5600 box for my work, mainly Photoshop and Dreamweaver which have no problems with the card, but it still makes the noise. I found out it may be still under warranty from XFX so I am awaiting an RMA if that's the case. (They have a two year warranty)
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
freak_jock said:
So i should contact my XFX people?

im from india
Well, from the looks of their homepage, it looks like they will have India tech support soon, but they don’t give a date.

http://xfxforce.com/web/intl/index.jspa

Did you buy the card in India or elsewhere? I am very impressed by their tech support team so far so maybe if you email them, they may be able to help you out or suggest a course of action. (You must have the original sales receipt and they have a standard two year warranty)

They are sending me a new fan, hopefully that will solve the problem. (I am in the USA.)

You could also try posting in their support forum here:

http://xfxforce.com/forums/forum.jspa?forumID=27
 

·
Registered
Joined
·
21 Posts
Nah, its was purcahsed in 04/04.. And i odnt have any reciept, but i guess that shudnt be an issue, i mean all our cards have serial codes, hdd guys no longer ask for bills, ipod people dont ask for bills, neither do nokia.

I just cant find my box to figure out who (sub dealer) imported my card to india.

Could it be a windows bug.. I found XFX support below satisfactory, they asked me to revert back to 5x.xx drivers.. whgich are really old, and didnt give me any explanation.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top