Tech Support Forum banner

Windows won't remember firefox window size/position

21839 Views 13 Replies 4 Participants Last post by  Kalim
Hi guys,

This has been bugging the hell out of me for about two weeks. Windows is no longer starting firefox maximized, and is putting it in a really small area to start out with. I'm sick of having to maximize it every time I open it.

I'm not sure if this is with other programs or not, but I can't remember anything coinciding with the start of this.

Also, I have a weird problem in FF where any drawers or menus will only open after clicking and moving under them. For example, I click an RSS feed in my bookmarks toolbar folder. The little arrow turns black, but nothing extends out. I have to move my cursor underneath the icon for the list to pop out.

Also, when adding a site to the bookmarks, I'll open up the dialog box and click "ok", but then the text just disappears and the bookmark will be entered without a label.

Any idea what might be up?
Not open for further replies.
1 - 14 of 14 Posts
Try this Fox

Right click on the Firefox icon (either on your Deskptop or in the Taskbar), click Properties. Click the shortcut tab, beside the Run line, use the drop down to change the way the application should open, change it to either Normal Window or Maximized

Let me know if this helps
Windows is no longer starting firefox maximized,
Just an FYI for troubleshooting purposes, but Windows has nothing to do with it.
I've seen similar problems with IE. If you maximize the window, then go to File> Close (or exit), it then remembers the setting the next time you open the browser.

What version of FF? Do you have the latest?

Yep it is the latest version.

Geekgirl, the shorcut trick worked fine, and I think I'll live with the other quirkiness until I do a complete uninstall/reinstall.

Thanks for the advice!
I would save my bookmarks, remove FF and reinstall to see if that resolves the other issues
This sort of behavior occurs if you have a conflicting or bad theme/extension.

Run Firefox in SafeMode (accessible from the menu) and see if you still experience this issue. If you don't its an extension/theme issue. You'll have to disable them and enable them one by one to figure out which one it is. If its the same either your profile is corrupt or your downloaded installation.
Under safe mode, the window starts windowed all the time (I didn't put the shortcut trick to the safe mode shortcut), but the menus and drawers open the way they should.

When the next release of FF comes out, I'm going to wipe it completely and start over, but for now I have too many custom settings (BlackBoxSearch custom searchbar item, mouse gestures, etc.) to make it worth my while as it is now.
Which version do you have? (check in Help>About Mozilla)

Its one or a combination of extensions thats causing your problems then. It may get worse.
The thing that makes FF great, also makes it worthless ;)

If you uninstall/reinstall, and you want to start from scratch, make sure you delete your application data, or you will just re inherit the same problems

There's no need to do all of that as the problem is just an extension, not an install nor a profile. To remove the problem, just a removal of one culprit extension is required. For a complete removal of everything Firefox related, the above link applies. Thats to "cure" a profile problem, an installation problem or an extension/theme problem.

Adblock Filterset.G Updater
DOM Inspector
Gmail Space
Right Encoding

Theme: Sky Pilot Classic
See less See more
Hi Fox

Firefox Problematic Extensions
Adblock: Prior to - Causes Firefox to hog memory
Adblock Plus: All versions - Triggers a bug in Firefox 2.0 that causes some extensions and web sites to break, most prominently Google Notebook extension
Fasterfox: Changes made by extension can interfere with Web site access, and persist after extension is uninstalled.
Filterset.G Updater: Prior to - Memory leak when used in conjunction with FlashGot
FlashGot: Prior to - Memory leak when used in conjunction with Filterset.G Updater
ForecastFox: All versions? - Causes excessive CPU usage with Firefox 2
Greasemonkey: All versions - Greasemonkey scripts do not work on sites blocked by NoScript
...prior to 0.6.3 - Window title doesn't change when switching tabs
NoScript: All versions:
-Causes an illegal operation in the Windows Media Player plugin if it is blocking JavaScript on a page with embedded Windows Media
-FlashBlock requires JavaScript to work to block flash ads
-Greasemonkey scripts require JavaScript
...since v1.1.0 - Java is blocked by default on untrusted sites
...prior to v1.1.3.9 - Causes Firefox to hog memory
To cut out their professionalism and community "codes", I'll tell you that many of the extensions you have installed (if the same versions and definitely Forecastfox) are problem full. I used to have them before going through endless troubleshooting to find the problem source. They don't just cause excessive CPU or memory leak but they disrupt standard browser behavior which for a lame reason is just never mentioned. Anything on the list can cause many problems.

Your best way is to disable them all (apart from Watch IP, DOM Inspector, Right Encoding and Talkback) and then use Firefox. If you don't get the same behavior then enable another one and restart again. Do this until you find which one you enabled right before you got the problem. That extension would have to be uninstalled. I'd then file a bug report for you but since leaving MozillaZine forums I've noticed that the site is in a complete mess (with most daily members the spammers) and the testers are just becoming too rude and crank. So I don't associate with most of them with Mozilla matters anymore. :eek:
See less See more
I messed around with all of it just now. Turned out it wasn't any of the extensions- it was actually a corrupted theme file. After uninstalling and reinstalling it, it's working as it should. Interestingly enough, any subsequent windows opened after the first will still not be maximized, but it's really not big enough a bother to waste time with.

Thanks for all your advice- if it weren't for you, I probably wouldn't have tested the theme.
You're welocme Fox, glad you got it pinned. :smile:

Theme was actually the next suggestion once the extensions were all in the clear :wink:
1 - 14 of 14 Posts
Not open for further replies.