Tech Support Forum banner

Windows Update and google search results not working after virus

2825 Views 1 Reply 2 Participants Last post by  TheBruce1
I got a virus about 4 days ago. After I got the virus, it said that my computer was infected and brought up a window and simulated a scan of my computer using the Antivir Antivirus program which I don't use. I use AVG and it is up to date. I closed the program and it kept telling me that it wasn't safe to not scan my computer. After that, any program I tried to open I would get a message saying that the file was corrupted, etc. This is what I've done so far to fix it.

1) I booted in to safe mode and restored the system to the last restore point. That allowed me to boot normally and download some antivirus/anti-malware programs.

2) I ran AVG and it didn't find anything.

3) I then ran malwarebytes and it found a few items and deleted them.

4) Ran Avast! antivirus and it also found a few infected files and deleted them.

5) I then ran both of those programs again to make sure everything was gone and neither found anything, so I assumed everything was good.

Over the next few days the Antivir program never came up to try to scan but I'm sure the computer is still infected. Every so often (usually after a reboot) I get the windows update in the system tray and it tries to download the update but it only says 0%. Then the icon goes away. Now I'm noticing that after I do a google search I can click on one of the links, but if I go back and click on another I get the following message "400 Bad Request" and below that it says "nginx/0.8.35".

It sometimes will allow me to get in the link but maybe only 1 out of every 10 tries. I usually just launch another browser. The other issue that I'm seeing is that when I click on the windows update "program" (really just a url link) from the programs list in the start menu it'll take me to a page that says "Internet Explorer cannot display the webpage" and that happens every time.

So the next steps I've taken are:

6) I ran Spybot - Search & Destroy and it found a lot of stuff, then deleted them.

7) I ran SuperAntiSpyware and it also found a lot, then deleted them.

8) Then I ran Dr. Web CureIt! and it found just a few, then deleted them.

I'm still having the same problems with my google searches and windows update. Note that I haven't seen any problems if I click on one of my favorites or type in a url and I haven't seen the problem occur when using internet explorer, except for the windows update issue. I've tried uninstalling and reinstalling google chrome now as well, but no luck. PLEASE HELP ME!
See less See more
Status
Not open for further replies.
1 - 2 of 2 Posts
Hello and welcome to TSF.

We want all our members to perform the steps outlined in the link I'll give you below, before posting for assistance. There's a sticky at the top of this forum, and a
Having problems with spyware and pop-ups? First Steps
link at the top of each page.

---------------------------------------------------------------------------------------------

Please follow our pre-posting process outlined here:

http://www.techsupportforum.com/f50...-posting-for-malware-removal-help-305963.html

After running through all the steps, you shall have a proper set of logs. Please post them in a new topic, as this one shall be closed.

If you have trouble with one of the steps, simply move on to the next one, and make note of it in your reply.

Please note that the Virus/Trojan/Spyware Help forum is extremely busy, and it may take a while to receive a reply.
See less See more
1 - 2 of 2 Posts
Status
Not open for further replies.
Top