Tech Support banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
when i hit start->turn off computer, it takes a long time before the options appear to either 'stand by', 'shut down', or 'restart'. i'm not sure what the computer is thinking about for so long, but is there a way to kick its butt into gear?
 

·
TSF Team Emeritus, Microsoft Support
Joined
·
15,478 Posts
SHUTDOWN WORKS, BUT IT’S REAL SLOW

1. If it appears that Win XP is not shutting down, give it some time. Some users report a minute or longer for shutdown to visibly start. Generally, this is a consequence of software that is running when shutdown is attempted. It also may have something to do with particular hardware. If you experience this problem, be sure to close all running programs before attempting shutdown and see if this solves your problem. If so, then you can determine, by trial and error, which program(s) are involved.


2. Newsgroup correspondent “Sarah” provided one specific solution for this. In Control Panel | Administrative Tools | Services, stop the Nvidia Driver Helper service. (You can also get this by launching SERVICES.MSC from a Run box.) Many other newsgroup participants quickly confirmed that this solved this “extremely slow shutdown” problem for them (it’s the most successful solution for this problem to date). According to correspondent Gan Ming Teik, downloading and installing the new version 23.11 Nvidia driver also solves this problem.


3. Correspondent Ron Spruell found that disabling the Terminal Services service reduced his shutdown time from over 2 minutes (hanging at the “Windows is shutting down” screen) to about 10 seconds. To disable Terminal Services, follow the steps in the prior paragraph for launching SERVICES.MSC. Please note that Terminal Services is required in Windows XP for running Remote Assistance, Fast User Switching, and (in XP Pro) Remote Desktop.


4. Correspondent Graeme J.W. Smith reported a more obscure cause of slow shutdown: In Win XP Professional, the Group Policy Editor has a security option to clear the pagefile at system shutdown. The same setting also forces the hibernation file to be wiped at shutdown. These processes take long enough that users may think that shutdown has hung. To change the setting, click Start | Run, type GPEDIT.MSC, click OK. Drill down to Computer Configuration | Windows Settings | Security Settings | Local Policies | Security Options. In the right pane, find “Shutdown: Clear virtual memory pagefile.” NOTE: Since someone actually has to have set this policy, the problem will be pretty rare, but is worth mentioning. However, Forum participant “roadrunner” reported that the personal security app Privacy Eraser automatically enables “Clear virtual memory pagefile,” and, therefore, may be the cause of a slow shutdown.


5. The Gear Software Security Service (GEARSEC.EXE), which enables iTunes for Windows to read and burn CDs, has been reported by many users to cause Windows XP to hang at the “Windows is shutting down” screen for as long as 20-30 seconds. WORK-AROUND: Stop the service prior to shutdown. One way to to this (suggested by “Thornburgh”) is to create a batch file with the one line net stop gearsecurity. You can either launch this batch file manually, or (in Win XP Professional) use GPEDIT.MSC) to specify this batch file as the shutdown script (under Computer Configuration | Windows Settings | Scripts | Shutdown). Gear Software’s forum has a thread on this issue here. (Tip from correspondent “Andy”)


6. MS-MVP Gary Thorn discovered that the Event Log can slow down Win XP shutdown. Disabling event logging removed the slowdown. If this works for you, then the real troubleshooting begins: finding out, by trial and error, what item that is being logged is causing the actual slowdown. (In Gary’s case, the Telephony service was causing the problem.) To disable the Event Log, launch the Services console as detailed in No. 2 above, and disable Event Log (right-click on Event Log, click Properties, under Startup Type select “Disabled”).



Points to improve the shutdown times
 

·
Registered
Joined
·
90 Posts
When did you first notice that it takes longer to shut down Scottie? If you actually remember about when - think of any software you may have installed recently, namely something like NIS (Norton Internet Security) and or any Creative Labs drivers for a soundcard or printer software (usually HP) - these apps can cause immense slowdowns in startup and shutdown. Usually - if it did shut down fast before but suddently becomes slow it's software you have installed. It can also be MS office software in startup. OS erros can also cause it and in that case some routine maintenance would be in order (scadisk/defrag/empty temps files).

Spyware can also cause this. So if you have tried and looked at all of the above - including Geekgirls notes referenced on her post you may need to head to the security forum here and let those folks help you out with cleaning up your PC to make sure you don't have anything nefarious on your hard drive.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #4 ·
thank you

thank you both, i will try to sort it out with all of the above (very helpful) information.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top