Tech Support banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have been having intermittent crashes BSOD and the bugcheck and memory dump come up with pciidex.sys Here is the memory dump


Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Users\KyleE\Desktop\MEMORY.DMP]
Kernel Summary Dump File: Only kernel address space is available

Symbol search path is: srv*c:\symbols*http://msdl.microsoft.com/download/symbols
Executable search path is:
Windows 7 Kernel Version 7601 (Service Pack 1) MP (8 procs) Free x64
Product: Server, suite: TerminalServer
Built by: 7601.17835.amd64fre.win7sp1_gdr.120503-2030
Machine Name:
Kernel base = 0xfffff800`01a49000 PsLoadedModuleList = 0xfffff800`01c8d670
Debug session time: Wed Aug 1 08:29:59.067 2012 (UTC - 7:00)
System Uptime: 1 days 12:51:20.660
Loading Kernel Symbols
...............................................................
................................................................
.........
Loading User Symbols

Loading unloaded module list
......................
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck A, {fffff88007c47000, 2, 0, fffff80001aca240}

Probably caused by : PCIIDEX.SYS ( PCIIDEX!BmSetup+6b )

Followup: MachineOwner
---------

1: kd> !analyze -v
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

IRQL_NOT_LESS_OR_EQUAL (a)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high. This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arguments:
Arg1: fffff88007c47000, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, bitfield :
bit 0 : value 0 = read operation, 1 = write operation
bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff80001aca240, address which referenced memory

Debugging Details:
------------------


READ_ADDRESS: fffff88007c47000

CURRENT_IRQL: 2

FAULTING_IP:
nt!RtlCopyMemoryNonTemporal+40
fffff800`01aca240 4c8b0c11 mov r9,qword ptr [rcx+rdx]

DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT

BUGCHECK_STR: 0xA

PROCESS_NAME: System

TRAP_FRAME: fffff880009d9470 -- (.trap 0xfffff880009d9470)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000001000 rbx=0000000000000000 rcx=fffff8800302d000
rdx=0000000004c1a000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff80001aca240 rsp=fffff880009d9608 rbp=0000000000000002
r8=0000000000000000 r9=0000000000000000 r10=fffffa800d677cd0
r11=fffff880009d95f0 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0 nv up ei pl nz na po nc
nt!RtlCopyMemoryNonTemporal+0x40:
fffff800`01aca240 4c8b0c11 mov r9,qword ptr [rcx+rdx] ds:6b10:7000=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER: from fffff80001ac7769 to fffff80001ac81c0

STACK_TEXT:
fffff880`009d9328 fffff800`01ac7769 : 00000000`0000000a fffff880`07c47000 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff880`009d9330 fffff800`01ac63e0 : 00000000`00000000 fffff800`01a07b7f 00000000`00000000 fffff880`07c47000 : nt!KiBugCheckDispatch+0x69
fffff880`009d9470 fffff800`01aca240 : fffff800`01a02e08 fffff880`07c47000 00000000`00000002 fffffa80`153f7220 : nt!KiPageFault+0x260
fffff880`009d9608 fffff800`01a02e08 : fffff880`07c47000 00000000`00000002 fffffa80`153f7220 fffff880`01042e9c : nt!RtlCopyMemoryNonTemporal+0x40
fffff880`009d9610 fffff800`01a02593 : fffffa80`0d677cd0 fffffa80`0d677c00 00000000`00000000 00000000`00000000 : hal!HalpDmaSyncMapBuffers+0x1b0
fffff880`009d96c0 fffff800`01a054fb : fffffa80`153b50f8 fffffa80`0d677cd0 fffffa80`153f7220 fffff800`01acd81a : hal!HalpDmaMapScatterTransfer+0xa3
fffff880`009d9710 fffff800`01a05472 : fffffa80`153b50f8 fffffa80`153b50f0 00000000`00001000 00000000`00000000 : hal!HalpMapTransfer+0x7b
fffff880`009d97a0 fffff800`01a0494f : 00000000`00000000 fffff800`01a01fb9 00000000`00000000 00000000`00000001 : hal!IoMapTransfer+0x8e
fffff880`009d97e0 fffff800`01a0513d : fffffa80`0d66b790 fffffa80`0d677cd0 fffffa80`0d677c01 00000000`00000000 : hal!HalpAllocateAdapterCallback+0xc7
fffff880`009d9880 fffff800`01a0471f : fffffa80`153b50b0 00000000`00001000 fffffa80`0d677cd0 fffffa80`153f7220 : hal!HalAllocateAdapterChannel+0x101
fffff880`009d98c0 fffff880`0108e0d3 : fffffa80`153b5010 fffff880`0108e12c fffffa80`000000a0 fffffa80`0d677cd0 : hal!HalBuildScatterGatherList+0x2f3
fffff880`009d9930 fffff880`0127eb53 : fffffa80`153b5010 fffffa80`0d6957d0 fffffa80`0d67b1a0 fffffa80`153b5010 : PCIIDEX!BmSetup+0x6b
fffff880`009d9990 fffff880`0127d803 : fffffa80`0d67c500 fffffa80`0d6957d0 fffffa80`0d67c500 fffffa80`0d67b1a0 : ataport!IdeDispatchChannelRequest+0xef
fffff880`009d99c0 fffff880`0127d336 : 00000000`00000001 fffffa80`153b5010 00000000`00000001 fffffa80`153b5010 : ataport!IdeStartChannelRequest+0x113
fffff880`009d9a40 fffff880`0127f59a : fffffa80`0d602901 00000000`00000000 fffffa80`0d6957d0 fffffa80`15414010 : ataport!IdeStartNextDeviceRequest+0x18e
fffff880`009d9ae0 fffff880`0127f104 : fffffa80`0d67b1a0 00000000`00000000 fffffa80`0d67b1a0 fffffa80`15414010 : ataport!IdeProcessCompletedRequests+0x26a
fffff880`009d9c10 fffff800`01ad28ec : fffff880`009c6180 00000054`7852a1fd fffffa80`0d67b050 fffffa80`0d67b118 : ataport!IdePortCompletionDpc+0x1a8
fffff880`009d9cd0 fffff800`01abfeca : fffff880`009c6180 fffff880`009d10c0 00000000`00000000 fffff880`0127ef5c : nt!KiRetireDpcList+0x1bc
fffff880`009d9d80 00000000`00000000 : fffff880`009da000 fffff880`009d4000 fffff880`009d9d40 00000000`00000000 : nt!KiIdleLoop+0x5a


STACK_COMMAND: kb

FOLLOWUP_IP:
PCIIDEX!BmSetup+6b
fffff880`0108e0d3 85c0 test eax,eax

SYMBOL_STACK_INDEX: b

SYMBOL_NAME: PCIIDEX!BmSetup+6b

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: PCIIDEX

IMAGE_NAME: PCIIDEX.SYS

DEBUG_FLR_IMAGE_TIMESTAMP: 4a5bc114

FAILURE_BUCKET_ID: X64_0xA_PCIIDEX!BmSetup+6b

BUCKET_ID: X64_0xA_PCIIDEX!BmSetup+6b

Followup: MachineOwner
---------



Please help I have tried several hot fixes but nothing seems to work

Thanks in advance!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Ok well I will have to wait until it crashes again to get a mini dump file I guess I tried the hotfix but it says not applicable to my system.

Thanks and let me know if you have any more ideas!
 

·
Registered
Joined
·
3,036 Posts
Recommendations:

Your crash primarily points to a hard drive related problem. This could mean hard disk corruption, bad sectors, a failing hard disk, Windows files or registry corruption, viruses, or memory problems.
  • If you are overclocking any hardware, please stop.

  • Run Disk Check with both boxes checked for all HDDs and with Automatically fix file system errors checked for all SSDs. Post back your logs for the checks after finding them using Event Viewer. In Event Viewer, expand Windows Logs, click Application to let it load, right click Application and click Find.... Search for chkdsk or wininit to find the logs.
    For any drives that do not give the message:
    Windows has checked the file system and found no problems​
    run disk check again as above. In other words, if it says:
    Windows has made corrections to the file system​
    after running the disk check, run the disk check again.

  • Run all Basic tests with SeaTools: S.M.A.R.T. Check, Short Drive Self Test, Drive Information, Short Generic, and Long Generic. Run the tests for all HDDs.
  • If you have an SSD, make sure the following are up to date:
    • SSD firmware
    • BIOS Version
    • Chipset Drivers
    • Hard disk controller drivers/SATA drivers
    • If you have a Marvell IDE ATA/ATAPI device, make sure the drivers are up to date from the Intel site or Marvell site and not from your motherboard/vendor support site.

  • Run a system file check to check Windows for corruption:
    1. Click Start Menu
    2. Click All Programs
    3. Click Accessories
    4. Right click Command Prompt
    5. Click Run as administrator
    6. Type
      Code:
      sfc /scannow
      and press Enter
    7. Once it is complete, make note of the message. If it says Windows Resource Protection did not find any integrity violations., restart your computer and post back
    8. If the message does not say Windows Resource Protection did not find any integrity violations., restart your computer and do steps 1-6 again.
    9. You may need to do steps 1-6 up to three times with a restart in between each run to resolve all corrupted files.
    10. If you still have corrupted files after a fourth run, post back here with the following:
      • Click Start Menu
      • Click Computer
      • Open your C: drive
      • Open Windows
      • Open Logs
      • Open CBS
      • Copy and paste CBS.log or CBS (it may not have the log extension) to a location you will remember.
      • Compress (zip) the CBS file and attach the .zip file to your next post.

  • Download and install Malwarebytes, update it, do not start the free trial, and then run a full scan. Also run a full scan with your antivirus software installed on your system. If you do not have antivirus software installed, I recommend: Make sure to update the security software before running the full scan.

  • Run Memtest86+ for at least 7-10 passes. It may take up to 22 passes to find errors. You should also run it once when the system has been on for a few hours and is warm, and then run it again once the system has been off for a few hours and is cold.

    Also, in case Memtest86+ misses anything and comes up with no errors, run the extended version of the Windows Memory Diagnostics Tool for at least five passes. You may want to run both Memtest86+ and the Windows Memory Diagnostics Tool overnight since they take a long time to complete (run them an hour before bed each of the next two nights and check before going to sleep that they are still running).


I also recommend you update/replace/remove the following drivers:

G200em.sys Thu Jan 29 11:44:50 2009 (4981F922)
Matrox G200e (ServerEngines) - English
http://www.carrona.org/drivers/driver.php?id=G200em.sys

G200ed.dll Thu Jan 29 11:44:50 2009 (4981F922)

G200ed.dll - this driver hasn't been added to the DRT as of this run. Please search Google/Bing for the driver if additional information is needed.

e1q62x64.sys Tue Jul 14 12:48:12 2009 (4A5CD2EC)
Intel Ethernet
http://www.carrona.org/drivers/driver.php?id=e1q62x64.sys


To update drivers, make sure to download the drivers from the manufacturer and not using 3rd party programs. Your drivers should be found from your motherboard support site (ASUS, Gigabyte, MSI, etc.) or your vendor support site (Dell, HP, Toshiba, Sony, etc.) first. If you have devices you bought yourself, the drivers for those devices need to be downloaded from the manufacturer support site for those devices. If you need help, let us know.

To remove drivers, do so by uninstalling the device or software associated with the driver. Devices can be uninstalled through device manager, and then the device itself should be physically removed from the system if possible.


3rd Party Drivers:
The following is for information purposes only. My recommendations were given above. The drivers that follow belong to software or devices that were not developed by Microsoft. Any drivers in red should be updated/replaced/removed. You can find links to the driver information and where to update the drivers in the section after the code box:
Code:
[font=lucida console]**************************Thu Oct 25 10:39:41.850 2012 (GMT-6)**************************
[COLOR=RED][B]G200em.sys         Thu Jan 29 11:44:50 2009 (4981F922)[/B][/COLOR]
[COLOR=RED][B]G200ed.dll         Thu Jan 29 11:44:50 2009 (4981F922)[/B][/COLOR]
intelppm.sys       Mon Jul 13 17:19:25 2009 (4A5BC0FD)
[COLOR=RED][B]e1q62x64.sys       Tue Jul 14 12:48:12 2009 (4A5CD2EC)[/B][/COLOR]
e1k62x64.sys       Wed Sep 23 18:11:00 2009 (4ABAB914)
avgrkx64.sys       Wed Feb 10 20:52:44 2010 (4B737F0C)
amdxata.sys        Fri Mar 19 10:18:18 2010 (4BA3A3CA)
avgldx64.sys       Thu Jun  3 15:06:48 2010 (4C081968)
avgmfx64.sys       Wed Aug 17 05:31:52 2011 (4E4BA6A8)
[/font]
http://www.carrona.org/drivers/driver.php?id=G200em.sys
G200ed.dll - this driver hasn't been added to the DRT as of this run. Please search Google/Bing for the driver if additional information is needed.
http://www.carrona.org/drivers/driver.php?id=intelppm.sys
http://www.carrona.org/drivers/driver.php?id=e1q62x64.sys
http://www.carrona.org/drivers/driver.php?id=e1k62x64.sys
http://www.carrona.org/drivers/driver.php?id=avgrkx64.sys
http://www.carrona.org/drivers/driver.php?id=amdxata.sys
http://www.carrona.org/drivers/driver.php?id=avgldx64.sys
http://www.carrona.org/drivers/driver.php?id=avgmfx64.sys



Analysis:
The following is for information purposes only. The following information contains the relevant information from the blue screen analysis:
Code:
[font=lucida console]**************************Thu Oct 25 10:39:41.850 2012 (GMT-6)**************************
Loading Dump File [C:\Documents and Settings\writh ziden\My Documents\BSODDmpFiles\jumperkyle\102512-60996-01.dmp]
Windows 7 Kernel Version 7601 (Service Pack 1) MP (8 procs) Free x64
Built by: [B]7601[/B].17944.amd64fre.win7sp1_gdr.120830-0333
System Uptime:[B]10 days 12:37:45.975[/B]
BugCheck Code: [B]BugCheck A, {fffff8801b59b000, 2, 0, fffff80001ad1040}[/B]
Probably caused by :[B]PCIIDEX.SYS ( PCIIDEX!BmSetup+6b )[/B]
BugCheck Info: [B]IRQL_NOT_LESS_OR_EQUAL (a)[/B]
Arguments: 
Arg1: fffff8801b59b000, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, bitfield :
	bit 0 : value 0 = read operation, 1 = write operation
	bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff80001ad1040, address which referenced memory
DEFAULT_BUCKET_ID:  DRIVER_FAULT_SERVER_MINIDUMP
BUGCHECK_STR:  0xA
PROCESS_NAME: [B]System[/B]
FAILURE_BUCKET_ID: [B]X64_0xA_PCIIDEX!BmSetup+6b[/B]
CPUID:        "Intel(R) Xeon(R) CPU           X3460  @ 2.80GHz"
MaxSpeed:     2800
CurrentSpeed: [B]2799[/B]
  Manufacturer                  Intel Corporation
  Product Name                  S3420GP
  BIOS Version                  S3420GP.86B.01.00.0022.072320091903
  BIOS Release Date             07/23/2009
¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨¨``
[/font]
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top