Tech Support banner

Status
Not open for further replies.
1 - 20 of 21 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
When I use Windows Media Player 10 to play a song file on my PC, no problem. When I use it to play a movie off the net, it stops responding altogether, and I have to reboot to get it to work on my song files. I read somewhere about reverting to Version 9 and I did that, but still have the same problem. Someone recommended "Light Alloy" but I can't get that to play movies on the net either.
Any advice on getting WMF to play movies off the net would be greatly appreciated? Thanks!
Rich
PS: I am running XP Professional on a Dell with Service Pack 2, 1GB RAM and a lot of HD space. I use Time Warner's Roadrunner broadband connection.
 

·
TSF Emeritus
Joined
·
26,228 Posts
K-Lite Codec Pack contains the latest codecs for all audio/video formats.
It also installs Media Player Classic which, if you set it up correctly, takes over from WMP/RealPlayer/QuickTime and plays streaming videos both in the browser and fullscreen.

Free download from www.free-codecs.com/download/K_Lite_Codec_Pack.htm
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
I couldn't find the "Quick Reply" referred to below so I hope you get this today.
Thank you, koala, for your reply. I'm not too experienced so I need a bit more help. (I've never heard of codecs, but reading about them at the link you provided gave me some insight.)

Should I reinstall WMP 10 over version 9 first before I download the codecs? I had 10 but when I got these problems online, I uninstalled it and it reverted to 9.

You said, "[K-Lite Codec Pack ] also installs Media Player Classic which, if you set it up correctly, takes over from WMP/RealPlayer/QuickTime etc."

If I just download and install K-Lite Codec Pack, is that "setting it up correctly" or is there more to it?

thanks again.
Rich
 

·
TSF Emeritus
Joined
·
26,228 Posts
Try it with WMP9 first. If it works, then you'll know it was just missing codecs. If you get the same problem with crashes, then open Media Player Classic and change the video file associations in the Options menu from WMP to MPC. This will make all videos, including streams, use MPC as the default player.

Which browser are you using? In Firefox go to Tools > Options > Downloads > File Types and change 'WMV files' to open with MPC using the 'Change Action' button.
 

·
TSF Emeritus
Joined
·
26,228 Posts
Media Player Classic, the Windows Media Player alternative I suggested.
Sorry, lazy typing :wink:
 

·
TSF Emeritus
Joined
·
26,228 Posts
Just one, they're both the same file but stored on different websites. I use the Full version but they're all free so take your pick. There should be a list of each version's features somewhere on the site.

EDIT: I hope this works for you and we're not barking up the wrong tree. :grin:
 

·
Registered
Joined
·
14 Posts
Discussion Starter #10
Well, I downloaded the codecs and installed them. It did not resolve the problem so I changed allthe file assocations in Media Player Classic to MPC and tried again. Now when I try to play an internet sample video, WMP opens and says "Downloading" but nothing happens. After that, WMP will not open anything, movie or song until I restart. MPC does not try to open the internet video at all, even though I checked all the file associations and rebooted. In MPC's Options, not only did I assign every file format to it, but I checked the box that says Autoplay (XPonly) Video, whatever that is. Now when I click on a sample video, say music video, instead of opening, it asks me if I want to download it, which I don't do.
Stumped.
Rich
 

·
Registered
Joined
·
14 Posts
Discussion Starter #11
In addition to my previous post, here is are samply movies that are a problem.

http://web.canon.jp/Imaging/pssd500/mov-e.html

We have a Canon Powershot and want to view these movies, but it now asks us if we want to download them versus just playing. This is happening on other sites with sample music videos, etc. The message asking if I want to download has the WMP icon on it.
R
 

·
TSF Emeritus
Joined
·
26,228 Posts
I went to the Canon link in Firefox, clicked the first video and it gave me the option of playing or saving. I clicked Play, chose Media Player Classic from the drop-down menu and after a few seconds it played fullscreen.

These are the settings I use...
MPC > Options > Player Formats > 'Video File ... Direct Show' enabled to allow streaming AVI files.
You can also enable Windows Media File (WMV) and MPEG Media File. Quicktime and Real Media are also optional if you visit sites that use these formats.

Did you disable the avi/wmv associations in WMP? Options > File Types

When your browser (IE or Firefox?) asks you if you want to download it, there should also be an option to play it and a drop-down menu of available players. You then click 'remember this setting' so next time you click on a video link it will play instead of trying to download.

Remember that if all this doesn't solve the original problem, you can easily uninstall and reinstall the Media Players without doing any harm.

Have you got ActiveX and javascript enabled in your browser and firewall?

EDIT: How to install the ActiveX plugin for Firefox
http://forums.mozillazine.org/viewtopic.php?t=206213
 

·
Registered
Joined
·
14 Posts
Discussion Starter #13
I'm sorry, I forgot to tell you I use IE, not Firefox.

I disabled the WMP's associations.

In MPC in Options>Player Format I have every option checked, including Video File..Direct Show, but I don't see anything about AVI files in there. Maybe you were just tagging that thought on there.

I'm going to try to send you two JPG's of my setup that I made using Print Screen.

I do believe I have ActiveX and javascript enabled in your browser but I'm not sure about the norton firewall. I just looked, the firewall is off. I'll have to change that later.

Now when I click on the Canon files, they open in an IE window as AVI files and I was asked if I wanted to restore Quicktime functionality. I said no. This is better than before but I'd rather they open in WMP or MPC. When they open, the blue icon, which I think IS quicktime, flashes. It plays as a box within a IE page as opposed to a full screen. I'm very happy it plays and you've had success here, but I wonder if we can get it to open to full screen without that wait for the download progress bar??
Rich
 

Attachments

·
TSF Emeritus
Joined
·
26,228 Posts
rich1234 said:
I don't see anything about AVI files in there. Maybe you were just tagging that thought on there.
It's there in your 2nd attachment image. 3rd up from the bottom, highlight it and look in the white box below to see the AVI format.

rich1234 said:
It plays as a box within a IE page as opposed to a full screen. ... I wonder if we can get it to open to full screen without that wait for the download progress bar?
If you right-click inside the video box it should give you the option of zooming 50/100/200% and fullscreen. The download progress bar shows the file is being loaded into memory or a temporary folder. Some videos do this and others use a buffer technique to stream in realtime.

I use Firefox rather than Internet Explorer (for security reasons mainly) but they handle streaming videos in pretty much the same way. See if this helps... open Internet Explorer and go to Tools > Internet Options > Multimedia and enable 'Play videos in web pages'

And in Media Player Classic, Options > Player > 'Launch files in fullscreen'

Good luck! :smile:
 

·
Registered
Joined
·
14 Posts
Discussion Starter #15
Well, since it was working, although not exactly the way I wanted, I switched back to WMP to see what would happen. It opened about 5 or 6 movie samples and then it quit. so I switched back to Classic and now everything opens in a Quicktime box within an IE page. I set the file format in Classic to open Quicktime and disabled Quicktime, no success--it still opens in IE as a Quicktime movie. With Classic everything opens in Quicktime. I did the things you suggestes such as

See if this helps... open Internet Explorer and go to Tools > Internet Options > Multimedia and enable 'Play videos in web pages'
And in Media Player Classic, Options > Player > 'Launch files in fullscreen'


You mentioned once that it is easy to unintall media players. I thought WMP was part of the operating system. If I can uninstall it, I may as well do that and download version 10 and start over. How do I uninstall it? I went to Control Panel>Add Remover Pgms>Add Remove Windows Components and I see it there but other things are checked also.Should I uncheck everything in there except WMP and hit "Next"?
R
 

·
Registered
Joined
·
14 Posts
Discussion Starter #16
WMP ugh and want to start over with new install

Koala, How do I uninstall Windows Media Player 9 so I can reinstall 10 and start over? I'm fed up with it as it is now.
Rich
 

·
Registered
Joined
·
14 Posts
Discussion Starter #18
Yes, but remember 10 did not work initially (same problem with web files) so I uninstalled to 9, and the problems continue. Wouldn't it be best to do a full uninstall then reinstall?

Also, I downloaded winamp thinking maybe it would work but I guess it's only for audio files because it does not open any internet movies.
I'm going to go eat, then check back here.
thanks!
Rich
 

·
TSF Emeritus
Joined
·
26,228 Posts
I'm starting to think it might not be the media players, but your browser settings. Plugins, ActiveX ? :4-dontkno

Winamp plays all media files, including streaming audio & video. I use it all the time. And I've also used WMP and MPC to play streams and web videos, both inside the webpage and fullscreen.

Hopefully someone else will jump in and help :wink:
 

·
Registered
Joined
·
14 Posts
Discussion Starter #20
Well, can I completely uninstall WMP and start over with a new clean install or is it part of the OS and completely uninstalling it is not possible?
R
 
1 - 20 of 21 Posts
Status
Not open for further replies.
Top