Tech Support Forum banner

Win7: issues updating, installing and running software

1174 Views 4 Replies 3 Participants Last post by  *WildChild*
There are a number of issues and I don't know where to start, so I'll go with the immediate and obvious problems. Bottom of the post will be the backstory to how this all started. The "read this" post made it seem ok to include screenshots, so I've uploaded and included shots (hosted at imageshack). If that isn't acceptable, please let me know


Problem #1
I am currently unable to install java updates. In the lower right corner I get an alert that there is a java update ready to install. I click on it, set it to download and install the update and not long after, I get the following:

This is for Java 6, update 20

Problem #2

Perhaps problem 1 is related to this. After some (stupid) changes I tried to make this morning (described below) I now am unable to run, or even turn on McAfee AV. I get a message in the lower right corner telling me that I have to solve 5 PC issues (2 important ones). The first two are McAfee and Windows Defender.

When I try to turn on McAfee, I am told that I can't.

Clicking on McAfee gives me the following error:

When I attempt to turn on Defender, I'm told that I need to check for new definitions, but the "Check for updates now" button isn't highlighted or clickable:

Now to the Backstory:

I have a 2 month old laptop with Windows 7 on it (built/purchased from Dell). There are two accounts on this system. My login, which has administrator privileges, and another account for my son. I didn't like that even on his account (non-admin) he could go into C:\users\mylogin and could access my files. So I wanted to 'protect' my documents, pictures, etc.

I went to C:\users\myloginID and right clicked to bring up properties. I went to the security tab and [edit] to change the permissions for my stuff. the group/usernames that I changed was "HomeUsers (systemname\HomeUsers) and changed the permissions to Deny for all of the options: full control, modify, read/execute, list file contents, read, etc.

In doing this, there were a few popups that said certain files/folders couldn't be changed. I figured no big deal, since MY account is an admin account. Once it was finished, all of my desktop shortcuts were gone. I couldn't see anything in my user directory. In order to even see my documents, my pictures, etc, I had to run as administrator. Even opening up single files, I had to do as administrator.

so of course, I'm thinking "what the hell?". I tried to do a system restore and couldn't find one. It's as if I don't have system backups set up, which I do. I tried to get on the internet and do a search for some info with Mozilla and it wouldn't come up. The only way I could bring up Mozilla is "run as admin" and when I do, the only thing I can do is click the "home" icon, which will take me to a Firefox Google search page. I can search from there, but the back button doesn't work. I can click, but can't go back. I found a page that said to go into control panel > system and security > restore your computer to an earlier time. In doing this, I did a restore from a week ago 7/11, the system initialized the restore, shutdown and rebooted. I thought all was well. Upon logging in to my account, I started seeing the following problems immediately after reboot:

(1) I get an error that comes up about Dell Docks installer is not functioning properly and I should uninstall and reinstall it. Never used it, don't have any clue what it is.

(2)Also, I get an error that says the following:

I have no idea what Softthinks Scheduler is.

I think that covers it. Web browsing was fixed after the restore, but these other problems still exist. Any additional info needed, please let me know. I'm sure I am forgetting something, but it's escaping me at the moment.

Any advice is greatly appreciated.
See less See more
Not open for further replies.
1 - 5 of 5 Posts
Hello Lynchsta,

Thank you for posting alot of info on your problem it really helped :).

For startes go here:

and click agree and start download.
I just did that. The installer seems to install fine, but once it tries to update/install update 21, I get a message that's basically the exact same thing as the update 20 screenshot from the first post

Clicking OK does nothing, which makes sense since the popup says the file is blocked
See less See more
OK. So on the surface this looks like a classic permissions issue. However, it could have also been just a coincidence that it coincided with the permissions change. It may also be infected. For now try starting in safe mode with networking. You can access this mode by pressing F8 repeatedly when your computer starts before the Windows boot sequence. Try logging into your account and downloading a Microsoft tool called SubInACL.exe. Since it is run from the command line there should not be a problem, however, I am not sure if you will be able to extract the .msi file locally so you may need to extract it on another computer and bring it over. Read this guide. Keep in mind there is a typo where they use the command "cdcd"... it should just be "cd". Also, cd C:\Program Files\Windows Resource Kits\Tools does not need quotations. If you move the reset.cmd file to anywhere but the folder containing the extracted SubInACL tool this will not work. If this fails we will need to do some more digging. Try downloading this tool and uploading the save file so I can do a quick check for suspicious items. We may also need to purge your signature files (don't do this yet) and rebuild them or try to build a new user account. The last ditch effort will be a full system recovery, luckily if Dell sent you a Win7 OEM disc all of your files will be backed up to a Windows.old folder. DO NOT USE A REGISTRY CLEANER.
See less See more
Also, we will check for group policies if all else fails.
1 - 5 of 5 Posts
Not open for further replies.