Tech Support Forum banner


1309 Views 11 Replies 4 Participants Last post by  JimE
I am using A4tech webcam, which suddenly now show black screen everytime i open my cam it was working fine but suddenly is shows now black screen. i m Using windows XP on dell inspiron E1705 laptop.
I have tried to reinstall the driver but nuthin works.
its a USB webcam that automatically install driver niether it shows any error in driver.
Someone told me that it might be problem with ur webcam embedded software please help.
Not open for further replies.
1 - 12 of 12 Posts
Test the webcam on another PC to ensure it isn't a cam issue.
its not working on another PC as well . i think its a prb with the firmware...can anyone suggest how to flash it ?
Why would you think it's firmware ??

I have never heard of a firmware upgrade for cameras. Did you try the manufacturers website ??
i read somewhr that there is certain code embeded in the camera which is responsible to create output..........i think prb is with that coz i have tried everything in order to make my camera work.....My camera shows black screen every diagnostic tools said dthat its working fine ..what cud be wrong plz suggest anything?
That they have dedicated processors is a fact and along with the processor there will be a firmware responsible for helping the processor communicate and transfer pictures or movies, save the data to memory etc. depending upon the processor type the firmware might be in non-volatile memory, written in read-only memory or even embedded in the processor.

In order to transfer the "new" firmware the processor and old firmware would have to be functional in order to access and communicate with the processor.

Just how communicative is the camera with any PC it is connected to.

A4 website here
i dont understand a single word u try to explain ...plz elobarate a little bit
webcam has processor
processor requires program to make it work.
program called firmware
firmware stored in memory.
memory can be independent integrated circuit device or part of processor.
memory area might be read only or be re-programmable.

to re-program (burn) the new data into a programmable memory location the old data must be functional and allow the processor to work properly.

I gave you the link to the a4 tech website (DOWNLOADS).
you can also contact them and ask if your webcam can be re-programmed.

please supply model number of your webcam in your next post
See less See more
some programs have an option to select which video and/or audio devices to use. I use a TV card which some programs see as an extra video input. check your (programs)options to see if the web cam is correctly selected
Model NO: PK 336E USB webcam. there is nuthin like that to update a firmware on A4tech website.
Secondly i have correctly chked that my webcam is selected.
One more thing, i have also read somewhr that USB Ports might creating a prb for the device....
I remmember a long time ago i had a prb wid my USB data traveller nd USB never recognizes it ...i read somewhr to uninstall usb drivers and unplug ur computer from the power for 2 hours nd den it works fine 4 me after reinstalling it again ....i tried the same thing at dis point but no sucess
i dont understand a single word u try to explain ...plz elobarate a little bit
What is prb ??? Can you please use properly spelt English or American words so that others can understand too. That includes me .. :laugh:

plz = please

note that I don't mind spelling mistakes but lazy use of language does not help me or you. :wave:
I highly doubt it's a "embedded webcam software"/firmware issue. Since it is not recognized/useable in two PC's, it would appear to be a faulty camera.

If you still insist it's a firmware issue, you will need two things. 1) A copy of the firmware or updated firmware from the manufacturer (don't ask me where...I've not seen any webcam firmware updates) 2) the webcam has to be recognized by the PC.
1 - 12 of 12 Posts
Not open for further replies.