Tech Support banner

Status
Not open for further replies.
1 - 16 of 16 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1 (Edited)
Edit: The GeForce 4 is a Chaintech, if that matters at all.. hehe..

Sorry I'm new here...posted in the wrong forum earlier. :\

Well let's see here.
It all started the other day when I exited out of a game (WarCraft III). All of a sudden there were Vertical lines through some of the screen (hard to explain, and they won't show up in screen shots...Which means it's probably the hardware right? :\)
I've tried reinstalling/removing/updating video drivers, chipset drivers, using system restore, and even reformatting. Nothing seems to fix the problem, and it's difficult to explain what it is exactly. Sometimes there's weird lines around the cursor, other times Win XP won't boot up at all. Because the screen goes black. I had to go in and try to fix things using Networked Safemode, but nothing seems to work. My guess is it's either the graphics card, the card's bios, something :\
Let's see, everything is really new, ordered off newegg.com. We already had to get replacement motherboard/cards because they were faulty/broken when we got the first ones. (Sorry if it seems like I'm rambling)

My comp specs:

80 GB Western Digital HD
Nvidia GeForce 4 Ti 4600
Asus A7N8X Deluxe MB
Nvidia Force 2 Chipset
AMD Athlon XP 2600+
Samtron 75E Monitor
Corsair XMS 2700 (512 DDR) with 2-3-3-6 MT's

I'm not sure what else to try. Maybe messing around with the Bios or Vid Card Bios a bit, but I don't really know what I'm doing. It seems to run fine in Safemode with 32 bit color, 16 only brings vertical lines.

Oh yeah, different modes (ie: resolution, color, etc.) affect how much clutter there is too. Like, lines all over the place, whatever. Seems to be best on 800x600 32 bit color, 16 bit makes it go to hell, or even shut off. So, device failure or what?

I basically can't boot up now without having this problem. Sometimes it doesn't boot up at all. Sometimes if I change a setting the comp reboots automatically. I've tried virus scans and all that, no flashed bios or video card bios... Any ideas? At the Moment I can't even get it to boot up without safemode, the screen just goes totally black after the windows loading screen, nothing happens, and I have to power down.
 

·
Registered
Joined
·
376 Posts
Check the settings in your system BIOS. I know Palette Snoop should be disabled with a card as new as yours. What other options are selectable for video in your system BIOS?

Go to your display properties to settings, and advanced. What is your refresh rate set at? What are your settings for your video card? Disable Enhanced CPU should be turned off.

Not sure what else to check, but if you tell us your settings, one of the big gurus might catch something that might be set wrong.
 

·
Registered
Joined
·
45 Posts
I once had a motherboard that had what is called a cold boot problem. It would only boot while warm .As long as I didnt turn it off it was fine. If it got too cold I had to put it outside in the sun for awhile(in miami back then) other than something faulty on it or the video card I would have to guess wildly at emi transmissions(is your system near any big power supplies or industrial machinery?). Or your system is not getting enough power because of bad supply to your house or too small a power supply on your computer.Or it may be overheating. If you built that system yourself its pretty much up to you to make sure its being cooled properly.Case fans on the back of it with ventilation on the front will draw air through the case and keep everything running smoother.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
I'm pretty sure Pallete Snoop is disabled by default, but I'll check all the settings and write em down. :\ Refresh rate should be hardware default since I'm running in safemode. Only way I can boot up normally and see what I'm doing is VGA mode...which is like 640x480 4 bit color...And for some reason there are 0 problems while running that..except that when I try changing any settings (res, color, refresh rate), the screen goes back to black and colored lines all over the place. I might try setting the refresh rate to the lowest setting in that mode..

I don't think it's a cold boot problem, because I never had any problems booting up for a month, and I can still boot up in certain modes...

ie: safemode and VGA mode - nothing else has worked, though when this all started I could still boot up normally, just with tons of vertical lines blocking every few inches of the screen.
I'll brb and post my settings.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5 (Edited)
Edit: I also tried updating the bios recently from Asus, didn't change anything.

Here goes.. I know some of these may be unnecessary to put on here but who cares. -_- (And Sorry, It's long.. =\)

(Btw ever since I booted up for the first time I get the "CPU Fan Failed error, but I've been told it's a common problem with A7N8X Deluxe Mobo's...The fans are all on, I can assure you. :))

BIOS:

P Master: HD
P Slave: None
S Master: CDRW
S Slave: None

(No Floppy Drive)


Advanced BIOS Features:

Boot virus detection - Disabled
CPU level 1 Cache - Enabled
CPU level 2 Cache - Enabled
Quick POST - Enabled
1st Boot Device - HDD-0
2nd Boot Device - CDROM
3rd Boot Device - Disabled
Boot up other Device - Enabled
Boot up floppy seek - Disabled
Boot up Numlock Status - On
Gate A20 Option - Fast
Typematic Rate Setting - Disabled
Apic Mode - Enabled
OS/2 Onboard Memory > 64 - Disabled
Full Screen Logo Show - Enabled
Speech POST reporter - Enabled
POST complete report - Enabled


Advanced Chipset Features:

CPU External Freq.: 166 Mhz
CPU Freq Multiple Setting - Auto (12.5x)
System Performance - User Defined
Cpu Interface - Optimal
Memory Freq. - 100%
Resulting Freq. - 166 Mhz
Memory Timing - User Defined (6-3-3-2T) (Had problems running certain programs until I changed these from default which was I think: 5-2-2-2T, maybe 4-2-2-2T, darn corsair memory incompatibilities >_<)
FSB Spread Spectrum - 0.5x
AGP Spread Spectrum - Disabled
CPU VCore Setting - Auto (1.650V)
Graphics Aperature size - 64 MB (Not sure if this should be 64...The card is a 128 MB, but my friend tells me you should put double the amount of the card, i've gone back and forth between 64 and 128, 64 being the default - which would be not listening to my friend's advice =P)
AGP Freq. - Auto
System Bios Cacheable - Disabled
Video Ram Cacheable - Disabled
DDR Reference Voltage - 2.6V
AGP VDDQ Voltage - 1.5V
AGP 8X support - Enabled
AGP Fast Write Capability - Enabled


Integrated Peripherals:

Primary VGA Bios - AGP VGA Card
USB Controllers - V1.1 + V2.0
USB Keyboard & Legacy Support - Disabled
USB Legacy Mouse Support - Disabled
Onboard AC97 Audio Controller - Enabled
Onboard AC97 Modem Controller - Enabled
Onboard Lan (nVIDIA) - Enabled
Onboard Lan (3com) - Enabled
Onboard 1394 Device - Enabled
Floppy Disk Access Controller - Disabled
Onboard Serial Port 1 - 3F8/IRQ4
Onboard Serial Port 2 - 2F8/IRQ3
UART2 use as - Com Port
Onboard Parallel Port - 378/IRQ7
Parallel Port Mode - ECP + EPP
Onboard Game Port - 201
Onboard midi I/O - 330
Onboard Midi IRQ - 10


PnP-PCI Configuration:

Resources controlled by - Auto(ESCD) (PCI IRQ Resources Exclusion)

PCI/VGA Pallete Snoop - Disabled
PCI Latency Timer (Clk) - 32 (Not sure what this is...And I don't recall seeing it any other time I've been in BIOS until this time...strange...might have been the bios upgrade)

Thanks ahead of time guys..
 

·
Registered
Joined
·
207 Posts
Aedak said:
It all started the other day when I exited out of a game (WarCraft III).
Have you checked the Blizzard site for errors of this type? Do you have the latest patch for WarCraft III? I ask this because you said that it started when you exited out of WarCraft III.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7 (Edited)
Yeah I had the latest patch, or I don't think it would let me on battle.net at all. I'll try blizzard's site, but since I've reformatted and everything I doubt it was the game. Though it's true I only started having these lines appear as I was exiting out the menu's in game. Then, they appeared on the desktop and kept me from watching anything in windows media player...Just got worse after I rebooted. :\
 

·
Registered
Joined
·
376 Posts
I'm having success with a GeForce4 Ti4200 128MB card on an Asus board, so perhaps my settings will help you.

I've got some stuff to try in the BIOS:

Disable Speech POST - I've read of others having troubles until they disable it. I disabled this at my system's first powerup.

Enable AGP Spread Spectrum - This is the default setting, which is what my BIOS is set at. This alone might correct the problem.

Graphics Aperature - 128

PCI Latency - Default is 64, although try this setting last.

AGP 8x Support - As a last reort, disable this. I believe your card is AGP x4.

Do you have an option to allocate an IRQ to PCI VGA?

I hope something here works...
 

·
Registered
Joined
·
16 Posts
Discussion Starter #9 (Edited)
IRQ to PCI VGA? I'm not sure but I'll go have a look. Seems I have no problems right now in VGA mode with no graphics acceleration, no write combining, 60 refresh rate on monitor, 640x480 and 8 bit color, though if I change anything I'm pretty sure it'll go crazy again. I'm not sure if this is supposed to happen, but I have no tab for Video when I use DxDiag (DirectX 8.1)

Oh, and I'm not sure much about this stuff, but maybe there's a problem with hardware Resources (Conflicts/Sharing). I don't know exactly how all that stuff works but there are a bunch (like 2-3 each) sharing I/O ports and IRQ's, as well as memory addresses. I don't know if they are supposed to or not. =P (I would imagine they are)

I also had a few times when this first started, soon after boot up the system would freeze. 15-20 seconds later it would be in 640x480 4bit color (black and white) with an error, windows recovered from a device failure, please save all work and reboot - something like that).
 

·
Registered
Joined
·
376 Posts
Try the other BIOS settings and let me know if they help.

Download and install DirectX 9.0b since this does improve and fix graphics issues:
DirectX 9.0b

In your hardware profile in Windows, are there conflicts listed? If another component is using the IRQ the graphics card is trying to use, and is creating a conflict, that's your problem right there! List all of your device conflicts, and what IRQ's they're trying to use. (IRQ sharing is fine and normal, but if that sharing causes a conflict, there are problems.)


Update -
I read up on some troubleshooting, and found these things to check:
- First and foremost make sure you have the latest drivers installed for both the card and the AGP controller. Remove any previous video drivers from your system including NVIDIA drivers first.
- If Video BIOS shadowing is enabled in your BIOS disable it.
- nVidia cards perform best when on IRQ 11 with no other devices sharing this IRQ. Check your system documentation for instructions on how to reassign IRQs.
- Check that ‘Assign IRQ to VGA' is set in your BIOS. If the card is sharing an IRQ with another device see above for correcting the situation.
- There are many factors that could be causing issues and most will probably require some input from the motherboard manufacturer. Among the settings that can affect this are: UC vs. USWC setting for the video BIOS, device sharing the same IRQ as the AGP card, I/O voltage, AGP – aperture, driving control value, 2X/4X setting, and AGP fast writes. Each motherboard will react differently to adjusting these settings, therefore we suggest you seek the advice of the manufacturer before changing from the defaults. In rare cases it may be necessary to format your hard and re-install everything.


(My guess is that you've got another device hogging the IRQ your AGP card is trying to use.)
 

·
Registered
Joined
·
16 Posts
Discussion Starter #11 (Edited)
I tried Enabling the AGP Spectrum, I think the default and only setting was .5% or .5x, something like that..
Changed graphics aperature to 128. Neither of these had any effect.

Oh yeah, when I boot up, things like BIOS and the Boot menu (F8) Don't show these vertical lines, Post screen, logo screen, and windows load do however. But, once I choose Safemode it Goes to User Select and everything looks fine as long as I run in 32 bit color...changing to 16 bit makes a ton of vertical lines appear. I don't know if this info makes any difference..

I didn't see anything regarding PCI Latency
Changed the AGP 8x Support to disabled, still no effect.

I think what you mentioned, Allocating IRQ to PCI VGA has something to do with the PnP-PCI Config, where it says Manual or Auto, manual lets you reserve IRQ's for whatever, but they're all already reserved (obviously)

With auto checked, it has:

x PCI IRQ Resources Exclusion (in grey)

Edit: Installing DirectX 9.1 didn't help. May be since I'm running in VGA mode, but if that's the case I don't know how to get windows to boot up normally without minimum settings for res, color, and refresh rates..Anyone know of a program that lets you reboot with certain settings like this?
 

·
Registered
Joined
·
376 Posts
I edited my previous post with new information.

Are you able to reserve IRQ 11 for the AGP card, and not allow anything else to use that IRQ?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #13 (Edited)
I'm gonna check all the IRQ's first (and edit them in here later), (btw 11 is missing, I believe it shows when I boot in safemode, but I'm running VGA mode now, which is probably why I can't find video in DirectX or here on the System Info..I don't see any conflicts, but it doesn't say which is sharing with which, or which is conflicting with which. It just shows the Ports, IRQ's, or memory addresses that are occupied by more than one. After I check these, I'll boot up in safemode and see what's in 11.

ok:

I/O port 0x00000000-0x00000CF7 - PCI Bus
I/O port 0x00000000-0x00000CF7 - DMA Controller

I/O port 0x000003C0-0x000003DF - NVidia Nforce2 AGP Host to PCI Bridge
I/O port 0x000003C0-0x000003DF - Nvidia GeForce4 Ti4600

IRQ 20 - Standard OpenHCD USB Host Controller
IRQ 20 - Nvidia(R) NForce(TM) MCP Audio Processing Unit (Dolby Digital)

IRQ 21 - Standard Enhanced PCI to USB Host Controller
IRQ 21 - Nvidia(R) NForce(TM) Audio Codec Interface
IRQ 21 - OHCI Compliant IEEE 1394 Host Controller

Memory Address 0xD8000000-0xE7FFFFFF - Nvidia nForce2 AGP Host to PCI Bridge
Memory Address 0xD8000000-0xE7FFFFFF - Nvidia GeForce2 Ti4600

Memory Address 0xE8000000-0xE9FFFFFF - Nvidia nForce2 AGP Host to PCI Bridge
Memory Address 0xE8000000-0xE9FFFFFF - Nvidia GeForce2 Ti4600

IRQ 22 - Standard OpenHCD USB Controller
IRQ 22 - Nvidia Nforce MCP Networking Controller

Memory Address 0xA0000-0xBFFFF - PCI Bus
Memory Address 0xA0000-0xBFFFF - Nvidia nForce2 AGP Host to PCI Bridge
Memory Address 0xA0000-0xBFFFF - Nvidia GeForce2 Ti4600

I/O Port 0x000003B0-0x000003BB - Nvidia nForce2 AGP Host to PCI Bridge
I/O Port 0x000003B0-0x000003BB - Nvidia GeForce2 Ti4600


Ok, Now in VGA mode somethings may be changed, I'm not sure, I'll reboot in safemode and see if they match up or whatever.
But these are missing from the IRQ Resource List:

IRQ 2
IRQ 6
IRQ 7
IRQ 11
IRQ 16
IRQ 17
IRQ 18

Then these IRQ's have more than one (Obviously since they were shared or conflicted as posted above):

IRQ 20: there's 2
IRQ 21: there's 3
IRQ 22: there's 2

I'm not gonna post all the memory resources and I/O's for every device, no point and there's too much to type out. :\

Under DMA Resource theres:

Channel 3: ECP Printer Port
Channel 4: DMA Controller

No channel 1-2, I dunno.. Heh

--------------------------------------------------

Tried in Safemode:

Now there's VgaSave instead of Nvidia GeForce4 Ti 4600 for these (I'm guessing it's because safemode uses it's own drivers or whatever instead of using the graphics card for resolution and all that):

I/O port 0x000003C0-0x000003DF
I/O Port 0x000003B0-0x000003BB
Memory Address 0xA0000-0xBFFFF

Those were previously shared of conflicting with the others if you scroll back up.
ie: now says
Memory Address 0xA0000-0xBFFFF - Vgasave (not Nvidia GeForce4 Ti 4600)

Also now

IRQ 5 has 3 devices using it:

OHCI Compliant IEEE 1394 Host Controller
Nvidia nForce PCI System Management
Nvidia(R) nForce(TM) Audio Codec Interface

So the OHCI one moved from 21 to 5, I have no idea what that means.

IRQ 11 has:

Nvidia(R) NForce(TM) MCP Audio Processing Unit (Dolby Digital)
Nvidia GeForce4 Ti 4600

So..I don't know what all of this means or if it's normal, but there are 2 sharing IRQ 11.

I'm not sure if I can reserve it just for the card because I really don't know how to do it, but it looks like it's shared with the nForce chipset's audio junk (Again this is in safemode So I dunno..

Edit: I'm also hesitant to try removing the card and putting another in. I have a spare Radeon 32 MB, but it's really old and PCI, I don't want to risk screwing up the Mobo or anything :| What do you guys think?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #14
If I can't find a solution by tomorrow I'm gonna try another graphics card to see if it works, and then maybe try clearing the CMOS and starting over from scratch.
 

·
Registered
Joined
·
45 Posts
My suggestion in the form of a question is this. Do you want a system that is so supersensitive that you have to find one perfect setting in order to get it to run at all? Obviously the answer is no. Start returning parts.
 

·
Registered
Joined
·
376 Posts
Disable the onboard audio in BIOS and see if that helps at all. I know this won't be a permanent solution, but it will show if that IRQ sharing is causing the problem.

If you have the latest BIOS and have at least a 350W power supply, I'm stumped otherwise.
 
1 - 16 of 16 Posts
Status
Not open for further replies.
Top