Tech Support banner

Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
HI,

I am not an ace in writing VBS script but need some help with a script I am using to run another .vbe script as an Admin.The problem comes when I am running the first script which is grc.vbe (I have encryped all the vbs files)
The grc.vbe at times gets stuck on WshShell.AppActivate "C:\WINDOWS\System32\runas.exe"
A cmd opens with heading as C:\WINDOWS\System32\runas.exe and then waits for the helpdesk password to be putin.The helpdesk password I am using is right.But still it reamins on enter helpdesk password.At times it takes in the password automcatically and at time it will be stuck till I enter the password manually.Please can you help me with this or maybe suggest a better script since I am not sure what I am using is the best way to do it.


grc.vbe
=================================
set WshShell = CreateObject("WScript.Shell")
set WshNetwork = CreateObject("WScript.Network")
WshShell.Run "runas /profile /user:" + WshNetwork.computername + "\helpdesk cmd",7
WScript.Sleep 2000
WshShell.AppActivate "C:\WINDOWS\System32\runas.exe"
WScript.Sleep 3000
WshShell.SendKeys "password"
WshShell.SendKeys "{ENTER}"
WScript.Sleep 3000
WshShell.AppActivate "cmd( running as" + WshNetwork.computername + "\helpdesk )"
WScript.Sleep 3000
WshShell.SendKeys "Cd \"
WshShell.SendKeys "{ENTER}"
'WScript.Sleep 1000
WshShell.SendKeys "GCL_31\31Admin.vbe"
WshShell.SendKeys "{ENTER}"
WScript.Sleep 1000
WshShell.SendKeys "exit~"


The other problem I have is again with the 31Admin.vbe which also has the same problem as seen above, the cmd window remains frozen on enter helpdesk password.Once I enter the password manually alls well.Please can you let me know what changes I can make so that the password will be taken automcatically all times and the unpredictability of the code is reduced to zero


set WshShell = CreateObject("WScript.Shell")
set WshNetwork = CreateObject("WScript.Network")
Set WshSysEnv = WshShell.Environment("PROCESS")
Const CDROM = 4
Dim FSO, DR, DrvLetter, f1, f2, f3, Dpoint, tsout, UserFile
Set FSO = WScript.CreateObject("Scripting.FileSystemObject")
Set DR = fso.Drives
For Each i in DR
Select Case i.DriveType
Case CDROM
DrvLetter = i.DriveLetter & ":"
End Select
Next

'==============================================================
' SETTING THE INSTALL POINT
'==============================================================
'Set the DPOINT varible for the Installation
Dpoint = "C:\GCL_31" 'Use if installing from CDROM
'WshNetwork.MapNetworkDrive "Z:", "\\10.120.1.9\gcl3.1\AdminMode" ,"false" ,"xyz" ,"password"
'Dpoint = "" 'Use if Installing from Network

'==============================================================
' SETTING THE HELPDESK PASSWORD
'==============================================================
WshSysEnv("DISK")=Dpoint
'***CHANGE THE HELPDESK PASSWORD HERE***
WshSysEnv("PW")="password"
WshSysEnv("ADMIN")="YES"

WshShell.Run "runas /profile /env /user:"+ WshNetwork.computername +"\Helpdesk ""%DISK%\APPINST.exe %DISK%\31Update.XML %DISK% $DPOINT= " & Dpoint, 7
WshShell.AppActivate "C:\WINDOWS\System32\runas.exe"
Wscript.sleep 5000
WshShell.SendKeys WshSysEnv("PW")
Wscript.sleep 5000
WshShell.SendKeys "{ENTER}"
Wscript.Quit
 

·
Registered
Joined
·
12 Posts
humm...

i think i know what is wrong.

in both cases you declare the WshShell by using this:
set WshShell = CreateObject("WScript.Shell")

However it seems that you forgot to add WScript in front of it, like i do:
set WshShell = WScript.CreateObject("WScript.Shell")

Try this and let me know how it works :smile:
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top