Tech Support banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter · #1 ·
I'm having horrible problems getting a working windows machine running. I had about 180gb of extremely important files on a seperate partion of a 298gb atapi hard drive, and I tried reinstalling windows on a smaller partition of the same drive. at the partition selection screen, the only option it gave me was to repartition the (already ntfs) partition as ntfs, so I did that, and it rebooted and when it (almost) came back up, I found out that it had wiped out every partition on the entire drive, so that it was just 298gb of unallocated space.
The only free partition revocery software I could find and use other than testdisk for linux is a program that has to be run from windows,
I tried using testdisk on the PartedMagic CD I use to recover the lost partition, and it saw everything but my important 180gb partition, so it was useless to me. Since then, I've tried installing windows on at least a handful of physical hard drives, and on every one of them, the windows xp installation starts fine, and gets up to the first time where it's supposed to reboot, and when it does reboot, it says:

Disk error
press any key to restart

I know it's not a problem with a single hard drive or (probably not) a hard drive controller, since as I said before, I've used a handful of physical hard drives, all with the same effect. Also, I can install a working installation of Ubuntu Linux 7.04 on them, and it boots from the hard drive just fine, which seems odd to me.
Any help at all is greatly appreciated, because I can't really afford to buy another desktop just to get a working windows installation to recover that partition with.
 

·
Premium Member
Joined
·
78,002 Posts
have you disconnected the other h/d whilst you install
the inicial load goes into ram and it hands over to the hard drive on the first reboot
check the jumpers are correct on the drive,with it the only one in set it as master
clear it first with dban
http://www.snapfiles.com/get/dban.html
then do the format and install
 

·
Premium Member
Joined
·
78,002 Posts
try a new 80 wire ide cable
it's the linux running that throws a spanner in the works if it can find the drive so should windows
dban found it also i assume
 

·
Registered
Joined
·
23,001 Posts
Disconnect all USB devices (except for keyboard/mouse) and any card reader you may have.
Disable integrated Ethernet (LAN) and audio in BIOS- you can enable them again when Windows is installed.
What motherboard do you have?
 

·
Registered
Joined
·
72 Posts
Discussion Starter · #6 ·
I found the problem. I don't know how it made any difference, but when I formatted with PartedMagic, it didn't work. Then in the windows installation, I tried the option to do a quick format to ntfs (or fat), and somehow that made it work. thanks for the help though.
 

·
Premium Member
Joined
·
78,002 Posts
Re: [SOLVED] urgent hard drive/windows installation/partition recovery problem

pm is showing it's age
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top