Tech Support Forum banner

Unresponsive file?

705 Views 0 Replies 1 Participant Last post by  Lebanza
I've run into an issue while trying to play Titan Quest: Immortal Throne (a legit copy, purchased on Steam) on my laptop. It's an HP Pavilion, Intel CORE i3, Windows 7 Home x64, 4 gb RAM, Intel 4600 graphics card.

I can play the vanilla Titan Quest with no issues. Both the vanilla game and Immortal Throne run fine performance wise at the settings I have, the only framerate stutters occur near cave entrances, going through portals or when dying, which I've read is normal for systems running Vista or later. For whatever it is worth, I have all the settings for both games set to maximum, except set to play windowed at 1366x768. I have not altered the game to run on multiple cores, and there are no weird mods installed.

After playing Immortal Throne anywhere from 2 minutes to an hour (usually only around 20 minutes though), the game goes "not responding." There is no obvious "trigger" that causes it, it has happened while speaking with merchants, fighting monsters, running around in town, looking through the skill trees, and so on. I have tried waiting for the game but it never comes back, so I just close the program.

When I start the game up again, it loads the main menu just fine. I can fiddle with the options and use the other menu items, but as soon as I click either "Play Titan Quest" or "Play Custom Quest" (where the game would then display a list of your save games), it immediately goes "not responding" again.

If I restart the computer, it will allow me to play again for another 2 minutes to an hour before it does the exact same thing.

I decided I was going to poke around at the save files based on my suspicion that it was having trouble loading them which was causing the problem. I attempted to copy the save game folder so I had a backup, but the little copy progress pop-up got stuck on "Discovering items" with the time remaining, items remaining, and speed all displaying "calculating" and never changed. Clicking the "cancel" button just left it sitting there saying "canceling" as the progress bar was moving but nothing happens. Attempts to delete the save game folder result in the same thing. After a restart, I was able to copy the save games out and continue.

I opened the folder and began deleting pieces out of it to try to isolate the problem file. In the save game folder, there is a folder for each character, and in each character's folder there is a file called "Player.chr" and any attempt to do anything with this file causes Windows Explorer to go "not responding" after the game has previously gone "not responding." If I restart my computer, I can mess with the "Player.chr" file as you would normally be able to (copy, move, delete, so on).

After the game goes "not responding" and the save file becomes unresponsive, I have not found any other issues or strange occurrences with any programs or files on the computer, it seems to be isolated to that file.

Things I have tried:
-Patching the game to the unofficial patch (no change)
-Deleting the save altogether and starting new with a different character of a different sex with a different name and skills (no change)
-Verify integrity of the files with Steam, twice (no problems found, no change)
-Uninstalling and reinstalling the game (no change)
-Using the "Unlocker" program I already had installed on the unresponsive "Player.chr" (program finds no issue with the file, but attempting to delete it using the program causes the program to go "not responding")

I've basically used up my computer knowledge here, and internet searches have just brought me to things that are only vaguely similar because the search terms are nearly the same.

Any suggestions or help would be greatly appreciated. I've got friends playing it currently and telling me how good it is so this is quite frustrating.
See less See more
Not open for further replies.
1 - 1 of 1 Posts
1 - 1 of 1 Posts
Not open for further replies.