Tech Support banner

Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I have an ASUS P5GDC Deluxe with a p4 550

In device manager i have an unrecognised PCI device listed, i've tried everything to find out what it is, i downloaded a pci scanner which has told me that it's an unknown device form ASUSTeK Computer Inc and it says it's an unknown chipset from intel corporation, i visited the intel site and downloaded the files for the intel 915 express chipset family which it said i have and it pretty much stopped everything frrom working, and the unknown device was still listed.

if anyone has any ideas i that would be great. cheers
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
it seems to be the same as an other program i tried, just tells me it's a PCI device, Chipset - intel corporation, OEM - ASUSTeK computer inc.

I've tried downloading the right drivers for my chipset just caused loads of problems and didn't work, any other ideas would be great.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
yeah those are the drivers i downloaded but didn't solve the problem, in fact caused ethernet and usb ports to stop working! any thoughts would be greatly appreciated.
 
P

·
Guest
Joined
·
0 Posts
can you do a " rollback driver " for the drivers which are not functioning ? the option is locted under device manager - right click on the driver - properties - driver tab - rollback driver. Lets see if it restores your ethernet and usbs.
** and when everything is working besides the unknown device please create a system restore point.

edit: Did you download your drivers from this list ? http://support.intel.com/support/chipsets/sb/CS-009247.htm
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
i managed to get everything working again but still have this unknown device, yeah thats where i downloaded the drivers from, the chipset identifier says that it's a part of the intel 915 express chipset family and i downloaded the right drivers according to them but didn't work, really has got me baffled!
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
ok i used the regedit to find out what it is, says its the intel high definition audio controller, vendor ID - 8086 and device ID - 2668, but can't seem to find any drivers for it, been googling but no luck.
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top