Tech Support banner

Status
Not open for further replies.
1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hello, I am having difficulty reinstalling Warcraft III Reign of Chaos. I uninstalled both ROC and it's expansion to fix a patch error that reported the issue was resolved through reinstallation. However, I am now unable to install ROC. After choosing the directory, I receive the following error message:

"Unable to save uninstall data file. Installation cancelled."

When I first got this game, It installed and ran perfectly, so I have no idea what this error is or how to resolve it. If anyone can help me it would be much appreciated. Thank you.
 

·
TSF Emeritus
Joined
·
26,228 Posts
Was it an official patch? Did you uninstall the expansion before uninstalling the game? Try reinstalling to a different directory.

Hang on a bit longer and you'll get some more replies, hopefully.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 · (Edited)
I should hope the patch was official, I got it straight from Blizzard's official website. I've also tried installing it to different directories, and I still get the same message. I even tried preforming a system restore to a point before all this nonsense, and still no dice. The game will install fine on other machines, so I know that the disc is not damaged. I have looked all over the web for any information regarding this type of error, but can find nothing. However, one thing that I did fail to mention is that I uninstalled the game using "Add/Remove programs" all at once rather than just the expansion through the start menu. When I did this, I received an error message stating that the uninstallation failed. However, all files pretaining to the game were gone from the computer. Obviously, the game was no longer installed. Thus, placing me in this predicament. I've tried everything, and even Blizzard's own technical support was not very cooperative. (They just e-mailed me a list of common installation issues.) So basically, this forum is my last hope. If no one here can help me, then I fear I will simply have to live without Warcraft until I get a new computer...
 

·
TSF Emeritus
Joined
·
26,228 Posts
It sounds like the failed uninstall of the expansion has left some entries in the registry that are preventing you from reinstalling. System Restore didn't work, which was going to be my next suggestion. I know it's unlikely, but can you install the expansion without the game, and then uninstall it properly?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Yeah, that's what I thought too. However, I went through the computer and manually deleted all the Warcraft III registry keys I could find, and I still get the same message. The only files related to the game that remain on the computer are some save files from the game, but for some reason I am unable to delete these. When I attempt to, I receive an error specifying that the files were unable to be deleted because they can't be found. (Probably because the game is no longer installed.) So either I missed something in the registry editor, or I need to delete those files. As for installing just the expansion, I tried that too, but it still requires the original game. This problem is seriously starting to get to me...
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #7 ·
One thing I would like to add. The only things I can find in the registry that may be of WC III are the following: .W3m- WorldEdit.Scenario, .W3n-WorldEdit.Campaign, .W3x.ScenarioEX. Also, a battle.net file containing the key: exodus.battle.net. I am not entirely sure if these are directly related to WC III and should be deleted. If anybody knows that these may be the reason I am unable to install the game, then please let me know. (I'm asking first before I delete them because messing around with the registry makes me nervous.)
 

·
TSF Emeritus
Joined
·
26,228 Posts
When you're messing with the registry, if you're not sure what something is, it's best to leave it alone. And make a backup/export before making any changes.

Have a look through the Warcraft forums. I saw one yesterday that mentioned uninstall problems. They might be able to give you some more advice.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 ·
I give up. I've tried evreything I can think, followed all advice I received, and the stupid game just won't install. Thank you for your support anyway, I appreciate the fact that you at least tried to help me.
 

·
Registered
Joined
·
1 Posts
I never had this error on my original copy but I lost it and bought the battlechest. I got the same error as you, tried most of the same things...Now I've gotten a differant error about not being able to find one of the movies, but it all seems to point to the cd not being readable...Tried it on several differant cd-roms. I will post here if I find a solution.:4-dontkno
 

·
Registered
Joined
·
1 Posts
your problems are solved :wave:

hi, ive had this problem for days but found a solution. i did all what u said.

ok what you need to do is remove all the world edit folders and eveything like that. it's safe to do, so once you done that click on start then find windows search. click on it. once its open type war3 and click search.

once the search is done there will be files. delete them to the recycle bin. now make sure the warcraft 3 cd is in the computer. if autoplay comes up, exit it.

now you're ready for the finishing part. disable your intenet connection, pull out the power of the intenet, turn off your computer, wait 2 minutes, turn computer back on, keep tapping the f8 key when there's a blank screen. now you will see safe mode. go in that, the computer will start up in safe mode.

now, once the computer started up, install the game. that way it will work perfectly and smoothly. once the game is installed, shut down the computer and turn it on like you normally do, then wc3 will be installed.

see SEE its on the computer HURRAYY!! start playing and be a nerd. bye now and have fun :wave:
 
1 - 11 of 11 Posts
Status
Not open for further replies.
Top