Tech Support Forum banner
Not open for further replies.
1 - 11 of 11 Posts

· Registered
239 Posts
Discussion Starter · #1 · (Edited)
I am unable to connect to the Internet. My modem/router is working fine as other machines in house are able to connect. I have run MalwareBytes, SuperAntiSpyware, MSE, Avast free ver, and all have found different infections and removed them. I did this from a different system. The problem persists. It seems that there are some services that are not starting. DHCP Client, and all the Diagnostic services. The error message after attempting to do Diagnostics on Connection problems is Access Denied. I am unable to start any of the above forementioned services manually either, same error message. I have tried ipconfig /release and /renew and /flushdns. Also have tried ipconfig /regiesterdns error message that there is not enough storage. I have run sfc /scannow and it found no problems. I have uninstalled network adapters, rebooted, and reinstalled and still no joy. I have tried netsh int ip reset and netsh winsock reset. System is a Dell Laptop with Win 7 HP 64 bit. I have reached the end of all I can find on Google concerning these issues, all/any suggestions and guidance is MUCH APPRECIATED as always!!
PS. It affects ethernet connection as well as wireless.


· Registered
548 Posts
Network Services Dependencies
Check that all your network services are Started:
  • COM+ Event System (for WZC issues)
  • Computer Browser
  • DHCP Client
  • DNS Client
  • Network Connections
  • Network Location Awareness
  • Remote Procedure Call (RPC)
  • Server
  • TCP/IP Netbios helper
  • Wireless Zero Configuration ( XP wireless configurations only)
  • WLAN AutoConfig ( Vista wireless configurations only)
  • Workstation

Note: You can check the services in Control Panel, Administrative Tools, Services.

All of these services should be started, and their startup type should be automatic (or perhaps manual).

If a service is not running, open it's properties and check the dependencies. Check each of the dependencies and see which one is preventing the service from running.

· Registered
TSF Emeritus
20,493 Posts
Some options for you:

1. Start up Repair
2. Restore to the factory default thru a backup Image (if available).
3. Clean Install
4. We can refer you to our Security Experts, it looks like there are virus/malware remnants in your computer that need to be completely removed.

If you choose to get assistance from our Security Team please follow the instructions here prior to Posting:

Create a New Thread and upload the files here: Virus/Trojan/Spyware Help - Tech Support Forum

A Security Expert will be assisting you to cleanup the infections. Be very patient bec. they are extremely busy.
1 - 11 of 11 Posts
Not open for further replies.