Tech Support banner

Status
Not open for further replies.
1 - 20 of 25 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
Unable to connect to internet following use of "last known good configuration"

Hello,

About three weeks ago, I built a desktop PC and it ran fine for about a week and a half, but then it would sometimes not start and go into "startup repair", which never succeeded in actually finding a solution. The cause of this was a blue screen error which reported the following:

STOP: c000021a
The Windows Subsystem System process terminated unexpectedly with a status of 0x
The system has been shut down.

This would occur perhaps a third of the time after powering the system on. In order to try and stop this, I opened Windows with "last known good configuration". The computer now does not find any internet connections, even though it is connected via ethernet as before.

How can I fix this issue? Any help is appreciated.

(I do not know if the startup repair issue is fixed, either)
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
Re: Unable to connect to internet following use of "last known good configuration"

I used the /scannow run and it removed a corrupt Windows file and suggested I reboot; I did, and the connection still does not work.

In the Device Manager, the one device under network adapters is "Realtek PCIe GBE Family Controller", and it has a yellow "!" on it, the description denoting that the drivers are unable to be read. When I select "update drivers", it tells me they are up to date, which I imagine could be because there is no internet connection. I also used my Motherboard software disc to try to repair the LAN drivers and that did not help.

Under "other devices" there is an unknown device which also has a yellow "!", explaining that drivers for it are not installed.
 

·
Microsoft-Team Manager , Hardware - Team Manager
Joined
·
68,686 Posts
Re: Unable to connect to internet following use of "last known good configuration"

Hi you will need to go to the maker of your computer or motherboards support site for your model and download the driver to either update or reinstall
 

·
Registered
Joined
·
34 Posts
Discussion Starter #5
Re: Unable to connect to internet following use of "last known good configuration"

I just finished reinstalling all drivers from the website and rebooting, and the computer still will not connect.
 

·
Microsoft-Team Manager , Hardware - Team Manager
Joined
·
68,686 Posts
Re: Unable to connect to internet following use of "last known good configuration"

Hi check device manager again,what order are you installing the drivers in
 

·
Registered
Joined
·
34 Posts
Discussion Starter #7
Re: Unable to connect to internet following use of "last known good configuration"

Device manager remains unchanged; that is, yellow exclamation point under network adapters on "Realtek PCIe GBE Family Controller" and under "other devices" on "unknown device".

I installed as follows (all are for Win7):
SATA3 driver
INF driver
USB driver
LAN driver
Intel Management Engine driver
Rapid Storage driver
Realtek sound driver

All for ASRock H77 Pro4/MVP Mobo.
 

·
Microsoft-Team Manager , Hardware - Team Manager
Joined
·
68,686 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #9
Re: Unable to connect to internet following use of "last known good configuration"

The download link on that page led me to a 404 error, but I found a similar driver on Realtek's website; going to give that a try now.
 

·
Microsoft-Team Manager , Hardware - Team Manager
Joined
·
68,686 Posts
Re: Unable to connect to internet following use of "last known good configuration"

Yeah I did out in a edit
 

·
Registered
Joined
·
34 Posts
Discussion Starter #11
Re: Unable to connect to internet following use of "last known good configuration"

The one I found did not work ("Windows encountered a problem installing the device software for your device"), I tried it again and then it told me that the device had the best driver already.

I tried the driver from your second link and it also only told me that I already had the best driver.
 

·
Moderator , - Microsoft Support
Joined
·
7,737 Posts
Re: Unable to connect to internet following use of "last known good configuration"

Hi, you will need to follow joe's advice and get those drivers installed without them you will get no internet. When you do, a little known consequence of repairing the registry (running "last known good ") is the possibility that winsock registry parameters get changed.

So when device manager gives you the all clear on the drivers, go to start search and type:- cmd, right click on the returned cmd.exe and select "run as administrator" at the prompt type:-

Code:
netsh winsock reset catalog
press enter (resets winsock entries)
Code:
netsh int ip reset reset.log
press enter (resets TCP/IP stack)

Cmd's take immediately, sometimes you need to recreate your ISP account although this is rare.

EDIT:- I see we just cross posted could you from a cmd (as admin) type:-

systeminfo > 1 & notepad 1 press enter right at the end is details about your network card we need that, you can delete all the windows updates and please post the rest.
 

·
Microsoft-Team Manager , Hardware - Team Manager
Joined
·
68,686 Posts
Re: Unable to connect to internet following use of "last known good configuration"

Realtek site is all I can suggest at this point Realtek
 

·
Registered
Joined
·
34 Posts
Discussion Starter #14
Re: Unable to connect to internet following use of "last known good configuration"

Alright, I will try there. Thank you for your time, I apologize for the hassle.
 

·
Microsoft-Team Manager , Hardware - Team Manager
Joined
·
68,686 Posts
Re: Unable to connect to internet following use of "last known good configuration"

No hassle it is sometimes a fight to get things to behave lol
 

·
Registered
Joined
·
34 Posts
Discussion Starter #16
Re: Unable to connect to internet following use of "last known good configuration"

EDIT:- I see we just cross posted could you from a cmd (as admin) type:-

systeminfo > 1 & notepad 1 press enter right at the end is details about your network card we need that, you can delete all the windows updates and please post the rest.
I just tried this and in the notepad file, the Network Card(s) section reads: N/A. Nothing else comes after.
 

·
Moderator , - Microsoft Support
Joined
·
7,737 Posts
Re: Unable to connect to internet following use of "last known good configuration"

Hi, it was the info from the start all about your system we need. In device manager right click on your network card and select properties, select the details tab under property you will see "device description" then under Value what does it say (you can highlight the value) and right click select copy. Post here, also if you expand the arrow under property a whole host of info about the device is shown look for driver assembly version what value does it return.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #18
Re: Unable to connect to internet following use of "last known good configuration"

The device description is "Realtek PCIe GBE Family Controller". The driver assembly says "7.61.612.2012".

Here's everything from that command prompt:

Host Name: UKOIL-PC
OS Name: Microsoft Windows 7 Home Premium
OS Version: 6.1.7601 Service Pack 1 Build 7601
OS Manufacturer: Microsoft Corporation
OS Configuration: Standalone Workstation
OS Build Type: Multiprocessor Free
Registered Owner: Ukoil
Registered Organization:
Product ID: 00359-OEM-8703917-01620
Original Install Date: 9/8/2012, 10:03:28 PM
System Boot Time: 9/26/2012, 4:58:42 PM
System Manufacturer: To Be Filled By O.E.M.
System Model: To Be Filled By O.E.M.
System Type: x64-based PC
Processor(s): 1 Processor(s) Installed.
[01]: Intel64 Family 6 Model 58 Stepping 9 GenuineIntel ~3094 Mhz
BIOS Version: American Megatrends Inc. P1.00, 2/21/2012
Windows Directory: C:\Windows
System Directory: C:\Windows\system32
Boot Device: \Device\HarddiskVolume1
System Locale: en-us;English (United States)
Input Locale: en-us;English (United States)
Time Zone: (UTC-06:00) Central Time (US & Canada)
Total Physical Memory: 8,088 MB
Available Physical Memory: 6,597 MB
Virtual Memory: Max Size: 16,173 MB
Virtual Memory: Available: 14,461 MB
Virtual Memory: In Use: 1,712 MB
Page File Location(s): C:\pagefile.sys
Domain: WORKGROUP
Logon Server: \\UKOIL-PC
Hotfix(s): 90 Hotfix(s) Installed.
[01]: 982861
[02]: KB971033
[03]: KB2425227
[04]: KB2479943
[05]: KB2484033
[06]: KB2488113
[07]: KB2491683
[08]: KB2492386
[09]: KB2506014
[10]: KB2506212
[11]: KB2506928
[12]: KB2507618
[13]: KB2509553
[14]: KB2511250
[15]: KB2511455
[16]: KB2515325
[17]: KB2522422
[18]: KB2529073
[19]: KB2532531
[20]: KB2533552
[21]: KB2534111
[22]: KB2536275
[23]: KB2536276
[24]: KB2541014
[25]: KB2544893
[26]: KB2545698
[27]: KB2547666
[28]: KB2552343
[29]: KB2560656
[30]: KB2563227
[31]: KB2564958
[32]: KB2567680
[33]: KB2570947
[34]: KB2579686
[35]: KB2584146
[36]: KB2585542
[37]: KB2603229
[38]: KB2604115
[39]: KB2618451
[40]: KB2619339
[41]: KB2620704
[42]: KB2620712
[43]: KB2621440
[44]: KB2631813
[45]: KB2633952
[46]: KB2640148
[47]: KB2644615
[48]: KB2645640
[49]: KB2647753
[50]: KB2653956
[51]: KB2654428
[52]: KB2655992
[53]: KB2656356
[54]: KB2656373
[55]: KB2656411
[56]: KB2658846
[57]: KB2659262
[58]: KB2660075
[59]: KB2660649
[60]: KB2667402
[61]: KB2676562
[62]: KB2677070
[63]: KB2679255
[64]: KB2685939
[65]: KB2686831
[66]: KB2688338
[67]: KB2690533
[68]: KB2691442
[69]: KB2695962
[70]: KB2698365
[71]: KB2699779
[72]: KB2705219
[73]: KB2706045
[74]: KB2709630
[75]: KB2709715
[76]: KB2712808
[77]: KB2718704
[78]: KB2719857
[79]: KB2719985
[80]: KB2722913
[81]: KB2729094
[82]: KB2731847
[83]: KB2732487
[84]: KB2732500
[85]: KB2735855
[86]: KB2736233
[87]: KB2741355
[88]: KB958488
[89]: KB976902
[90]: KB982018
Network Card(s): N/A
 

·
Registered
Joined
·
34 Posts
Discussion Starter #19
Re: Unable to connect to internet following use of "last known good configuration"

I fixed the issue; I booted Windows 7 in Safe Mode with Networking, uninstalled the drivers on the network card, and it automatically reinstalled correctly and is now working. The startup repair issue is still present but is bearable until I find another solution.

Thanks for all the help.
 

·
Moderator , - Microsoft Support
Joined
·
7,737 Posts
Re: Unable to connect to internet following use of "last known good configuration"

Hi, glad you worked it out well done. For the startup repair as this is a newly built machine I would first check all connections make sure the MB is well (and evenly) seated on the posts and that all cables are securely attached. Next I would boot to a cmd prompt as admin and run

Code:
chkdsk/f
press enter allow to run at restart "Y" and restart,chkdsk will run can take a long time when finished it will boot into windows. When finished open cmd as admin and type :-

Code:
sfc/scannow
press enter system file checker will run takes awhile.
 
1 - 20 of 25 Posts
Status
Not open for further replies.
Top