Tech Support banner

Not open for further replies.
1 - 1 of 1 Posts

528 Posts
Discussion Starter · #1 ·
Here’s what I have:

An Asus mainboard, model number A7N8X-E Deluxe. Running Windows XP Professional with SP2 and all the latest updates, patches, fixes etc etc etc.

Primary Master is a White Lable Magnetic Data Tech 200 GB hard disk drive
Primary Slave is a Memorex dual layer dual format DVD burner
Secondary Master is a Pioneer DVD-R burner
Secondary Slave is a Western Digital 120 GB hard disk drive

In the device manager:

Under IDE ATA/ATAPI Controllers

Both of the Primary Drives are set to PIO mode and I can’t get them to set to DMA.

In the Primary IDE Channel Properties under the Advanced Settings tab the Transfer Mode is set to DMA if available but under the Current Transfer Mode, PIO is the only option available.

Both of the Secondary Drives have DMA as the Current Transfer Mode. The Secondary Master is set to DMA 2 and the Secondary Slave is set to DMA 5.

Why can’t I get my primary bus to DMA? I thought that there is/was a setting in the BIOS but I have been all over the BIOS and can’t find any settings for the busses and/or DMA vs PIO. Is there somewhere else I should look? The only thing that I haven’t tried yet is to uninstall the Primary IDE Channel from the device manager and reboot the PC but I don’t see how that will help. I would also like to mention that I double checked my data cables and both the primary and secondary busses are using 40/80 cables.

Should I change my device config and put the hard drives on the same bus and the DVD burners on the same bus or is the current config correct? Both cables are firmly plugged in to all devices and the main board.

I am also posting a copy of this topic to the hardware/hard drives section in these forums. Thanks for any help.

1 - 1 of 1 Posts
Not open for further replies.