Tech Support banner

Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
i got vista installed in AHCI sata mode
i got xp installed in IDLE sata mode

when i tried to boot up vista, it tries to boot up xp instead and bsod occured.
i used vista eRecovery i typed bootrec.exe /fixboot and it didnt work it still tries to boot into xp, i typed bootrec /scanos , it only scanned my D:\Windows XP OS only

what should i do to boot back my vista? im using acer 8930g model
 

·
Moderator , - Microsoft Support
Joined
·
7,753 Posts
Hi, there are a number of ways around this. If you have a copy of the Vista DVD then boot from it, run the startup repair to invoke the Vista Boot (BCD). XP will have taken over the boot (boot ini), from the original install. Now when you boot you will only have the option to boot to Vista. In Vista download Easy BCD :-
http://neosmart.net/dl.php?id=1

Run this to set a dual boot menu with XP Now one thing Vista does not see drive letters as you might imagine so when you set the boot path make sure XP points to the same drive as Vista. If Vista is on drive "C" for example and even though you have XP say on drive "F" point XP to drive "C". Here is an example XP is actually on "H" drive on this machine:-

 

·
Registered
Joined
·
17 Posts
Discussion Starter · #3 ·
jenae

i used vista dvd and started the repair, it didnt work, its still tries to boot into xp and recieves bsod

at first there were no os for me to select , and yes i have vista and used it before



and the unkown on unkown local disk


i am running this on AHCI sata mode

extra: ive taken this pc to acer to fully recover my pc before because i messed up my dual boot and i cant boot on either Vista and XP.

ive got the laptop back with everything installed the way it were when i first bought the laptop

after 2 weeks of using it (i didnt attempt on installing xp or anything) it shows NTLDR is missing when i start up, i used the vista dvd to "startup repair" when i reboot i by passed the NTLDR is missing and saw the xp logo (??the laptop is new i dont know why it shows the os before) and bluescreen occured after that and restarted.

thats why i installed xp on IDLE after that occurred to find help
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #5 ·
this is what happened when i type bootrec /scanos , total identified window installed : 1



but i have Vista Pre Installed (in AHCI) and XP installed (IDLE)




I dont think my laptop knows that my Vista Exists, Its Boosting XP instead of Vista in AHCI sata mode and keeps recieving bsod and restarts computer automatically since AHCI doesnt support XP / older os versions, Vista is Preinstalled and i dont know why XP tries to Boot up instead.



Im right now on IDLE sata mode boosting XP to reply on this forum
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #7 · (Edited)
i got vista pre installed in my C drive AHCI, now im using IDLE to run window XP

but when i use AHCI it seems to boot Window XP instead and error occured, how do i make my AHCI recognise and run pre installed Vista instead?


on IDLE, Vista is on D: drive and XP is on F: drive
on AHCI, Vista is Pre-installed on C:drive
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top