Tech Support Forum banner

TP-Link TL-WN723 WiFi adapter does not connect to Edimax BR62-04Wg router

3906 Views 3 Replies 2 Participants Last post by  TheCyberMan
Dear Tech Support!

I have a TP-Link TL-WN723 USB WiFi adapter attached to my laptop, which runs WinXP Service Pack 3. It successfully detdcts the WiFi provided by my Edimax BR62-04Wg router, but when I try to connect, it cannot obtain an IP address and cannot connect to the network. Here are some details:

- The very same WiFi adapter can connect to other routers without any problem
- Any other device can connect to the very same network provided by my router without any problem
- Using the WiFi adapter with other computers does not help

Thus, it seems that the problem is somewhere between this specific router and WiFi adapter. Here is an interesting detail though:

- If I try connecting to my WiFi while a LAN cable from the router is plugged into my computer, the wireless connection establishes too. Even if I later unplug the LAN cable, the wireless connection continues to work. But it won't establish the connection without the cable plugged in.

Here's what I've already know/tried:

- Rebooting the PC
- Re-installing the WiFi adapter's drivers
- All drivers and firmwares are the newest available
- Re-starting and reconfiguring the router
- Using the Windows client for wireless networking and the client included on the WiFi adapter's CD
- Changing the router's connection type to any available option: Access Point, Station Ad-hoc, AP Bridge WDS

None of these had any effect except for one:

- When I changed the router's connection type to Station Ad-hoc, I could connect wirelessly even without the LAN cable plugged in, and I had Internet access. However, in this case, other devices, such as smartphones could not detect the WiFi connection.

Please help me with suggestions if you know anything better than this. Any ideas would be appreciated and if you need further details, I'll do my best to provide them.

Thanks and regards
See less See more
Not open for further replies.
1 - 2 of 4 Posts
Dear TheCyberMan!

Thank you for your response. I forgot to mention that the 3rd party client has already been uninstalled. Now I set the router to AP mode and tried removing the existing wireless profiles and re-connecting to the network but I get the same error message: "Connection is limited or no connectivity."
1 - 2 of 4 Posts
Not open for further replies.