Tech Support Forum banner
Status
Not open for further replies.
1 - 20 of 47 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter · #1 ·
Hi . . .
I have recently bought a TP-link WN350G network card and installed it and it works
LONG STORY SHORT
the card works just fine after restarting (so it worked in the first time of installing software, cuz restart is required upon software install) but it will not work and the pc wont even detect it properly when booting (it shows as an unknown device or something at device manager) and reinstalling the program is useless since its just like restarting the pc "which fixes the problem on it's boot"
Also it will come up with a BSOD if i put the pc to stand by >>> power_state_failure_driver or something, its clearly the network card since i have not made anything that may cause this recently...

***
boot = no card/driver + BSOD upon stand-by
restart = everything works well !!

it's pretty confusing and im so frustrated that i cant see where the problem could be :(

Thx in Advance =)
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #2 ·
Sorry for the unsuitable title i tried to change it but i was a little bit too slow xD
anyway i was just wondering if i can tweak the signal strength to make it better... 3 bars are ok but my laptop's getting full signal so....
its not a big deal to me but if it can be fixed, i will be very happy to do so :)
 

·
Premium Member
Joined
·
8,370 Posts
what windows version are you running, XP, vista, win7

can we see a device manager screen shot
Also the BSOD - can you post the stopcode and any filenames

have you been to the TP-link website and downloaded the latest drivers
Download

Are you using the tp-link utility to control the adapter or windows - that maybe conflicting

------------------------------------------------------------------------
Device Manager
Post back the results in device manager
If you cannot access the internet with this PC, then you will need to copy the program across to the faulty PC
Start > control Panel {Vista set to classic view}> system > {Vista, device manager on left hand side} {XP hardware Tab, device manager button} >
windows 7
start > control panel> System and Security> Device Manager

network adaptors, click on the + > post back the devices listed there
are there any ! ? or X


post a screen shot of the device manager - network adapters

To post a screen shot of the active window, hold the Alt key and press the PrtScn key. Open the Windows PAINT application and Paste the screen shot. You can then use PAINT to trim to suit, and save it as a JPG format file.
To upload it to the forum, open the full reply window and use the Manage Attachments button to upload it here
Full details are here TSG Posting a Screenshot - TSG Library of Knowledge
------------------------------------------------------------------------
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #5 ·
Hi thanks for responding...

as you can see below my name im using win7 32 and

Device mangaer screenshot


Uploaded with ImageShack.us

The BSOD
power_state_failure_driver didnt see anyother things in there... "note that it does not occur unless i go into stand by mode"

TP-link latest drivers
I tried them, weird thing that i uninstalled the driver to install those and for that i needed to restart, but when i rebooted the pc the adapter was functioning and all :S, i installed them then and booted the pc from off status and the problem is still there...

About the utility i cant get it installed because the drivers installation tells me that for my OS (win7 - 32) i cant get the utility and it will install the driver only...
 

·
Premium Member
Joined
·
8,370 Posts
you could try an update
from device manager right click on the atheros wireless adapter and do an update - allow windows to search the internet for an updat e
OR
Whats the make and model of the PC and download a manufacturers updated driver
OR
try this link
Drivers for Atheros AR5007G and Windows 7
You only need to click on the green download button labelled " click to download " and wait, the file will download - you do not need to click on any other buttons to get the download started
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #7 ·
Tried them no dice
Tp-link appeared in the device manager instead of atheros at some point
i updated it and it changed to atheros :S then i updated this atheros it updated succesfully...
i tried booting in every point but no dice ...
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #8 · (Edited)
Should i uninstall it some way that everything is cleared i mean i remove the adapter (hardware) remove every software and then reinstall things... or that would just be waste of time and energy and motherboard strength of holding objects that get pushed into its sockets :p

And for the manufacturer my dsektop is a build from some local company in my country ... and the motherboard is an ASUS p67 if that helps ...
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #9 ·
OMG!!
I tried uninstalling it from device manager and programs (perfect uninstaller) but when i restarted the device and program are still there ?!!
Should i do something else to uninstall ?
note that the adapter i am getting at the final stages (lol) is Atheros 5007G and funny thing that in device manager when i want to install a device "select it manually" i do not see a G its always an N whats that ?
 

·
Premium Member
Joined
·
8,370 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter · #11 ·
The data bass
It shows the "atheros communication ..." when i search by vendor
and i see my driver "or what i believe it is" but with E >> Atheros AR 5007[E]G
my device is WN350G but whats there is WN350GD
note that i have the CD of the product but its not installing right...


Im not sure but thats what i got from the internet
DRIVER NEEDED: Atheros Communications Dual Band 2.4 and 5 Ghz A-B-G-N 300Mbps N Speed Half Size pci Express internal Laptop Mini Card (Windows 7) - DriverGuide Support Forums
http://rapidshare.com/files/397969540/Atheros_wlan_9.0.0.173.zip
 

·
Premium Member
Joined
·
8,370 Posts
You would use the driver from the PC manufacturers site - as asked - whats the make and model of the PC

you should not need a CD Product Key - to install a driver

I also posted the Atheros web site for the driver for windows 7

by using the PCI data base you have confirmed the device is an Atheros

So
Have you tried updating the driver form the PC manufacturers web site ?
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #13 ·
And for the manufacturer my dsektop is a build from some local company in my country ... and the motherboard is an ASUS p67 if that helps ...
as i said its some SMALL company its actually buying alot of stock for various brands and its building pcs by order... this is their website (ADVANTI Systems Customizer :: ADVANTI SYSTEMS :: ADVANTI® Online) so they wont give me make or model or drivers .... besides the network adapter i bought is from another place...

i tried updating with what i have posted which i found in the data base, not working

i am just thinking is it really the driver or it might be something related to it ... just a guess tho because i havent done anything that might interfere...:4-dontkno
 

·
Premium Member
Joined
·
8,370 Posts
besides the network adapter i bought is from another place...
did you try the atheros website -
and have you uninstalled the adapter from device manager and let windows redetect and then pointed to the new drivers to install?
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #15 ·
Is this what u meant by atheros website ? (this is what you've posted)
Drivers for Atheros AR5007G and Windows 7

Atheros 802.11 a/b/g/n Dualband Wireless Network Module, Atheros AR2427, AR5002G ...... AR5007, AR5007EG, AR5007G
notice that its there (AR5007G , or EG im not so sure) BUT
TP-LINK 150Mbps Wireless N Adapter, TP-LINK 300Mbps Wireless N Adapter, TP-LINK Wireless N Adapter
Notice that its not there (Wireless G adapter) "whats the difference G/N, :p i asked for a wireless network adapter for desktop then i heard her say G for computers... i think that means desktops for her"

i've also tried atheros from google and didnt find mine there .....
 

·
Premium Member
Joined
·
8,370 Posts
very confused sorry

you already have a wireless adapter Atheros AR5007 (EG) and you have purchased another wireless adapter PCI adapter WN350G WHY

The data base told you the device manger with a yellow ! was an atheros Device
and in device manager the TP-Link is not shown at all

I'm confused as to what we are trying to fix now

"whats the difference G/N, :p i asked for a wireless network adapter for desktop then i heard her say G for computers... i think that means desktops for her"
No it does not mean desktop etc - its the speed the wireless adapter works at

there are all specifications for wireless - you can have a A/ B / G /N
have a scroll down this page and you will see the specifications
IEEE 802.11 - Wikipedia, the free encyclopedia
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #17 ·
"you already have a wireless adapter Atheros AR5007 (EG)"
Are you sure that i have an atheros before?
I am very "unfamiliar" with these things but shouldnt i see the atheros in the back of my case ? or its something.. um.. integrated?!

Ok i just want to get a wireless connection if "my" atheros can work well as good as a tp-link then i will throw the tp-link at another pc or someone...

IF so then how do i do that ? unplug the tp-link and reinstall atheros driver?
IF NOT then how do i get this tp-link to work...
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #20 ·
note that its like this before and after restarting :D progress maybe
with the exception of the yellow !
note that i tried to install before restarting and got an error adapter or driver cannot start code 10 something like that ....
 
1 - 20 of 47 Posts
Status
Not open for further replies.
Top