Tech Support Forum banner
Not open for further replies.
1 - 2 of 2 Posts

· Registered
1 Posts
Discussion Starter · #1 ·
Hi all,

Cut long story short:

I own one Toshiba Satellite A10 old model Celeron 1.8Ghz Processor, currently running Windows XP SP3.

Just bought thru Ebay one 2.5Ghz Celeron Processor SL75T, checked same FSB, same pin, compared with the current 1.8Ghz.

Did a swap and replace the 1.8Ghz with the latest 2.5Ghz, the notebook is able to boot, however it crashes just before got into normal windows.

Tried safe mode, it went in smoothly, however intermittently it will hang, too, but at least I could go in and change some settings.

Originally thought it was the Thermal Design Power from the old 24.5W to the current 35W. Though without any hard evidence from me i.e. getting reliable facts on 3rd party processor temperature software (coz the 3rd party software can't run in safe mode environment), the fan is still running strong, just changed new fan not too long ago.

My hunch is that, when I was in the Safe Mode windows, I could see that in the Hardware list of the Device Manager, the processor is still showing the old 1.8Ghz and not the latest 2.5Ghz? However, when I right click on My Computer and select Properties ==> System Properties, it is showing 2.49Ghz alright, just not inside the Hardware list of the Device Manager. I've tried to uninstall it, but it still won't work after various reboot.

I don't think there's any driver for the change of processor, what should I do to prevent this 2.5Ghz to hang up every time before it tries going into normal windows? I think this should be the OS problem am I right? (not sure) Please enlighten. Thanks!!
1 - 2 of 2 Posts
Not open for further replies.