Tech Support Forum banner

Toshiba keyboard problems

3483 Views 15 Replies 4 Participants Last post by  oscer1
I have a toshiba satelite l300D but my keyboard is playing up, it seems certain letters are linked so for example when I press the p key on my keyboard pk appears onscreen, and when i type k, pk appears onscreen.
This happens with the following keys:
I appears as -i onscreen, and - key shows as -i
, appears as ,[ and vice versa
space bars makes my browser bar dissapear and reappear
0 shows as 80 onscreen and 8 as 80
Can you help please?
Not open for further replies.
1 - 16 of 16 Posts
this could be that your keyboard has dust etc in side it. so you need to try and clean it out by, using compressed air to get underneath the keys also get a cotton bud or something similar to clean any stickiness off the actual buttons. if this does not work then it is probably a fault with your computer and you should try taking it back to where you got it from if it is under warrenty.
not sure its dust as the problems are not 'random' but have cleaned -it and it didnt offer a solution, unfortunately the laptops no longer covered by warranty. thanks anyway
hi haynes86 welcome to tsf,

hook up a usb keyboard see if it does the same thing. if thats ok i would start by taking keyboard out and re-seat the cable. be careful not to break the zif connector
thanks for the reply i have tried an unsucessful attempt to use an external keyboard but unfortunately this didnt solve the problem:mad:
so you stated you hooked up a usb keyboard and it did the same thing? or the keyboard did not work at all?
The usb keyboard did the same thing...Would it be worth restoring the laptop to factory sett-ings? Thanks again for your help
goto device manager and uninstall the keyboard and reboot. It will install driver upon startup.
No unfotunately the problem still persists. :upset:
Sorry meant to say tri-ed it but problem still persists...
Hi have you tried going to the toshiba support page for your model here is one model
check if it is yours Model Content Page on page 2 near the bottom is the touchpad driver try installing it provided it is your model if not then look yours up
Still no luck, installed the new driver to no avail. Any more ideas at all?:rolleyes:
Thanpks again
Does it work ok in the bios is it visible in the bios under usb device or similar
how long ago did this start happening? can you try a restore point?
It started in October but my only restore points are thereafter...
1 - 16 of 16 Posts
Not open for further replies.