Tech Support Forum banner
Status
Not open for further replies.
1 - 19 of 19 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter · #1 ·
I have a Sony Viao Pentium 4 running XP Media (SP2) and it has worked without issues for about two years. The short version of this is that when I click on most, but not all, exe programs I see a dialog box pop up stating, “This file does not have a program associated with it for performing this action. Create an association in the Folder Options control panel.”

The long drawn out history is this: I had Norton Internet Security 2006 and I was prompted to upgrade to 2008. During the upgrade process I had to download and install for some reason, a Visual C++ package, vcredist_x86.exe which is digitally signed by Microsoft. After a couple of reboots and such it appeared that Norton Internet Security 2008 had installed successfully. I then performed a complete scan where a couple of items were found. It quarantined them and off I went. Afterwards I powered down the machine and went to bed. I woke up the next morning, turned on the PC and noticed that the parental portion of Norton didn’t come up (my son’s PC). After a few minutes I also noticed Norton didn’t show up in the system tray (along with several other items that normally do) nor was Norton running when I opened the Task Manager window. I then tried to click on some of the icons on my desktop and any one I double clicked on I received the message stated above.

When I go to Folder Options in the Control Panel I view the File Types tab, everything looks correct as compared to my fully functioning second PC running Windows XP Pro. All the icons on my troubled PC look normal but when I click on it I receive the stated message above. For the record, only a couple items in the Control Panel can actually run a program. About 90% of them give the error message above.

I also looked into the registry under HKEY_LOCAL_MACHINE/software/Symantec I do see many items so it appears that Norton is still installed but I wouldn’t swear by it.

Before you ask, Norton has been extremely unhelpful in this scenario to the tune of not even returning my emails after the initial exchange but they sure accepted my money… They did send me a link to download a removal tool, which I did, that is supposed to remove all traces of Norton (if it were a bad install) so I can start the process over but guess what, when I click on it to execute it I see the dialog box stated above.

One last clue. When I click on Start I can mouse over the Firefox "tab/icon" and when I click on it Firefox starts up and runs. If I use the Firefox icon on the desktop or in the quick startup menu I get the error stated in the first paragraph. Very odd... Other programs that are shown when I click on Start don't work so it's a hit and miss kind of thing. Sorry about the long email but I figured my diatribe might reduce the number of return questions...

Help me Obi Wan Kenobi, you’re my only hope!

Any help would be greatly appreciated and please let me know if I need to give you any more information.
 

·
TSF Team Emeritus , Microsoft Visitng Expert
Joined
·
4,279 Posts
Hello 3leggedpc

Try this and see if it helps

http://www.dougknox.com/xp/file_assoc.htm

Click "EXE File Association Fix"

See if that helps

NOTE: If your EXE file associations are corrupted, it can be difficult to open REGEDIT, or to even import REG files. To work around this, press CTRL-ALT-DEL and open Task Manager. Once there, click File, then hold down the CTRL key and click New Task (Run). This will open a Command Prompt window. Enter REGEDIT.EXE and press Enter.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #3 ·
Thanks so much for your time. After downloading the file I double clicked on the file and received the following message: "Cannot import C:\..pathname..\xp_exe.reg: Not all data was successfully written to the registry. Some keys are open by the system or processes." I only had a Firefox window open and the directory containing the registration fix. Is the normal outcome?

Also, I was able to open up the registry by your NOTE but I'm not sure what to do now that I'm here. I've clicked on an exe and I still see the same results as stated originally :(
 

·
TSF Team Emeritus , Microsoft Visitng Expert
Joined
·
4,279 Posts
No, that is not normal

Make sure no other windows open
Download Doug's zip file
Right click on the .reg file and then click Merge
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #5 ·
Hi Dunedin,

I started up the PC and ensured my son's account didn't have any open processes and performed the actions you requested on my account (administrator) with the same exact result as before.

"Cannot import C:\..pathname..\xp_exe.reg: Not all data was successfully written to the registry. Some keys are open by the system or processes."

I do appreciate your time so thanks for hanging with me... Shall I shoot the machine? ;)
 

·
TSF Team Emeritus , Microsoft Visitng Expert
Joined
·
4,279 Posts
OK, here are more ways to try to do the same thing.

#2 is checking the registry manually.
Follow the directions very carefully.
If you need more help just ask rather than make a mistake
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #7 · (Edited)
Hello Dunedin,

The good news is that I haven't "broken" my pc any worse that it was though the bad news is I'm still at the same place.

I downloaded and double clicked on the com file and it appeared to run but I still saw the same issue as I reported originally. I then ran the "silent" command and received no errors in my command window and got the prompt back, but again, no change from original issue.

I then performed the manual steps but when I attempted to click "OK" after typing "%1" %* in the field I received the following message:

Cannot edit : Error writing the value's new contents.

The value when I looked at the register was "(value not set)".

Sorry to be a pain but I do appreciate the help... Any more suggestions?
 

·
TSF Team Emeritus , Microsoft Visitng Expert
Joined
·
4,279 Posts
This is a strange one.

I have been trying to think what might be causing the problem.

You did say that Norton removed some malware. I`m wondering if there are still some registry keys belonging to the malware. I think you should check for that as follows....

Please follow our 5 Step process outlined here:

http://www.techsupportforum.com/sec...read-before-posting-malware-removal-help.html

After running through all the steps, please post the requested logs in the HijackThis Log Help forum.
http://www.techsupportforum.com/security-center/hijackthis-log-help/


If you have trouble with one of the steps, simply move on to the next one, and make note of it in your reply.

I hope you can do most of that.
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #9 ·
I'm sorry to say I can't perform a single step. I can't access the Add/Remove Programs because of the problem. For some reason I can click on Folder Options in the Control Panel and that works but the vast majority of the icons give me the error message. I can't perform step two because I can't successfully double click on the downloaded exe file. No association problem comes up... Same thing with Spyware Blaster or any other program needing to be downloaded and executed. Nor can I run an OS update for the same reasons. I did see that the PC ran an update a few days ago (I was running through some steps you asked me to and I noticed the download/install icon appear in the system tray - 5 critical updates were pushed). I'm very diligent about OS updates so I'm pretty sure I'm up to date or as close as I can be given my current circumstances.

Obviously I have nothing to post so step 5 is not happening. Is there a virus/scan program that runs remotely without having to run an executable from my PC?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #10 ·
I still don't understand how the Firefox icon located on the "menu" when I click Start works. No other Firefox icon works regardless of where it is located. How can that "icon" work and the others on the desktop and quick launch area not work? They run the same program... I have Outlook under the Firefox "icon" when I click on Start and that works too. None of the other programs do though... The icon Outlook in the quick launch area doesn't work either. Just seems odd...

Sincerely appreciate y'alls time...
 

·
Registered
Joined
·
2,697 Posts
Welcome to TSF....

What is the make and model of the computer?

Do you have the recovery disk set for this computer?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #12 ·
Thor, it's a Sony Viao, Pentium 4, XP Media Center, SP2. Actually, I don't think I do have a recover disk for this PC. I was a bit dismayed as to why I didn't get one but I do have an official copy of XP from another computer that is defunct and not in use. I had planned to use this disk as a last resort.

I'm sorry but I'm about to catch a plan to go on a business trip. I'll ping you guys when I get back on Thursday. I really appreciate y'alls time and what you do for the larger community so please be patient and I'll get back to you guys in a few days with more detailed system info if the above isn't enough.

Thx
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #13 ·
Gents,

I'm back again. Specifically I have a Sony VGC-RB50 (G) series PC. IS there anything worthwhile left to try or do I go ahead and wipe the drive clean and start with a new install?
 

·
Registered
Joined
·
17 Posts
Discussion Starter · #15 ·
Gents - I notice some time ago that while I am administrator, there is another administrator account that I only see when I go into safe mode. I copied the panda file and norton removal tool to the other administrator account and I was able to get my PC running again. I've just downloaded Norton and it's running another full system scan. So whatever the issue was, it appears to affect my account and my son's account, but not the other administrator account that is only see when I enter safe mode. Anyway, appreciate the help and time you put into this case.
 

·
Registered
Joined
·
2,697 Posts
Sorry it took me so long to get back.

Do not use that other disk from another computer it actually is written for that other computer and more than likely will do harm to the operating system of this one.

My suggestion is to contact Sony and purchase the proper recovery disk set for your Vaio. And during the time that it takes for the disks to get to you what you can do is backup all of the important data on your computer to another media like CD-R's, DVD or other media that you prefer. When you get the proper recovery disk set for the computer then post back and we will start a procedure to get your computer back to proper working order.

In a last choice if You can find an OEM version of your windows xp Pro or Home you can use that.
 

·
Registered
Joined
·
2 Posts
Hey guys, I just stumbled upon this thread and I'm curious as to whether or not the issue was resolved and if so what was it that fixed it? I'm trying to fix a friend's computer and it's doing the same thing that 3leggedpc's computer was doing. Except the administrator account gives me the same message. This is pretty bizarre. Even in safe mode I can't do anything. I wonder if the system files or the registry are corrupted. Any help would be appreciated guys. Thanks. Oh yeah, he's running Windows XP Media Center Edition on a laptop (Dell Inspiron E1505 if that makes any difference).
 

·
Registered
Joined
·
2 Posts

·
Registered
Joined
·
2,697 Posts
Welcome to TSF, squizzle

I can appreciate that you are having a similar problem as the one in this thread but due to the fact that there are differences between the computer and operating systems the out come might be different and also that having two people in one thread with a similar problem makes it difficult to keep track of what is what I would ask you to make a new thread for your problem separately from this one. This would make solving your problem much easier.

Thank you for your co-operation.
 
1 - 19 of 19 Posts
Status
Not open for further replies.
Top