Tech Support Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
So recently I tried playing Garry's Mod for the first time in a while, and while the game loads up okay and I can create a singleplayer game without any issues, when I try to connect to a server, it gets to the 'received all Lua files we needed' loading bar and then just freezes. I have tried waiting around 10 minutes or so, and on the occasion that anything happens, it just says I've timed out.

I also loaded up TF2 - very similar issue here, too. Game loads up fine, singleplayer seemed to be okay when I tried it, but connecting to servers stops at the last few bits of the 'sending client info' loading bar. Just like gmod, it freezes and then eventually (5-10 minutes later) just tells me I timed out.

However, immediately trying to rejoin the same server (without restarting the game) actually gets me into a server - but I would have to do this routine every time I want to join a server, so if I can fix it that would be...preferable.
I'm assuming that the two games having such a similar issue must mean it's something to do with Source games in general, I would try CSGO to confirm this but joining CSGO servers has never been a smooth process for me for some reason, so I don't think it would be worth it. I haven't yet tried the instant reconnect with gmod as I uninstalled it to see if that would fix my issue before playing tf2 and haven't reinstalled yet. I've tried verifying both games, removing the config files for both games, and resetting all the settings for both games, along with turning off both my windows firewall and the one on my router - no luck at all.

Please help, I really miss playing these but have no idea what to do to try and fix them.

I have console logs from both games and will attach them, no idea if they're any use though.
 

Attachments

1 - 1 of 1 Posts
Top