Tech Support Forum banner
Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I have a TC200 Techumseh MiniTiller Cultivator Model # 161lcm

The Problem is that While the engine runs fine, the Tiller tines will turn but have VERY VERY low power.
They will spin when free but will not work when any resistance is applied.

This model has a centrifugal clutch. The idea is that the times don't move while idling the engine but turn when accelerating.

Now they don't turn when accelerating at all.

My question is: Do I need a new clutch or do I need to fix something in the transmission? (clutchdrum)

THe Tines turn when spun by hand.
The Clutch spins and expands (if that is the term???) when accelerated. They just don't work together.

I have found parts lists and exploded views. All parts are there and none appear broken, but I don't know enough to know why this doesn't work anymore.

Thanks for any help.
 

·
Registered
Joined
·
14,580 Posts
Hi and welcome to forum :wave:

The centrifugal clutch would be my guess as to the problem.

If you have a link to the parts break out, please post it.

BG
 

·
Registered
Joined
·
14,580 Posts
I had a look see. Part #21 and 31 make up the centrifugal clutch. My guess would #21 is were the problem is. Make sure it is clean, no oil in it.

BG
 

·
Registered
Joined
·
14,580 Posts
Well grease would make it slip. I would use spray carb cleaner or brake cleaner if you have any. A little grease on the outside should not hurt, but inside is what that has to be clean.

Keep us posted on how it works after you clean it.

BG
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top