Tech Support banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
First up, I apologize if this has already been covered somewhere; I searched and couldn't find anything.

I've just installed Red Hat 8 on a machine my parents want to use as a file server. However, I am now stuck with a rather annoying problem: I can't get the new linux box to talk to any of the other machines.

The network itself is in a... transient state at the moment, but there are currently three machines: a Win98 machine, a Win2k machine, and the new linux box.

The Win98 machine has nothing special about it, except that it's configured to automatically get an IP address. The Win2k machine is set up for internet connection sharing, and so is 192.168.0.1, and atm has assigned the 98 machine an IP of 192.168.0.2.

The linux machine we don't need to have access to the internet (my parents would rather it don't for security reasons), so I set it to have an IP of 192.168.0.255.

Now, I KNOW that eth0 is being detected and brought up. If I run 'neat', it shows eth0 as being active, and checked in the profile. Under the device options, it's setup to have a static IP address (192.168.0.255), and subnet of 255.255.255.0 (which is what the Win2K machine is set up to have). It doesn't have a gateway address, as I don't think we have one/it needs one, and when I set it up to be 192.168.0.1, sendmail crashed the machine on boot (ie it just stalled). There's nothing in route, and hardware device is set to eth0, with the rest all unchecked.

Under hardware, the card is visible, but when I edit it, it's got device 'eth0', and then IRQ 'unknown', with the rest all empty. I know the card is on IRQ 12, so I put that in, but I didn't know if I had to put anything in the other fields (ie MEM, IO, IO1, etc. are all blank).

Hosts just has the loopback, and DNS just has the hostname set to the machine's hostname, and the only entry in the DNS search path is the machine's hostname.

Now, I know the loopback interface works (I can ping it), and I can ping my static IP address (192.168.0.255), but I can't reach the other two machines (which can talk to each other just fine). When I DO ping one of the other machines, I notice that there is network activity on both the linux box, and the machine being pinged on the hub (same if I try pinging the linux box from one of the other machines).

I've read and re-read all the guides and HOWTOs I can find, but still nothing seems to work. ANY insights into this would be greatly appreciated; I don't want to try reinstalling this thing as a Win2k file server...

Thanks in advance (and sorry for the long post),

-- Daniel
 

·
Registered
Joined
·
1,393 Posts
You need to change the IP address. You can't use the .255 for a host address. That address, 192.168.0.255 is the broadcast address for the network. The other "unusable" address is the subnetwork address, 192.168.0.0.

I've you've ever studied IP addressing theory and seen the formula for figuring out host addresses (2^N-2) this is where the -2 comes in.

Change the address to 192.168.0.254 and you should be fine for pinging and so forth.

For file sharing, you're going to need Samba on the Linux box.

HTH
 

·
Registered
Joined
·
1,393 Posts
Ps. You talk about you set it up with a .1 address and sendmail crashed - that would have been a duplicate IP address and that's now allowed under a normal IP network.

If you insist on giving the Linux box a static address, you really ought to do it through a reservation on the ICS box which is functioning as a DHCP server. Or you can take .254 out of the DHCP pool.

HTH
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Yeah, I found an article on the net just a little while ago about that... <bangs head against table> Why, oh why don't people mention these things :S

Ah well, it's all working a treat now. Got Samba up and running.

As for sendmail, I read somewhere else that it apparently doesn't like it if you don't have a domain setup for the machine or somesuch... I don't have a domain set up for any of the other machines (all the Windows machines are just under a 'Workgroup'), and since I'm not going to be using it, I just disabled it.

Thanks for your help :)
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top