Tech Support Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
This all started since i installed a new m.2 ssd in my sistem, now I'm experiencing really bad stuttering and freezes while playing, I tried so many things as of now, but nothing seems to work. I need to solve this problem asap, please help me :c
Specs:
-B450 Aorus Pro (latest Bios version)
-Ryzen 5 2600x
-Radeon RX 5700 XT
-G.Skill Trident Z 2x8gb ddr4 3000mhz
-Crucial P2 CT500P2SSD8 500gb m.2 nvme
-Kingston NV1 NVMe SSD 500GB M.2
-Seagate Barracuda 1Tb hdd
-EVGA 750 GQ, 80+ GOLD 750W

Procedures I've already tried:
Uninstalling and reinstalling every single driver possible;
Updating BIOS to the last version;
Disabling Sysmain and Windows Search services;
Uninstalling Windows and reinstalling it on another drive;
Swapping old PSU for a new one (from 700 to 750w);
Checked all temperatures while gaming, they are fine;
Checked for Memory Health;
Bought a new Displayport cable.
(I may have tried also other things, but i cant remember rn)
 

·
TSF Moderator , Hardware Team , Networking Team
Joined
·
8,917 Posts
Try performing a Clean Boot. If everything is working fine now you can keep it this way or, you can add one Startup item and/or Service at a time until it stutters or slows down again. When it does you will have found your culprit.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Try performing a Clean Boot. If everything is working fine now you can keep it this way or, you can add one Startup item and/or Service at a time until it stutters or slows down again. When it does you will have found your culprit.
I just did that and got no improvements, do you have any other ideas?
 

·
Team Manager, Microsoft Support
Joined
·
29,770 Posts
Try switching to on board graphics. If it's any better, buy a new GPU. You didn't mention what you're currently using.
 

·
Team Manager, Microsoft Support
Joined
·
29,770 Posts

·
Team Manager, Microsoft Support
Joined
·
29,770 Posts
When you said "temps are fine", please post here to be sure.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
Guys I figured it out, my problem with stuttering is AMD Chipset drivers, if uninstall them this issue goes away, i tried reinstalling them, and the issue came back, so its them, for sure.
Can i just ignore those drivers and play without them?
 
1 - 14 of 14 Posts
Top