Tech Support Forum banner

Strange problem: I think failed motherboard!

534 Views 0 Replies 1 Participant Last post by  danielgent
Got a PC off someone to look at. Tried so much stuff but its behaivour is just WIERD!
I'm thinking the harddrive controller on the motherboard has broken in some way. Any suggestions would be much appreciated! This post is quite long so if you can't be bothered reading it just scroll to the end and tell me if the error messages indicate a failed harddisk controller. thanks!

The PC is from about 2005 I reckon if not a bit older. 2 HDDs on the primary IDE cable and 2 ODDs on the secondary. The PC one day just wouldn't boot. It gave an "unmountable boot" or something like that so was brought round my house. Didn't write the whole error down as I assumed it would be a simple problem! These error messages aren't 100% accurate as some of them I didn't fully write down and some of them flash up for so quick!
To note, an boot an error message: "primary IDE no conductor cable type 80 is installed" flashes up so quickly. might already have been there though. Tried my own IDE cable and still same error.

What i've done and found:
Can't boot from CD.
unplugged HDDs, and CDs seem to work fine (can boot ubuntu live CD).
Then when both HDDs are plugged in no CD can boot.
Linux seemed to load once with both HDDs in (though it took ages) and could see both HDDs.
booting off XP recovery CD doesn't happen when 1st HDD (master) connected. With 2nd (Slave) it boots but takes ages.

some combinations of the 2nd HDD allow the XP recovery CD to boot up (if on its own IDE cable) but not when it shares the IDE cable with the ODD. XP recovery never boots with the 1st HDD in.

So i took out the first HDD and connected it to my comp as the only HDD. Windows didn't boot and hit a BSOD (which probably is a little bit expected if switching windows to a different PC!). Ran chkdsk on this drive from XP recovery and it found errors for 1st 3 runs. Also ran maxtor seatools on it and reported no errors with the HDD.
put this HDD back in the broken comp and on booting gives a "hal.dll error". XP recovery now runs but gives an error message I've never seen before saying the CD has a file missing! (it doesn't)

So decided to try reinstalling windows. With the 1st HDD XP install wouldnt load. With the 2nd HDD XP install loads. I tried backing up 12 GB of data from this 2nd harddrive before deciding to go ahead with the installation but Ubuntu said 2 hours left so I put my own IDE HDD in instead to install windows onto that. When selecting the partition to delete and install windows on, the Windows setup gives an error message again i've I've never seen before.
"computers startup program cannot gain access...."

Maxtor diagnostic software can't see this MAxtor drive, as for HDD2 (a Hitachi). Hitachi Disk Fitness Test can see HDD2 but gives an error on trying to run.

Damaged motherboard I'm thinking? That was a long post!

Dan Gent
See less See more
Not open for further replies.
1 - 1 of 1 Posts
1 - 1 of 1 Posts
Not open for further replies.