Tech Support Forum banner
Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi,

Apologies if this is in the wrong part of the forum but I've only just joined:embarased

I've got a Dell XPS Gen 3 Pentium 4 (3.4Ghz) with a Creative Soundblaster Audigy 2 ZS installed.
Previously, I was using an Nvidia 8500GT graphics card but I've recently upgraded to an ATI Radeon HD 5670 (1Gb GDDR5).

Unfortunately, with one exception (Armed Assault 2: Operation Arrowhead), since I installed the ATI Radeon HD 5670 I've not got any sound from the Audigy 2 ZS - indeed Windows isn't even registering a sound card as being on my machine!!

Is this a known problem and if so does anyone have suggestions on a solution?

Thanks for any help anyone can provide.

Kind regards,

Martin
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Thanks pip22.

There aren't any red 'x' symbols or yellow '?' marks against any of the sound and video entries on Device Manager.

According to Creative Labs I've got the most up to date version of the sound card drivers.

I've got an entry on the sound, video and game controllers on Device Manager called "ATMI HDMI Audio". Do I need to disable this in some way to get the analogue sound in the Sound Blaster to work?

Kind regards,

Martin
 

·
Moderator; Hardware
Joined
·
19,884 Posts
Ensure the default audio device is set to the Creative chipset. After installing the ATI card, it was likely changed to the ATI HDMI audio.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Ensure the default audio device is set to the Creative chipset. After installing the ATI card, it was likely changed to the ATI HDMI audio.
Dogg,

How do I do that? When I go into "Sound and Audio Devices" on the Windows XP Control Panel it says "No Audio Device" and won't let me select any devices for "Audio" or "Voice" - everything is greyed out.

Kind regards,

Martin
 

·
Moderator; Hardware
Joined
·
19,884 Posts
Uninstall the software/drivers for the Creative card using Add and Remove programs (if any are listed), reboot, and then reinstall the Creative drivers.

Control Panel / Sounds and Audio Devices / Audio tab / Sound playback "Default device:" drop down box should list the ATI chipset and the Creative chipset....select the Creative chipset
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Uninstall the software/drivers for the Creative card using Add and Remove programs (if any are listed), reboot, and then reinstall the Creative drivers.

Control Panel / Sounds and Audio Devices / Audio tab / Sound playback "Default device:" drop down box should list the ATI chipset and the Creative chipset....select the Creative chipset
Hi Dogg,

I tried everything you suggested and I've still got the same problem.

Is there anything else in Windows I could turn on (or off for that matter) to try and resolve the problem or should I resign myself to putting the old nVidia card back in until I get a new desktop?

Kind regards,

Martin
 

·
Moderator; Hardware
Joined
·
19,884 Posts
Video card shouldn't matter at this point, but feel free to swap back and test.

If the Audigy card isn't recognized, it's not installed properly (ie: loose or misalligned) or faulty.

If it is recognized and there are still yellow ! shown in Device Manager, there is a driver installation issue.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Video card shouldn't matter at this point, but feel free to swap back and test.

If the Audigy card isn't recognized, it's not installed properly (ie: loose or misalligned) or faulty.

If it is recognized and there are still yellow ! shown in Device Manager, there is a driver installation issue.
Hi Dogg,

I don't think the sound card is faulty because it does work for A2:OA, just nothing else.

I did think it might be Steam related (as A2:OA runs through Steam) but none of the other stuff on Steam works so it's probably not related to that.

Just looking at Device Manager it shows that the ATMI HDMI Audio is installed at Location 65535 (Internal High Definition Audio....).

I'm wondering whether (even though it's disabled) that the HDMI Audio is still in charge? Is there any known way to turn off the Location 65535 thing?

Kind regards,

Martin
 

·
Moderator; Hardware
Joined
·
19,884 Posts
Doesn't matter if it's installed or not. You can have multiple sound cards/audio chipsets installed. All Windows cares about is the configuration, specifically the default audio device ( Control Panel / Sounds and Audio Devices / Audio tab / Sound playback - Default device ).

Test with a different game (ie: something that does NOT use Steam). If it works, you have some sort of Steam issue.
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top