Tech Support Forum banner
Status
Not open for further replies.
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I've met a very strange situation today.

The setup is as follows. The computer was originally connected to a cable modem, then using a VPN connection the Internet was accessed. This worked perfectly fine.

However, after we placed a router in between (the model is ASUS RT-G32), things went strange.

Now, the computer is connected to the router, which is then connected to the cable modem. The router handles the VPN connection, so essentially it should be 'plug in and use'.

This actually happens on my Windows 7 laptop - I can browse the internet without any problems. However, this is not the case with the computer.

My investigation showed that any HTTP connection receives a tiny bit of data (it's a kilobyte or so) and then the connection just hangs - it doesn't receive any data nor it's being dropped.

The ping/tracert/DNS are all working fine. I suspect the case is only with HTTP connections, as Skype seems to be working fine.

The situation goes back to normal if I plug the computer directly to the modem.

The operating system on the guilty computer is Windows XP, service pack 3.

Any ideas? Thanks in advance.
 

·
Networking Team |Tech
Joined
·
4,117 Posts
Re: Windows XP stops receiving HTTP data after a kilobyte or so

Hi mcm69,

Perform a reset on the router and see if that resolves your issue. Since everything works fine when you plug in the computer directly to the modem, the problem could definitely be the router. Hope resetting the router device will resolve your issues.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Re: Windows XP stops receiving HTTP data after a kilobyte or so

DBCooper,

Thanks for the reply. This did not work, but made me check the MTU setting on the router. It was set by default to 1460 which seemed okay for Windows 7 machine but not for XP. I set the MTU to 1400 to match the Windows XP default VPN maximum transmission unit and it now works as a charm.
 
1 - 3 of 3 Posts
Status
Not open for further replies.
Top