Tech Support Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
Upon starting up supreme commander forged alliance I am left with a black screen, behind is the following error message.

Code:
CD3DDeviceResources::DevResInitResources: Unable to load effect file /effects/cartographic.fx

Program : C:\Games\THQ\Gas Powered Games\Supreme Commander - Forged Alliance\bin\ForgedAlliance.exe
Cmd line arguments : 

Callstack:
    unavailable.

Last 100 lines of log...

debug: SND: Loaded SoundBank 'xab'
debug: SND: Loaded SoundBank 'xal'
debug: SND: Loaded SoundBank 'xal_weapon'
debug: SND: Loaded SoundBank 'xas'
debug: SND: Loaded SoundBank 'xas_weapon'
debug: SND: Loaded SoundBank 'xca'
debug: SND: Loaded SoundBank 'xcb'
debug: SND: Loaded SoundBank 'xcl'
debug: SND: Loaded SoundBank 'xcs'
debug: SND: Loaded SoundBank 'xea'
debug: SND: Loaded SoundBank 'xea_weapon'
debug: SND: Loaded SoundBank 'xeb'
debug: SND: Loaded SoundBank 'xel'
debug: SND: Loaded SoundBank 'xel_weapons'
debug: SND: Loaded SoundBank 'xes'
debug: SND: Loaded SoundBank 'xes_destroy'
debug: SND: Loaded SoundBank 'xes_weapons'
debug: SND: Loaded SoundBank 'xra'
debug: SND: Loaded SoundBank 'xra_weapon'
debug: SND: Loaded SoundBank 'xrb'
debug: SND: Loaded SoundBank 'xrl'
debug: SND: Loaded SoundBank 'xrl_destroy'
debug: SND: Loaded SoundBank 'xrl_stream'
debug: SND: Loaded SoundBank 'xrl_weapon'
debug: SND: Loaded SoundBank 'xrs'
debug: SND: Loaded SoundBank 'xrs_weapon'
debug: SND: Loaded SoundBank 'xsa'
debug: SND: Loaded SoundBank 'xsa_destroy'
debug: SND: Loaded SoundBank 'xsa_weapon'
debug: SND: Loaded SoundBank 'xsb'
debug: SND: Loaded SoundBank 'xsb_weapon'
debug: SND: Loaded SoundBank 'xsl'
debug: SND: Loaded SoundBank 'xsl_destroy'
debug: SND: Loaded SoundBank 'xsl_weapon'
debug: SND: Loaded SoundBank 'xss'
debug: SND: Loaded SoundBank 'xss_destroy'
debug: SND: Loaded SoundBank 'xss_weapon'
debug: MEM: -59705600 bytes SND
info: MD5 of global settings: d2a23d6464d3fd77956e7648c43b5077
info: IsStreamingWaveBank("/sounds/voice/us/briefings.xwb") => true
debug: SND: Loaded WaveBank 'briefings' at 317e7f8
info: IsStreamingWaveBank("/sounds/voice/us/seraphim_language.xwb") => true
debug: SND: Loaded WaveBank 'seraphim_language' at 317f960
info: IsStreamingWaveBank("/sounds/voice/us/x01_vo.xwb") => true
debug: SND: Loaded WaveBank 'x01_vo' at 3180ae0
info: IsStreamingWaveBank("/sounds/voice/us/x02_vo.xwb") => true
debug: SND: Loaded WaveBank 'x02_vo' at 3180c48
info: IsStreamingWaveBank("/sounds/voice/us/x03_vo.xwb") => true
debug: SND: Loaded WaveBank 'x03_vo' at 3180db0
info: IsStreamingWaveBank("/sounds/voice/us/x04_vo.xwb") => true
debug: SND: Loaded WaveBank 'x04_vo' at 3180f18
info: IsStreamingWaveBank("/sounds/voice/us/x05_vo.xwb") => true
debug: SND: Loaded WaveBank 'x05_vo' at 3181080
info: IsStreamingWaveBank("/sounds/voice/us/x06_vo.xwb") => true
debug: SND: Loaded WaveBank 'x06_vo' at 31811e8
info: IsStreamingWaveBank("/sounds/voice/us/x1t_vo.xwb") => true
debug: SND: Loaded WaveBank 'x1t_vo' at 3181350
info: IsStreamingWaveBank("/sounds/voice/us/x_fmv.xwb") => true
debug: SND: Loaded WaveBank 'x_fmv' at 31814b8
info: IsStreamingWaveBank("/sounds/voice/us/xgg.xwb") => true
debug: SND: Loaded WaveBank 'xgg' at 3181620
debug: SND: Loaded SoundBank 'briefings'
debug: SND: Loaded SoundBank 'x01_vo'
debug: SND: Loaded SoundBank 'x02_vo'
debug: SND: Loaded SoundBank 'x03_vo'
debug: SND: Loaded SoundBank 'x04_vo'
debug: SND: Loaded SoundBank 'x05_vo'
debug: SND: Loaded SoundBank 'x06_vo'
debug: SND: Loaded SoundBank 'x1t_vo'
debug: SND: Loaded SoundBank 'x_fmv'
debug: SND: Loaded SoundBank 'xgg'
debug: MEM: -796091502 bytes SND
info: MD5 of global settings: d2a23d6464d3fd77956e7648c43b5077
debug: MEM: -796091502 bytes SND
debug: Loading module '\000/lua/sim/buffdefinitions.lua\000'
debug: Loading module '\000/lua/sim/adjacencybuffs.lua\000'
debug: Loading module '\000/lua/sim/adjacencybufffunctions.lua\000'
debug: Loading module '\000/lua/sim/cheatbuffs.lua\000'
info: adding font file /fonts/arial.ttf
info: adding font file /fonts/arialbd.ttf
info: adding font file /fonts/arialbi.ttf
info: adding font file /fonts/ariali.ttf
info: adding font file /fonts/arialn.ttf
info: adding font file /fonts/arialnb.ttf
info: adding font file /fonts/arialnbi.ttf
info: adding font file /fonts/arialni.ttf
info: adding font file /fonts/ariblk.ttf
info: adding font file /fonts/arlrdbd.ttf
info: adding font file /fonts/butterbe.ttf
info: adding font file /fonts/vdub.ttf
info: adding font file /fonts/wintermu.ttf
info: adding font file /fonts/zeroes_3.ttf
debug: Loading module '\000/lua/keymap/keynames.lua\000'
debug: Loading module '\000/lua/keymap/keymapper.lua\000'
debug: Loading module '\000/lua/user/prefs.lua\000'
debug: Loading module '\000/lua/options/optionslogic.lua\000'
debug: Loading module '\000/lua/keymap/defaultkeymap.lua\000'
debug: Loading module '\000/lua/keymap/keyactions.lua\000'
debug: Loading module '\000/lua/options/options.lua\000'
warning: c:\games\thq\gas powered games\supreme commander - forged alliance\gamedata\effects.scd\effects\cartographic.fx: unable to compile effect: c:\games\thq\gas powered games\supreme commander - forged alliance\gamedata\effects.scd\effects\cartographic.fx reason: unknown error
I have seen suggestions that installing the newest DirectX will help but installing 'Re-dist February (2010)' did nothing. :/

Another note my nvidia display drivers have been faulty lately, with the screen going black for a second or two and then returning to normal. Updating these didn't seem to make any difference.

Thanks in advance for any help. :)
 

·
TSF Team Emeritus
Joined
·
3,450 Posts
Re: Supreme Commander 1 FA crash upon startup

Looks like it's having a problem loading the cartographic map effects. Have you tried reinstalling the game to replace the file?
Do you have any mods installed or have you edited any of the files yourself?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Re: Supreme Commander 1 FA crash upon startup

Yeah I have tried reinstalling the game, none of the files has been edited or any mods installed. This is the first time ive installed the game since upgrading to Windows 7. Im reinstalling it now without the patches and i'll see whats happens.

Any otehr suggestions?

Thanks for the reply :)
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Re: Supreme Commander 1 FA crash upon startup

Hmmph reinstalling it this time worked, sorry i dont have a soloution it just worked. You can close the thread now.

Thanks for your time though
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top