Tech Support Forum banner
Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey, new to the forum, I hope that doesn't impede anyones opinions of me, although I am very new to PC building and this IS my first PC but, whatever. :p

Anyway, I bought a bunch of parts from Scan and they all came, fairly quickly though the GTX 580 was super late, that's mainly due to the shortage that was suffered at release. So recently my mobo and gpu broke (I'm pretty sure the gpu was defective or something from the beginning but whatever) and I sent them back for repair/replacement. After a good 2 MONTHS they replace my parts after loosing them and then marking my invoice as solved or completed or...whatever which was APPAULING but after many phone calls it was solved.

So, I have now a new/repaired mobo (Sabertooth x58) and gpu (Asus GTX 580) and I, stupidly, assembled the whole thing before testing everything worked. This took me like 2 hours and then I turned it on....

I insert the power cable and the green standby led turns on, good so far, then I press the power button and the vga red led flashes along with the cpu red led. They flash for a split second and the cpu cooler fan and chasis fan begin to spin but then everything turns off (except the green standby led which is constantly on) and the fans, slowly spinnning, spin to a halt.

I have tried EVERYTHING to solve this. I reseated the cpu, I changed the pci-e slot the gpu is in. I tried 1, 2 and 3 sticks of ram and then no ram at all (yes I put them in the corresponding slots, according to the manual.) and finally I'm here, on my virtual hands a knees BEGGING for some help....please?
 

·
Registered
Joined
·
211 Posts
Re: Sabertooth x58 won't boot

plz list all parts.
ram, power supply, ect

I'm guessing the power supply but, you need to list your other parts
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Re: Sabertooth x58 won't boot

Okays, I got

Sabertooth x58 Mobo
ASUS GTX 580 GPU
Corsair Dominator 6gb (3x2gb) Memory
850W Antec TruePower Quattro PSU
Intel Core i7 930 CPU

and that's all the necessary parts, right? I mean theres more but it wouldn't really affect the problem right?
 

·
Registered
Joined
·
211 Posts
Re: Sabertooth x58 won't boot

do you have anyway to test the power supply? that is a good brand but sometime you get a bad one
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Re: Sabertooth x58 won't boot

What do you mean by test it? I mean, I don't really have another computer to try it on, is there any other way? Also, I dunno what would have triggered the PSU to break since it worked before the mobo and gpu got sent away and now they've been replaced it's not. But if it is, then I have NO IDEA
 

·
Registered
Joined
·
211 Posts
Re: Sabertooth x58 won't boot

you said the power supply was working before this, hmmm must me something els, i'm not the greatest at this. I am sure some1 on these forums can help
 

·
Registered
Joined
·
25,110 Posts
Re: Sabertooth x58 won't boot

?>Are you certain you have the 4/8 pin Molex connected from the power supply to the motherboard?

> Are you certain you have a motherboard post (standoff) for every hole and a hole for every post (no more, no less)?

> When you put it back together, did you clean off all the thermal paste from the CPU/Heatsink and redo it with new paste?

> Are you certain that all four legs in the Heatsink/Fan are snapped clear in and tight on the CPU. (slots have to be where the instructions specify and all the same)

> Is the heatsink/CPU in there tight so you can't wiggle it?

BTW, that is a great motherboard with a lot of features and I am using one in this rig!
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 · (Edited)
Re: Sabertooth x58 won't boot

Definately have the molex connected.

I'm sure I have a post for every hole. (That's a good innuendo lolol :biggrinje)

I redid the thermal paste, ya.

Spent freaking AGES making sure the heatsink/fan was as tight on the cpu as I could get it (Innuendos ftw)

Can't wiggle it. (This is getting ridiculous)



I know I'm a child.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #11 ·
Re: Sabertooth x58 won't boot

Alright thanks dude, I'll do a thorough test tomorrow, off to bed now but I'll post what happens before I ring up Scan again. I'm on a tight schedule since I get home from school at 3:45 pm and Scan close their offices at 5:00 pm (I wanna get this thing up and running as quick as possible, don't wanna wait another day) but I'll get on it in straight away. Thanks :D
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #13 ·
Re: Sabertooth x58 won't boot

So I got home and performed a bench test and, for some ODD, ODD reason, it works now...guess I'm bad at putting PC's together. Anyway a HUGE thanks to you for suggesting it, even if I didn't know the problem, thanks a bunch. :pray:
 
1 - 14 of 14 Posts
Status
Not open for further replies.
Top