Tech Support banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1 (Edited)
Hey

Woke up today tried to turn on the pc after pressing the on button with no success i mashed the button a few more times with no luck

No fans start
no screen

Light on motherboard is on
light at back of pc where the ethernet cable is on

so i unpluged every cable and put it in a new room which i pluged the power cord in and wolla it work. following this success i put it back to room and and it didnt work so im guessing a cord is loose

Any ideas on how one would start to fix this
 

·
Premium Member
Joined
·
78,003 Posts
Re: PSU troubles

have you checked the wall out let with something else plugged in

i.e. a fan
 

·
Premium Member
Joined
·
78,003 Posts
Re: PSU troubles

check the power plug to the m/b is secure and nothing came loose when you were moving it
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
Re: PSU troubles

By saying that i know the cord gos into the back so do i just folow the cords comming from the PSU onto the M/b
 

·
Premium Member
Joined
·
78,003 Posts
Re: PSU troubles

yes just remove and put back in checking they are seated ok

the main power plug and the aux power plug
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
Did as you said after taking away entire case to remove PSU the faulty/loose cord worked again so decided not to touch it any further and leave it in working condition
Thanks for all your help Dai

Kelvin
 

·
Premium Member
Joined
·
78,003 Posts
if the loose one is from the wall to the power supply on the back of the case just bend the psu pins slightly to make it fit tighter

try a new cord
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top