Tech Support Forum banner
Status
Not open for further replies.
1 - 13 of 13 Posts

·
Global Moderator
Using Google to solve problems
Joined
·
43,131 Posts
Re: nspr4.dll missing error message

Boot off of the Windows 7 DVD. Choose to Fix My Computer. Windows will try and fix the error. If not then you have the choice of going to the Command Prompt. Here type chkdsk C: /R and press enter. The check disk utility will try and fix any errors. You can also go to Start/Search and type SFC /scannow and press enter. Put the 7 DVD in and it will take any files it's missing from the DVD.
 

·
Global Moderator
Using Google to solve problems
Joined
·
43,131 Posts
Re: nspr4.dll missing error message

This file is a part of Mozilla (Firefox, Thunderbird etc) If you have Firefox browser, try reinstalling.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
Re: nspr4.dll missing error message

I am using both Firefox and Chrome but it seems to be coming up with the problem when I use Chrome, I have downloaded and reinstalled Chrome this morning as well as Firefox.

That didn't fix the problem either??
 

·
Sr. Tech, TSF Team Emeritus Microsoft Support Staf
Joined
·
1,099 Posts
Re: nspr4.dll missing error message

Hi Bungy welcome to TSF. Firefox has had a problem with not uninstalling bad files using Windows uninstaller. Please download and install http://www.revouninstaller.com/revo_uninstaller_free_download.htm. Run in advanced more to uninstall the program. When uninstall is complete, please click next and let it scan for leftover traces in your registry and HDD. Click delete to delete traces.

If you aren't getting rid of the currupt files, when you reinstall the program it'll just reinstall the corrupt files again.
 

·
Global Moderator
Using Google to solve problems
Joined
·
43,131 Posts
Re: nspr4.dll missing error message

This is a problem with Chrome and Firefox not liking each other. I would uninstall both browsers, and restart the computer. Then Install Chrome First then Firefox, if you need them both.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #9 ·
Re: nspr4.dll missing error message

Looks like I have found a solution to my problem on another website:

copied from :

Chrome error message - nspr4.dll missing | Windows Secrets Lounge

I just started receiving an error message when I open Google Chrome. The message states that the application failed to start because nspr4.dll is missing, then Chrome starts anyway. nspr4.dll is the Netscape Portable Runtime, so I assume it must be used somehow for compatibility within the program and that the only thing not started is this compatibility function.

I searched for the error message in Google and found a workaround in a thread on Chrome's help forum, but it doesn't explain why it happens.

The fix is to copy nspr4.dll from Program Files>Firefox> to the Windows>system32 directory. (Alternately some copied it to ProgramFiles>Chrome)

Some other answers in the thread stated that after doing this, a new message popped up saying a couple of other dll's were missing, all were found in the Program Files>Firefox directory. Copying them to system32 fixed all of the machines.

Since this seems to be a common problem I was surprised there was no direct answer on the Google Chrome Help site, but just a thread from users in the forum.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #11 ·
More Information:

It's an alert produced by Adobe Flash within Chrome. The Flash plugin is dependent on Firefox nspr4.dll. I managed to rid myself of it at one point without copying the files from Mozilla FireFox, I think, by disabling plugins, or more specifically Flash, in the options dialog.

go to Options
go to Under the bonnet
go to Content Settings
go to Plugins
go to disable individual plugins
disable Flash
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #12 ·
This still didnt work for me as the problem re occured today.....I have read that the following solution will fix the problem.....

Now "disabled options "Attach Roboform to Firefox even if Adapter is not installed" (Roboform Options->Browser Integration)" and then hopefully all is well.

Hope this helps other users out there :)
 

·
Registered
Joined
·
1 Posts
I have been wrestling with the missing mspr4.dll for a while now by uninstalling and reinstalling both Chrome and Firefox without success. Ran sfe /scannow with no file problems reported. Even performed two different virus scans. Following bungy's suggestion to disable browser integration in Roboform, I have gotten past the chrome.exe system error. So far so good.
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top