Tech Support banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I've just installed an ATI HD 2400 video card (Sapphire) in my PC and my sound has disappeared. This video includes built in support for HDMI audio, and automatically installs the sound device.

In the process, it has removed my Realtek audio, which is built into the HP motherboard. I do not have HDMI devices attached to my PC and, when I read the documentation on how to disable the video card sound, it told me to select the native sound from the sound control panel. Of course, the Realtek sound has been removed, so now I have a mute PC.

Does anyone know how to disable the sound on the video card permanently and return the Realtek sound?

Any help would be greatly appreciated.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
Re: No Sound in HP Media Center PC with new ATI HD 2400 Sound Card

[Solved]

After I wrote the request for help, I realized that the BIOS was auto-detecting the sound device as the ATI card. So, I simply forced it to see the on-board sound device and all was well.
 

·
Registered
Joined
·
2 Posts
Re: No Sound in HP Media Center PC with new ATI HD 2400 Sound Card

[Solved]

After I wrote the request for help, I realized that the BIOS was auto-detecting the sound device as the ATI card. So, I simply forced it to see the on-board sound device and all was well.
My BIOS (Compaq) doesn't have an on-board sound option and it has RealTek HD on-board. Once I installed the ATI 2400 Pro, the system never recognizes the Realtek stuff anymore. Anyone know how to disable sound on the ATI? Or any other options, I want to use my on-board RealTec HD...:upset:
 

·
Registered
Joined
·
300 Posts
Re: No Sound in HP Media Center PC with new ATI HD 2400 Sound Card

I'm just guessing but I would go to my device manager and find the driver for the card you installed then disable that driver (don't uninstall it, just disable it).

I think if you disable that driver your onboard audio driver should default back.
 

·
Registered
Joined
·
2 Posts
Re: No Sound in HP Media Center PC with new ATI HD 2400 Sound Card

I tried that as well - after boot, still no RealTek and of course, Windows says it found new hardware "VGA Controller" and wants to find a driver for it...
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Re: No Sound in HP Media Center PC with new ATI HD 2400 Sound Card

My BIOS (Compaq) doesn't have an on-board sound option and it has RealTek HD on-board. Once I installed the ATI 2400 Pro, the system never recognizes the Realtek stuff anymore. Anyone know how to disable sound on the ATI? Or any other options, I want to use my on-board RealTec HD...:upset:
Not that I'm questioning your ability to read your BIOS, but I have to ask "Are you sure?" The reason I say this is that my PC is an HP Media Center and I'd be very surprised if HP uses a completely different BIOS setup on its Compaq machines from the HP ones.

Look around in the BIOS for a setting to override auto-detect of sound. That will work.
 

·
Registered
Joined
·
1 Posts
Re: No Sound in HP Media Center PC with new ATI HD 2400 Sound Card

HP onboard Sound is disabled,When
HP bios detect RADEON HD2400PRO on chip HD AUDIO.

you can hear onboard sound that
force overwrite this vga bios to your RADEON HD2400PRO.
because, this vga bios is disabled onchip HD AUDIO.

http://support2.jp.dell.com/jp/jp/download/document.asp?dn=304571
download "OUGA5.ISO" an burn to CDROM and boot from it.

atiflash -s 0 backup.bin 10000
atiflash -fs -fp -p 0 s3b17002.108

but, own your risk.
 

·
Registered
Joined
·
1 Posts
Re: No Sound in HP Media Center PC with new ATI HD 2400 Sound Card

This was driving me crazy but thanks to rranger and my co-worker I figured it out. rranger is correct, go into the bios and for onboard sound make sure it is set to "Enabled". After you set it to enabled, save your settings and continue booting up. Once you are logged in, go into control panel, then double-click your sounds audio devices icon, and then go into the audio tab and select the RealTek driver (or whatever related onboard driver you may have.) And in the future stay the heck away from ATI video cards :4-thatsba :grin:
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top