Tech Support Forum banner
Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I am having the same problem. Two XP computers. I have tried a thousand things, the only thing that changes is the wonderful variety of error messages and the fact that sometimes I can see the other computer and sometimes I can't, which is also wonderful.

ERROR MESSAGE:

Here are some of the great error message I get (these change all the time, which keeps things interesting)

\\Newpc is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Long failure: the user has not been granted the requested logon type at this computer.​

ANOTHER ERROR MESSAGE:

When I do Start > Run > \\oldpc and a window pops up with some printers and shared folders on the other computer. But when I click on a shared folder (the folder name is "test") I get the following message.

\\oldpc Test is not accessible. you might not have permission to use this network resource. Contact the admisistrator of this server to find out if you have access permissions.

Access is denied.​

Now, these error messages are great. And I'm really enjoying the grey hair that's appeared on my head after 3 days of this. But what I would really like to do is share some files between my two computers.

THINGS I HAVE TRIED:


  • Network Setup Wizard has run on both computers


  • Folder to share has "share this folder on the network" enabled.

  • In "Network Connections" both connections have Windows Firewall off

  • I can ping both computers in a command prompt when Notron Internet Security is disabled

  • In "Network Connections" both connection's Internet Protocall TCP/IP is set to "Enable Netbios over TCP/IP"

  • I have "use simple file sharing" enabled on both computers

  • The connection on both computers have the same Subnet Mask, 255.255.0.0

  • Control Panel > User accounts > I have created user accounts with the other computer's name on each computer

  • At some point I read to make sure 4 services are Started and set to Automatic. So I did this:
    Control Panel > Administrative Tools > Service.
    Make sure each of the following is set to Automatic: Computer Browser, Network Connections, Server, Workstation
    One of them was set to Manual, I changed it to Automatic. I think it was Network Connections.

  • At another point I read to enable Guest Account. So I did this:
    Right Click My Computer > Manage > Local Users and Groups > Users > Right click Guest > Properties
    Untick Account is Disabled (so enable the account)
    Right Clicked Guest again and set a password.

  • I have also tried the Windows Server 2003 Resource Kit Tools suggested in this forum and the regedit also suggested here.

I've spent hours and hours and hours searching for an answer. Somebody please help me. I was going to post my own topic, but I feel this fits here and since this thread is on google and has had over 4000 views, it would probably get more exposure here.
 

·
Registered
Joined
·
2 Posts
onionman,
I han the same same problem and I did post a solution also, if you have missed that one here is it again:
1>Enable guest account on the computer where the share is hosted
2>Remove the "guest" entry from
Local Policies->User Rights Assignment
Deny access to this computer from the network
3>Add the "guest" entry in
Local Policies->User Rights Assignment
Access this computer from the network
3>On the TCP/IP properties of your LAN connection, check "Authenticate as guest when user or computer information is unavailable"

let us know if it helped.
Thanks
 

·
Global Moderator
Joined
·
51,635 Posts
Even though it appears you're having the same problem, please start a new thread when you have a new issue. It's very difficult to keep two problems straight and who's working on what in a single thread. I've created a new thread for your issue here. Thanks for your cooperation.
 

·
Global Moderator
Joined
·
51,635 Posts
Checklist for networking Windows Machines with TCP/IP
-----------------------------------------------------
- PCs which are not XP must have TCP/IP installed.
- Each PC must have a unique computer name.
- Each PC must have a network share defined.
- ALL NICS must be on the same subnet (e.g. IP 192.168.0.* subnet mask 255.255.255.0).
- XP PCs must have Netbios over TCP/IP enabled (only essential for XP to talk to W9X PCs).
- MS Client and file & printer sharing must be enabled on each machine.
- All NICs must have their node type = anything except p-node (peer to peer, or point-point).
* To check, open a command prompt and type IPCONFIG /ALL.
- XP's ICF firewall is permanently disabled. (Only necessary for pre XP SP2).
- All 3rd party firewalls are disabled, uninstalled and deleted (until connection is working).
- PCs have the same workgroup (helps, but not essential for XP/2K, necessary for 9X/ME).

Allow 15 mins after rebooting a PC for that PC to appear in the workgroup, or
for it to see all other PCs. Or you can search for the PC by its computer name.


Additional things to check if you still have problems:
-----------------------------------------------------
- Check your Services are Started on all PCs: Workstation, DHCP Client, Server, TCP/IP Netbios helper, Computer Browser.
- XP gives access to its shares via the Net Guest Account. (Note, not the same as the local guest account in user accounts which should be off). Net Guest Account is enabled by default in XP, but to check it, open a command prompt and type: NET USER GUEST
Should return a line with 'Account active yes'.


Check XP Security policies:
--------------------------
- Access this computer from the network: add guest
- Deny logon locally: remove guest
- Network access:Sharing and security model... -> Guest only
- Deny access to this computer from the network-> check Guest is not here.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Thanks guys

Thanks Menzie and Johnwill.

Johnwill, Thanks for the advice. I am still working with the information in your post. I will post back shortly after trying everything.

onionman,
I han the same same problem and I did post a solution also, if you have missed that one here is it again:
1>Enable guest account on the computer where the share is hosted
2>Remove the "guest" entry from
Local Policies->User Rights Assignment
Deny access to this computer from the network
3>Add the "guest" entry in
Local Policies->User Rights Assignment
Access this computer from the network
3>On the TCP/IP properties of your LAN connection, check "Authenticate as guest when user or computer information is unavailable"

let us know if it helped.
Thanks
Menzi,

I really appreciate the help. I actually did try that before when I first read your post, but wasn’t sure if I did it right. Maybe you could let me know.

First first I typed the word “guest” in the field, clicked “ok” and nothing happened. The name didn’t appear on the list.

Then I tried locations, changed it to MSHOME and Entered NEWPC, which is the other computers name, as the name. Was prompted to enter User Name in the form of Domain/User Name and a Password. Tried a few things but didn’t get anywhere.

Then I tried the “Advanced” button and then “find now”. I found the word “guest”, added it. I was expecting to see “Guest” on the list, but the result “OLDPC\Guest” (OLDPC is the computer’s name I was working on). I figured that was good enough. Still not sure if that went correctly or not.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Checklist for networking Windows Machines with TCP/IP
-----------------------------------------------------
- PCs which are not XP must have TCP/IP installed.
- Each PC must have a unique computer name.
- Each PC must have a network share defined.
- ALL NICS must be on the same subnet (e.g. IP 192.168.0.* subnet mask 255.255.255.0).
- XP PCs must have Netbios over TCP/IP enabled (only essential for XP to talk to W9X PCs).
- MS Client and file & printer sharing must be enabled on each machine.
- All NICs must have their node type = anything except p-node (peer to peer, or point-point).
* To check, open a command prompt and type IPCONFIG /ALL.
- XP's ICF firewall is permanently disabled. (Only necessary for pre XP SP2).
- All 3rd party firewalls are disabled, uninstalled and deleted (until connection is working).
- PCs have the same workgroup (helps, but not essential for XP/2K, necessary for 9X/ME).

Allow 15 mins after rebooting a PC for that PC to appear in the workgroup, or
for it to see all other PCs. Or you can search for the PC by its computer name.


Additional things to check if you still have problems:
-----------------------------------------------------
- Check your Services are Started on all PCs: Workstation, DHCP Client, Server, TCP/IP Netbios helper, Computer Browser.
- XP gives access to its shares via the Net Guest Account. (Note, not the same as the local guest account in user accounts which should be off). Net Guest Account is enabled by default in XP, but to check it, open a command prompt and type: NET USER GUEST
Should return a line with 'Account active yes'.


Check XP Security policies:
--------------------------
- Access this computer from the network: add guest
- Deny logon locally: remove guest
- Network access:Sharing and security model... -> Guest only
- Deny access to this computer from the network-> check Guest is not here.
Thanks for posting that information, Johnwill. I just been going through the checklist you laid out. There are 3 things I am not sure about, but actually I think everything checks out. At this point I cannot see anything when clicking “view workgroup computers”.

One thing I might mention just incase it affects anything is that both computers have their own DSL connection running into a network card. In other words, two DSL connections, two computers. The two computers are connected together using an Ethernet crossover cable into the Ethernet input built into the motherboards. Not sure if that matters.

Here are the 3 items which I am not sure I did correctly. Still cannot see the other computers.

Each PC must have a network share defined: Not sure how to do that. I have folders on both PCs which are shared on the network under Properties > Sharing.

Node Type: My node type is “unknown”. I am not sure if that is okay. Do I need to change it? I wouldn’t know how or what to change it too.

XP's ICF firewall is permanently disabled. (Only necessary for pre XP SP2) I am not sure what ICF Firewall is or how to disable it. If it is just normal Windows Firewall, that has been disabled by Norton and I have also made sure it is disabled in the appropriate Internet Connection Properties. Anyway, both computers are XP SP2 so it shouldn’t be a problem, according to what you say.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #8 · (Edited)
Checklist

Johnwill, In working through your checklist I have made note of how to actually find the settings and included that in a sort of revised list. Hopefully other readers will find it helpful. I am still racking my brain, and the brains of others trying to get my two stupid computers communicating with eachother.

If I get anything wrong here, just let me know and I will update it. Cheers.

Checklist for XP computers:

Run Network Setup Wizard on both computers:
Start > Control Panel > Network Connections (if you don’t see it, click “switch to classic view”) > Set up a home or small office network

Each computer must have unique Computer Name:
Start > Control Panel > System > Computer Name > Change

Each PC must have a network share defined:
????????????????????????????????????????

ALL NICS must be on the same subnet:
To check: Start > Control Panel > Network Connections > single click the connection you are using and look on the bottom of the right panel. Check both computers are the same. Mine says Subnet Mask 255.255.0.0

Enable MS Client and File & Printer Sharing on both computers:
Start > Control Panel > Network Connections > right click the connection you are using > Properties. Tick both “Client for Microsoft Networks” and “File and Printer Sharing for Microsoft Networks”.

All NICs must have their node type = anything except p-node (peer to peer, or point-point)
To check: Start > Run > type “command” > type “ipconfig/all” hit enter. Check the “node type” near the top.

XP's ICF firewall is permanently disabled. (Only necessary for pre XP SP2)
????????????????????????????????? Not sure if that is just plain old Windows Firewall. If it is:
Start > Control Panel > Network Connections > right click the connection you are using > Properties > Advanced > under Windows Firewall click “Settings” > tick “off”

All 3rd party firewalls are disabled, uninstalled and deleted (until connection is working).
Start > Control Panel > Add or Remove Programs > click the firewall (example Norton) > Remove

PCs have the same workgroup (helps, but not essential for XP/2K, necessary for 9X/ME).
You can set this during Network Setup Wizard. The default is MSHOME

Additional things to check if you still have problems:


- Check your Services are set to “started” on all PCs: Workstation, DHCP Client, Server, TCP/IP Netbios helper, Computer Browser. (I also heard that they should be set to “automatic”.
Right click My Computer > Manage > Services and Applications > Services
- Open a command prompt and type: NET USER GUEST
Make sure you see a line with 'Account active - yes'.

Check XP Security policies:

Found in Security Settings\Local Policies\User Rights Assignment
- Access this computer from the network: add guest
- Deny logon locally: remove guest
- Deny access to this computer from the network-> check Guest is not here.
- Network access:Sharing and security model... -> Guest only
Found in Security Settings\Local Policies\Security Options

Notes for networks with operating systems that are not all XP.

- PCs which are not XP must have TCP/IP installed.
- XP PCs must have Netbios over TCP/IP enabled (only essential for XP to talk to W9X PCs).
 

·
Registered
Joined
·
9 Posts
Re: Network not accessible

I had this problem
In the end it turned out to be hardware.
Crossover cable had intermittant bad connection -in one direction only.
With hindsight the symptoms pointed towards hardware rather than software.
I'm just so used to blaming everything on Microsoft.
Hope this helps, A.
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top