Tech Support banner

Status
Not open for further replies.
1 - 20 of 20 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1 (Edited)
Hey everyone
Basically Runescape runs alright for me. I'm maxed out in that game and all I really do is play this minigame called castle wars (in runescape). It's a capture the flag type of game and when the flagholder dies he drops the flag and you gotta click on it to take it right. Now whenever i click on the flag (or any other object for that matter or even when I run/walk) theres this 0.5 - 1 second delay before my character actually grabs it. I thought it was normal for everyone but when I played at my friends or on my brothers computer I would grab it without any delays. I dont think it's an internet issue since my friend doesn't have any problems (same ISP) and even on my brothers computer it runs fine and smoothly without this small delay/lag. I have high speed 7 mbps download 512 kbps upload, my brother uses the same connection, and my friend also has high speed from the same ISP. So my conclusion was that it was my computer.
I'ved tried updating java, running the game on microsoft java vm (which made it worse so I went back to the latest SUN Java), defragmenting my computer, restarting modem but nothing seems to work.

My computer specs:
Windows XP Professional
Intel Pentium 4 CPU
2.40 GHz
512 MB of RAM

Runescape specs: (everyone says those arent the real requirements but thats what the runescape site says anyway so here it is:)
64Mb RAM
300+ MHz CPU
Thats for low detail, and I always play on low detail instead of high but it still lags :x

I ran antivirus, antispyware and whatnot and I'm pretty sure I don't have any viruses. I deleted all my big files/games that I dont need anymore. More than half of my hard disk is free space. Now, my friend on the other hand has loads of games on his computer, a slower CPU (1.8 GHz, I have 2.4), dont think he even ever defraged his hard disk or have the latest java updates (yeah he just doesn't care and doesn't play runescape much)... and he doesnt have this lag/delay. Even on full servers he would click on an object and the character would perform the action instantly.

Half a second between actions might not make a big difference in general but at this minigame it really does. Playing this minigame is pretty much all I play anymore and if this lag continues I don't know what I'm gonna do...

Sorry if it was a long read but I hope you know exactly what my problem is and can help me :)
Thanks.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3 (Edited)
Re: Minor lag/delay, Runescape

Ok thats going to be linked with your ping (player server interation time) try a server closer to you, also it is my experence that the game runs slow at or about castle wars or the pest control area
On my computer I tried closer servers/less crowded but nothing helps. However my brother and my friend have no lag whatsover on any server any location whether it is full or empty, and a concentrated number of people in one area doesn't affect them either.
There's the red x when you click on objects, I click and it immediately does the red/yellow x but it takes a good 0.5-1 second for the character to actually do the action. It has to be something to do with my computer, since my brother uses the same connection, but on his computer, and doesn't have this problem at all.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
Re: Minor lag/delay, Runescape

Have you tried a program like swiftswitch?
Yes I've tried swiftswitch, internet explorer, firefox, the official runescape client.. all the same problem.
Nothing that eats up my CPU runs while I play.
Someone told me to delete my temp internet files and use a direct connection for java. Tried it but again they didn't work.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #9
Re: Minor lag/delay, Runescape

hmmmm maybe you have an internal temp problem is you're comp clean?
What do you mean by clean? I'm pretty sure I don't have any viruses/spyware and nothing that uses a lot of my internet bandwidth or CPU running.
Anything else I can do to make sure my computer is clean?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #11
Re: Minor lag/delay, Runescape

Its pretty much clean. There is no clumps of dust, not overly dusty but I did clean up as much as I could.
But problem not solved :sigh:
 

·
Registered
Joined
·
10 Posts
Discussion Starter #12
Re: Minor lag/delay, Runescape

I read in the runescape knowledge base "Microsoft Java is slightly better at playing RuneScape than Sun Java."
I tried ms java but it lagged. I don't know if it was because I had both sun and ms java but I could try uninstalling Sun java and run only on microsoft java see if it works this time. Hopefully
 

·
Registered
Joined
·
10 Posts
Discussion Starter #13
Re: Minor lag/delay, Runescape

Ok, I uninstalled all sun java and microsoft java. Re-installed ms java and the game worked as good as with the latest version of SUN java. But I still have this delay...
However I noticed that it's not as much as before. Maybe it was because I uninstalled all the previous old versions of Java I didn't use and re-installed the latest java only. So yeah i did notice a small improvement when I got rid of all the old versions of java. There is little difference between ms java and sun java though. Same delay..
Still waiting for help :x Hopefully someone will find a fix for this soon:pray:
 

·
Registered
Joined
·
10 Posts
Discussion Starter #15
Re: Minor lag/delay, Runescape

well just how sure are you the pc is clean from viruses,and spyware?do you keep such programs up to date?also do you do regular scans?do you regularly clean the internet cache with disk cleanup etc?
Yeah i do update and i do scans.

But the great news is that i finally fixed it ;))))
I searched for all runescape files and found the jagex cache. I cleared the runescape cache (.jagex_cache_32)which was stored in my WINDOWS folder. Clearing the internet cache using disk cleanup didnt clear this file.
Everything works great now :smile:
 

·
Registered
Joined
·
4 Posts
Re: Minor lag/delay, Runescape

Yeah i do update and i do scans.

But the great news is that i finally fixed it ;))))
I searched for all runescape files and found the jagex cache. I cleared the runescape cache (.jagex_cache_32)which was stored in my WINDOWS folder. Clearing the internet cache using disk cleanup didnt clear this file.
Everything works great now :smile:
hi i had a mayor lag yes today up to that point runescape was running great no lags no problems at all but now it is laging teribly i can't play enymore like that cos it get's stuck in 1 place or logs off by it self, i don't know what to do it's not my PC cos it was running fine up to yes today
even yes today when i first logged on it was fine but then i changed server
and from that point on it started laging plz
HELP!!!!!!!!!!!!!!!!:sigh:
 

·
Registered
Joined
·
4 Posts
Re: Minor lag/delay, Runescape

What do you mean by clean? I'm pretty sure I don't have any viruses/spyware and nothing that uses a lot of my internet bandwidth or CPU running.
Anything else I can do to make sure my computer is clean?
Hi view month ago i had 658 viruses on my PC my step dad tried everything
and downloaded Anti virus XP 2008 in the beginning it was working but up to the second registration it stopped working so my step dad uninstalled
all of the old anti viruses and installed McAffe Seciurity Center and belive me it runs great deleting spyware viruses and complitley keeping my PC protected and with new version of McAfee Site Advisor it keeps me on safe net sides free of viruses and spam but the Anti virus XP 2088 keeps finding viruses that are not there so if u see Anti virus XP 2008 keep away from it it won't do eny good trust me :D
 

·
Registered
Joined
·
4 Posts
Re: Minor lag/delay, Runescape

hi i had a mayor lag yes today up to that point runescape was running great no lags no problems at all but now it is laging teribly i can't play enymore like that cos it get's stuck in 1 place or logs off by it self, i don't know what to do it's not my PC cos it was running fine up to yes today
even yes today when i first logged on it was fine but then i changed server
and from that point on it started laging plz
HELP!!!!!!!!!!!!!!!!:sigh:
 
1 - 20 of 20 Posts
Status
Not open for further replies.
Top