Tech Support Forum banner
Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
I have been having trouble with my LAN over the past few days. My LAN was working fine until a few days ago. Long story-short, I accidentally reset my computer back to the state it was when it was new. This isn't a big problem for me. I updated everything back to it's previous state, reinstalled my wireless adapter, and got everything back to normal. My Internet is working fine, but my LAN says acquiring network address for 5 minutes before showing as Limited or No Connectivity. My PC has 2 Network Connections; my Wired LAN using an Ethernet cord from my Xbox 360 to my PC. My PC's Wireless Adapter connects to a router and then a modem.

My LAN tells me the reason it has Limited Connectivity is because it can't obtain a network address from the network. My IP is configured to be automatically obtained (DHCP Enabled), but it instead gives me a Automatic Private Address (169). I have tried MANY methods to fix my DHCP, TCP/IP, and other Networkish stuff, but none of it works.

I have also tried to set a static IP for my computer, and Xbox. Using numerous combinations of IP's and Gateways I finally got my Xbox to connect to the network. I set my Xbox's Ip to 192.168.2.94, Subnet to 255.255.255.0, Gateway to 192.168.2.93, and Primary DNS to 192.168.2.93. My PC was set at IP: 192.168.2.93, Subnet: 255.255.255.0, and DNS: 192.168.2.1. This let me connect to the network, but told me my DNS couldn't resolve the names of Xbox Live Servers. I found nothing wrong with my DNS, and I found no solutions to fixing it, so I assumed that the Xbox was wrong (The Xbox's only error with Internet is DNS related). I then set my setting all back to automatic.

Looking for concrete proof of what was wrong, I tried using the commands ipconfig/release and ipconfig/renew. My Wireless was fine in renewing IP's, but my LAN had an error message; "Can't contact DHCP server." I assume this is the main root of all my problems, even if I can bypass it with static IP's. My Xbox used to work just fine connecting to Xbox Live, and I know it still can. I need any solutions you can give me on how to resolve this problem.

The only other information I can give you on this problem is that ever since I accidentally reset my PC, I have been getting random disk checks on startup. File System: NTFS I think. This would obviously seem like the cause of all this (and it probably is), but I have had random disk checks when my Xbox could connect to Xbox Live. Also, every time I manually configure a default gateway to my LAN, my Wireless shows up as Connected, but doesn't work at all. My Belkin Router's IP is 192.168.2.1 and my Wireless's IP is 192.168.2.60.
Finally, here is my ipconfig/all data.



Windows IP Configuration
  • Host Name: Cameron
  • Primary DNS Suffix:
  • Node Type: Hybrid
  • IP Routing Enabled: Yes
  • WINS Suffix Search List: Belkin
Ethernet adapter Local Area Connection:
  • Connection-specific DNS Suffix:
  • Description: NVIDIA nForce Networking Controller
  • Physical Address: 00-1A-92-51-CB-80
  • Dhcp Enabled: Yes
  • Autoconfiguration Enabled: Yes
  • Autoconfiguration IP Address: 169.254.246.93
  • Subnet Mask: 255.255.0.0
  • Default Gateway:
Ethernet adapter Wireless Network Connection:
  • Connection-specific DNS Suffix: Belkin
  • Description: Belkin Wireless G USB Network Adapter
  • Physical Address: 00-17-3F-50-36-EA
  • Dhcp Enabled: Yes
  • Autoconfiguration Enabled: Yes
  • IP Address: 192.168.2.60
  • Subnet Mask: 255.255.255.0
  • Default Gateway: 192.168.2.1
  • DHCP Server: 192.186.2.1
  • DNS Servers: 192.168.2.1
  • Lease Obtained: Saturday, March 12, 2011 5:23:07 PM
  • Lease Expires: Monday, January 18, 2038 10:14:07 PM
If anyone can give me a solution so that my LAN will automatically be assigned an IP address, Network Configuration Settings so that my Xbox can connect to Xbox Live, or just get my Xbox to magically connect, I would appreciate it. If I have to purchase something than it probably won't be possible for me to fix the problem. PLEASE HELP ME!:4-dontkno:sigh::upset:
 

·
TSF Emeritus
Joined
·
16,395 Posts
Re: LAN can't contact DHCP server

You can't use the same ip range on the xbox that you have between the router and you.

Though you have routing set to yes it does not appear that ICS is engaged. I would suggest reinstalling ICS. It should give your wired nic [which is set to obtain ip automatically] 192.168.0.1 and act as a dhcp server for that subnet which means your xbox will bet a 192.168.0.x ip
 
1 - 2 of 2 Posts
Status
Not open for further replies.
Top