Tech Support Forum banner

[SOLVED] Java issues.

1866 Views 9 Replies 2 Participants Last post by  likalaruku
Haven't played Minecraft in a few months. When I tried to play it today, I got this message: "The registry refers to a nonexistant Java Runtime Environment instillation or the runtime is corrupt. The system cannot find the path specified." So I went to uninstall & reinstall it. Java 7 Update 17 uninstalls fine. I have both a Java 6 Update 26 & Update 31. Update 31 will not uninstall but 26 will.

When trying to uninstall J6U31, I get this: "The feature you are trying to use is on a network resource that is unavailable. Click OK to try again, or enter an alternate path to a folder containing the instillation package "jre 1.6.0_31-c-l.msi" in the box below." When exiting I get another box that says "The instillation source for this product is not available. Verify that the source exists & that you can access it."

I tried using JavaRa 2.1; Remove Java Runtime option says "no uninstaller found." Update Java Runtime hangs & freezes around 80%.

I can't find J6U31 in AppData/LocalLow/Sun/Java, so I imagine I need to manually remove some .dll so it stops showing up?

After reinstalling Java 7, I tried to reinstall Minecraft, but I still get that first message.
Not open for further replies.
1 - 10 of 10 Posts
Re: Java issues.

You shouldn't have v6u26 or u31 as the current but no longer supported is v6u43, but you should have uninstalled u26 when you updated to 31.

If you still have v6u31 showing in Progs & Features, then you could use the free or trial Pro version of Revo and do the uninstall in Safe Mode with Networking.

If it's no longer listed then you could try the reinstall of it from here - it's well down the list.

Reinstall v7u17 when successful and Java have this troubleshooting check list should you still have problems.

Rather than disabling your AV as it suggests, do the installs in Safe Mode with Networking as well, as your AV will be isolated in this mode but will still keep you safe.
Re: Java issues.

Thanks. I knew I could get good help here.

I'll return with the results after I try these, in case anyone finds it useful in the future.
Re: Java issues.

Okay, I installed V6U31 6 bit & ended up with 2 V6U31s.

I uninstalled that & attempted to reinstall a 32 bit version.

"This software has already been installed on your computer. Do you want to reinstall it?"


"The feature you are trying to use is on a network resource that is unavailable."

I'll try Revo now.
See less See more
Re: Java issues.

Okay, Rev Pro got rid of all the leftovers. Now to reinstall Java 7.

Well, Update 31 is finally gone, but Minecraft is still giving me this: "Launch4j: The registry refers to a nonexistent Java Runtime Environment instillation or the runtime is corrupt."
Re: Java issues.

You could try installing the 64bit version as well and then it can choose which version it wants to use and have you checked for any updates for your graphics ?

Also run the Java test
Re: Java issues.

The only other two articles that come close to resolving this is this article and a poor YT Video.

If you can follow what he's doing in the video, it may also resolve for you - using the Pause & Play may help.

Minecraft Java Runtime Environment Problem - YouTube
Re: Java issues.

Oh, the video's tip worked <3

Thanks for all the help Tomken.
Re: Java issues.

I thought the video was a dead loss but glad you found it helpful :smile:

If you're happy and don't have any other problems then you can use the Thread Tools dropdown to Mark thread as Solved - and you're welcome :smile:

Re: Java issues.

Yeah, who'd have thought a little boy would actually have a useful tip on troubleshooting? I thanked him too.
1 - 10 of 10 Posts
Not open for further replies.