Tech Support Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
92 Posts
Discussion Starter · #1 ·
I think my Geforce 210 is damaged or dying. Whenever I run any game I get weird graphic glitches like in the screenshot attachment below.

I have followed the nine troubleshooting your video card tips from this website, and while that was an excellent starting point, I still don’t know what the problem is.

Some background, four weeks ago I upgraded my rig with a new motherboard HDD and PSU, I did not realise at the time how important a good PSU was! Mine was an underpowered cheapie. (My friend built my PC.) And I had some bootup problems, see thread if interested. Last weekend I replaced my PSU with an OCZ 600W StealthxStream 2.

Prior to that I noticed the graphics problem while playing dead space and arkham asylum. I loaded up the game the other day and the problem is much worse, It’s like as if during gameplay the screen is being slashed with a knife and it’s flickering like a mad thing. (I can watch video fine, no problems there.)
I followed these forum tips.

Fix #1: install the latest motherboard chipset drivers.
Mobo:Gigabyte G31M-ES2L Downloaded chipset from gigabyte website and reinstalled.
Fix #2: uninstall your old display drivers and then install the latest display drivers. Did this for my geforce 210.
Fix #3: disable your sound system. Did this, still had the problem
Fix #4: slow down your AGP port. Got stuck with this! Could not work out h tried powerstrip programme but was unable to change any settings.
Fix #5: rig a desk fan to blow into your computer. Did this, no change in graphics. BTW according to speedfan and pc wizard my GPU temperature didn’t run above 6o degrees while running Arkham, so don’t think it’s overheating.
Fix #6: underclock your video card. Underclocked both engine clock and video ram, problem still persisted.
Fix #7: do physical checks. Took my card out, cleaned fan, seemed fine. Everything looked ok.
Fix #8: test your CPU and RAM.
Ran memtest and it passed with no errors, pheww! Did not really understand prime 95, I ran it and this came up, (see attachment. )Not sure if it’s good or bad.
Fix #9: check your power supply
My readings were: +12v =12.11v
+3.3 =3.36v
+5 =5v
Any ideas, do I need a new card?

Thanks a lot,

Neill
 

Attachments

·
Emeritus
Joined
·
51,675 Posts
Re: Is my Geforce 210 damaged/dying

It's a possibility the previous "underpowered cheapie" PSU damaged the GPU. Can you try your GPU in another PC or try another GPU in your PC?
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #3 ·
Re: Is my Geforce 210 damaged/dying

Hello Tyree,

Well most of my immediate friends have laptops. I would have to buy another GPU. I can do that in a few days.
 

·
Registered
Joined
·
92 Posts
Discussion Starter · #4 · (Edited)
Re: Is my Geforce 210 damaged/dying

Ok, I bought a new card, same model Asus EN210 and installed it last night. Seems to have fixed the problem.:tongue: Tested Just cause and a new game Burnout paradise, graphics were fine.

I guess running my old Allied 400w PSU damaged the last card. You pay to learn!
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top