Tech Support Forum banner
Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Hello guys.

I got a problem with my graphics on my PC. Here is the story behind it.

About 1 month ago I decided to buy a new graphic card. I discovered my slot was AGP and that my choice was limited. So I was suggested to buy ATI Radeon 2600 HD, for AGP slot. And I bought it. I installed it and everything and when I tried to open my video game, the first problem appeared. The screen was all messed up, the textures were messed, and all the text, to make it short: you couldn't see almost anything.

So I took my computer to the service and the guy fixed it. When he gave me my computer back it worked perfectly. When I asked what was the problem he said:

"The graphic card was too strong for your motherboard, so I updated the drivers so it could carry the graphic card."

Everything went fine until today. I bought a new hard disk. So I installed everything back again and when I opened the game.. I saw the same again. I tried to contact the service, but it's sunday so they don't work, and I need my computer really badly for tonight and also I don't have much cash anymore to pay some guy to just install some drivers...

So I was trying to do it by my own, downloaded about 10 different drivers, nothing helped. I am not even sure if I am looking for the right motherboard drivers, this is what EVEREST says:

Motherboard Properties:
Motherboard ID 63-121-0000010-00101111-072706-nVidia$M2N3V121_AM2NF3-VSTA BIOS P1.30
Motherboard Name Unknown

And this is what it says about my graphic card:

Video Adapter Properties:
Device Description ATI Radeon HD 2600 Series
Adapter String ATI Radeon HD 2600 Series
BIOS String 113-AAXXXXX-XXX
Chip Type ATI display adapter AGP (0x9587)
DAC Type Internal DAC(400MHz)
Installed Drivers ati2dvag (6.14.10.6734)
Memory Size 512 MB


So I am really clueless, no idea what to do. Here is a screenshot of the game how it looks:


http://img504.imageshack.us/img504/1018/wowproblemba2.jpg

And I would also like to mention that I cannot watch videos. Only some videos. I can watch WMA files, but not AVI ones... AVI clips are the same like games are for me. But WMA runs fine.


Please help me guys.
 

·
Registered
Joined
·
9,639 Posts
Re: Graphic problem somewhere between motherboard and graphic card. Help needed!

Hi,
Welcome to TSF.
I need to see what your device manager says. Open the device manager and open all the + marks. Post a screenshot with all the + marks opened.
Here is how to post a screen shot:
http://www.techsupportforum.com/content/Software/Articles/151.html
You may have to take 2 shots and attach them to the thread.
Thanks,
Bill
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Re: Graphic problem somewhere between motherboard and graphic card. Help needed!

I think i fixed my problem. It's some buggy but working. Think i am gonna change my graphic card+motherboard..


thanks a lot for the reply!
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top