Tech Support Forum banner
Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi, hoping someone here might be able to help. I have a Beko 32" LCD TV (model: 32WLA530HID) and live in the UK. It will be 4yrs old at the end of June. Since Tuesday, I have not been able to use it...

On freeview (built-in), the screen freezes after about 10 seconds and it won't let me do anything other than switch it off (then it says "please wait" which it never used to do, it'd just switch off). Analogue won't tune in at all, it will give me sound but no picture (other than ugly colour sqiggles!).

I live in a flat and use a communal arial but haven't heard of anyone else having any problems. The only thing I've yet to try is an indoor arial, but I'm pretty sure it's not the arial and the TV is knackered...

Any help, or even an idea if it's something I could get fixed, would be great.
 

·
Registered
Joined
·
392 Posts
Re: Fault with Beko 32WLA530HID LCD TV

Just a guess, try a power down reset. Unplug the power cord and press and hold the power on button for 10 seconds, then let it set 20 minutes to give all the circuits time to drain. Plug it back in and try it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Re: Fault with Beko 32WLA530HID LCD TV

A marginal improvement...on first attempt the picture was fine, but after a while it wouldn't let me change the channel or go into the guide. Second attempt, got into the guide but then the picture froze. So thank you as now at least I might be able to watch something (even if I have to turn the TV off and on again to change channel)...!
 

·
Registered
Joined
·
1 Posts
This is a problem on these sets you need to replace some capacitors on the psu and digital panel.

PSU change ,C924,C925,C926,C927

DIGITAL/PANEL change, C465,C467,C507,C638

May be some others too have a look see if any are showing stress
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top