Tech Support Forum banner
Not open for further replies.
1 - 4 of 4 Posts

· Registered
2 Posts
Discussion Starter · #1 ·

I have a Toshiba Equium P300-16T and it has Vista Premium running on it. We also have a BT Home Hub (the black one) which we had replaced on the advice of BT. Prior to that my laptop had been connecting to the white hub, until about 3 months ago, when the connection just dropped.

All the other laptops in this house or friends' laptops were still able to connect to the hub, and my laptop was having no problem connecting to other unsecured networks in my street. It would occassionally connect to our hub, but this connection was temperamental.

We were told that we needed a black hub which we got, but it will not connect to this one at all. It shows it in its list of wireless networks, but will not connect due to low signal, even though I am next to the hub. The ethernet connection works perfectly fine.

I have been through the whole BT routine thousands of times, and quite frankly I know they cannot help. Is this a problem with my laptop and what can I do to fix this, as I really need to be able to use this laptop wirelessly.


· Global Moderator
Electronic Design
52,686 Posts
Re: BT HomeHub wireless problem

First off, I'd load the latest wireless drivers available for the machine, since low signal can sometimes be driver issues.

Next, here are some changes that may help to increase the compatibility of Vista with older networking devices:

Disable the IP Helper service:

1. Hold the Windows key and type R, enter "services.msc" (without the quotes) and press Enter
2. Scroll down to the IP Helper service, right click on it and select Properties
3. In the dropdown box that says "Automatic" or "Manual", set it to Disabled and then click on "Apply"
4. Then click on "Stop" to stop the service from running in the current session
5. Click OK to exit the dialog

Disable IPv6:

1. Hold the Windows key and type R, enter "ncpa.cpl" (without the quotes) and press Enter
2. Right click on each network connection and select "Properties"
3. Remove the checkmark from the box next to "Internet Protocol Version 6 (TCP/IPv6)
4. Click OK to exit the dialog

NOTE: You should do this for each network connection.

Disable the DHCP Broadcast Flag:

  1. Hold the Windows key and type R, enter regedit and press Enter.
  2. Locate and then click the following registry subkey:
  3. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\{GUID}
  4. In this registry path, click the (GUID) subkey to be updated.
  5. If the key DhcpConnForceBroadcastFlag does not exist, use the Edit menu, point to New, and then click DWORD (32-bit) Value. In the New Value #1 box, type DhcpConnForceBroadcastFlag, and then press ENTER. If the key exists, skip this step.
  6. Right-click DhcpConnForceBroadcastFlag, and then click Modify.
  7. In the Value data box, type 0, and then click OK.
  8. Close Registry Editor.
NOTE: You should do this for each and every GUID subkey.
NOTE2: (GUID) is a mnemonic for the individual subkeys, the actual text "GUID" does not appaer.

The only program I'm aware of that currently relies on IPv6 is the new Windows Meeting Space. The first 2 changes will cause that program not to work - but will leave all of your normal (IPv4) connections unaffected. If it causes problems that you can't overcome, simply revert back to the original settings.

· Registered
2 Posts
Discussion Starter · #3 ·
Re: BT HomeHub wireless problem

Thank you for your reply. I haven't tried it yet, as I managed to log-in to the Hub itself using the Ethernet cable.

Apparently my network adapter is 802.11b/g and the default for the hub is 802.11b/g/n. I changed the hub setting to match my laptop setting and restarted both of them, and it connected without a problem.

I have no idea what all those letters and numbers mean, but it sure did work for me, and it is recognising the hub now.

Thanks, once again for your response, which I will save just in case my joy is short lived :grin:
1 - 4 of 4 Posts
Not open for further replies.