Tech Support Forum banner
Status
Not open for further replies.
1 - 20 of 26 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I've done plenty of searching to try to find the solution to this problem to no avail. I have gone through all 10 of the steps in the sticky threads to make sure it wasn't anything simple (thought it might have been as i'd forgotten about direct-X updates) but i'm still getting exactly the same error after updating.

On trying to run the game i get the big "Battle for Middle Earth II" bannermajig on screen then a highly informative;

Battle for Middle Earth II has stopped working
Find solution to the problem..... *LOADING BAR*​

which quickly becomes;

Battle for Middle Earth II has stopped working
A problem caused the program to stop working correctly. Windows will close the program and notify if a solution is available.​

Computer spec;

Intel Core 2 duo E6750
2GB RAM
nVidia 8600GT
Realtek Audio

All fully up to date as of this post, so is Direct-X.

Any help would be much appreciated, bought the game for plenty of LAN play and i'm the only one who can't get it to work :rolleyes:

-d
 

·
TSF Team Emeritus
Joined
·
3,450 Posts
Re: Battle For Middle Earth II

Hi deedoubleyou, welcome to TSF.

Believe it or not, I used to have the exact same problem. It seems the game has trouble creating files in Vista.
Give this a try:
Search for a folder named AppData Then open Roaming -> My Battle for Middle Earth 2 Files.
You'll probably find that the folder is empty. If it is, open up notepad and save new file to that folder. It should be named Options.ini.
In that file, place this data:
AudioLOD = Low
HasSeenLogoMovies = yes
IdealStaticGameLOD = VeryLow
Resolution = 800 600
StaticGameLOD = VeryLow
TimesInGame = 1
Then save that, and create a new folder named Maps in the My Battle for Middle Earth 2 Files folder.

If that still fails, delete the data out of the Options.ini file and replace with this:
AllHealthBars = yes
AmbientVolume = 81.000000
AnimationLOD = High
AudioLOD = Low
Brightness = 50
DecalLOD = High
EffectsLOD = Medium
FlashTutorial = 0
GameSpyIPAddress =
HasSeenLogoMovies = yes
IdealStaticGameLOD = Low
ModelLOD = Medium
MovieVolume = 70.000000
MusicVolume = 78.000000
Resolution = 1024 768
SFXVolume = 80.000000
ScrollFactor = 64
SendDelay = no
ShaderLOD = Low
ShadowLOD = Low
StaticGameLOD = Custom
TerrainLOD = Medium
TextureQualityLOD = High
TimesInGame = 59
UseEAX3 = no
VoiceVolume = 69.000000
WaterLOD = Medium
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Re: Battle For Middle Earth II

That first fix was the one! Thank you very much, appreciate it mate. It seems that Battle for Middle Earth is the culprit for a lot of the threads in this forum.
 

·
Registered
Joined
·
1 Posts
hello I got a problem too. When I play the game I can play it only for about 3 an a half munutes then all my structures crash down and all my worriors die and I lose the battle. I did the thing you said to deedoubleyou but still it doesen`t work. Do you know the solution for this too ?
 

·
Registered
Joined
·
1 Posts
i have a problem where i put in the disc, it starts running the loading screen but then it says i need 2 insert the correct disc. i have the collectors edition and before you ask...i DID make sure it was the game disc. any helpon this would be good so i can move onto the other problem windows 7 has with windows 7

wait never mind...it turns out that it was trying to run it in compatibility for xp. duno y it tried that
 

·
Registered
Joined
·
1 Posts
Re: Battle For Middle Earth II

Hi deedoubleyou, welcome to TSF.

Believe it or not, I used to have the exact same problem. It seems the game has trouble creating files in Vista.
Give this a try:
Search for a folder named AppData Then open Roaming -> My Battle for Middle Earth 2 Files.
You'll probably find that the folder is empty. If it is, open up notepad and save new file to that folder. It should be named Options.ini.
In that file, place this data:


Then save that, and create a new folder named Maps in the My Battle for Middle Earth 2 Files folder.

If that still fails, delete the data out of the Options.ini file and replace with this:
Hi, i did the first options.ini thing for BFME2 and it worked a charm, the game plays on Windows 7 fine. And then i tried it for the expansion pack (Rise of the Witch King) and it worked but then the next day, the same problem that happened before on bfme2 with the programme not responding, still happens on the expansion. I've made it so i have full control on my user and i did the options ini but it still wont work. I've reinstalled it many times and it still has the same problem, is there any solution to making the expansion work on Windows 7?
 

·
Registered
Joined
·
1 Posts
I downloaded the option.ini and i go to (windows C:/>Users>[user name]>AppData and then there is nothin in there!! Not any file named Roaming neither My battle for middle earth!! What do i do in this case?
 

·
Registered
Joined
·
1 Posts
Hi, I have the same problem as described. It helped for Windows 7 and so for Windows 8. Today I have upgraded to Windows 10 and either the BfME 2 or the RotWK works. It shouws the same fail as written in the beggining.

Does it mean, that Win 10 are the end of lan partys of BfME? Or do you know how to solve it? Any other games I´ve tried are working (even the old Unreal Tournament)... Please, help:angel:
 

·
Registered
Joined
·
1 Posts
I FOUND IT I FOUND IT I FOUND IT!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Right click on the game icon and "run with graphics processor". worked Right away!!!!!!!!!!!!

This is after the options.ini fix.

been two hours.... now i get to finally play.

for windows 10

:thumb:
 
1 - 20 of 26 Posts
Status
Not open for further replies.
Top