Tech Support Forum banner

[SOLVED] 1GB DIMM installed but only 512mb in windows?

10274 Views 13 Replies 2 Participants Last post by  Doby
I recently bought a MSI-MS6741 (K8TM\K8MM) Motherboard and set it all up using an AMD Sempron 3100+ CPU and a 1GB DDR400(PC3200) and an old 250wPSU(has 13A on +12v) and it boots fine,installs windows (XP and Vista)
but i noticed that while i have 1GB Module installed it is only showing 512MB(and it runs like it only has 512mb,very slow on Vista).
I tried to see what was showing in Setup and it only shows speed(Mhz) and CAS Latency but does not show how much memory available? BIOS is AMI 3.31a if you need to know.
Following that i d/loaded Everest 2.0 (from the valuable links this site provides) and it shows the same in there which is querying the SPD i assume for that info so my guess is the board.
The boards manual says it can take 2GB (2x 1GB) and says it supports "unbuffered" DDR400 RAM (and 333/266) so what type of RAM Modules do i need to get this board running 2GB (and showing it in window's).
My guess is either u need to populate both banks with 1GB modules or use 1GB modules @ DDR333?
If you need more info i can post an Everest report with relevant sections(SPD,BIOS,Mobo etc)

Hope someone knows whats goin on here!
Not open for further replies.
1 - 7 of 14 Posts
Re: 1GB DIMM installed but only 512mb in windows?

I just ran Memtest86 and has following info:

testing(under progress meters) 200k-1024m 512m using cpu(0).

Cached 512m and it also says my RAM is running at 1490mbp/s(should be 3200 right?).

RAM spec are: Kingston KVR 2.6v (KVR400x64C3A/1G)
numbers are: 9905193-054.A00LF

also separated from other type on sticker is: TMH1640703.

BIOS does show memory installed and it's 512mb.

Dropped speed to 333Mhz no change, dropped it down to 200Mhz(lowest setting) and still no change?
See less See more
Re: 1GB DIMM installed but only 512mb in windows?

just located and ran a 256mb DDR333 Chip and it shows as DDR333(166Mhz) at POST and in memtest. The section in memtest that says "testing 200k-256m 256m on cpu0" had 200k-256M(whereas 1GB test said testing 200k-1024Mb 512M on cpu0) so i'm thinking memtest can see the 1GB but it's only testing half of it?
Maybe it's the chip that's faulty?
Now i just installed the 1GB chip in my old ASUS A7N8X-VM board with an Athlon XP 2000+(The "Thoroughbred" i think) and it shows the full 1GB @DDR33 (board has a 400Mhz FSB (100Mhz QDR) but with 166Mhz RAM speed (DDR333) so maybe it's not the chip?
Re: 1GB DIMM installed but only 512mb in windows?

I didn't think it was the RAM because i maybe should have mentioned this earlier but i have owned that 1GB chip for 12mths now,i bought it for my ASUS K8V-SE deluxe and have used it mainly on that PC and never had a problem(always shows as 1GB). I also build/repair/upgrade PC's for friends etc etc and have used this chip in numerous other boards and never had a problem til this board.
I did try it in both slots with same result (only 512mb)
I'm starting to think that while the manual says it can support 2GB and can support DDR400 maybe it can't support 1GB modules @DDR400 (maybe 1GB chips @DDR333)
Sort of reminds me of the time i installed a 2.8Ghz Sock 478 P4 with 800FSB into a board with only 400FSB, the CPU only came up as 1.4Ghz @400FSB but that may be something else altogether.
So it's definitely the board and i suppose only way to get to the bottom of this is to get my hands on some 1GB DDR chips in DDR333 or DDR266 and see if it comes up right coz if it don't then this board is doomed to 1GB total memory(which isn't that bad i suppose).
Anyway i'll leave this case open in the hope someone has some insight to this prob.

Will let u all know how it go's!
Thanks for the help!
See less See more
Re: 1GB DIMM installed but only 512mb in windows?

contacted an Ebay RAM seller asking them what 1GB DDR RAM was compatible with my board and would work(i.e. show the full amount). and they say that this 1GB DDR333 chip will work on my system. Naturally they won't give any other info (or not til i actually buy the chip). So i'll buy this chip and install it,if it don't show a full 1GB i'll assume the board has issues and send the chip back for refund and set it up with 2 x 512mb(assuming that will work as the 256mb did) and run with 1GB total.
RAM details are as follows:Memory Size 1GB DDR SDRAM 1 x 1GB
Memory Speed 333MHz DDR333/PC2700
More Information 1024MB 64*8 Modules Low Density Chip configuration
Non ECC Non Registered UnBuffered Cas Latency 3 ( CL3) 6 Layer

My money is on that the board has probs and can't run 1GB DIMM's of any speed for some unknown reason when it should?
Re: 1GB DIMM installed but only 512mb in windows?

I think i may have got to the bottom of this (sort of).
Rather than run out and buy RAM that may or not work(properly) i decided to dig out some more DDR chips i have stashed away and run more tests. I ran the board with 2 x 256mb chips (DDR333 in bank 1/DDR266 in bank 2) and same result, likewise for test 2 which was 2 x 256mb(both DDR400) so still at square 1 there.
So i went into windows and checked out Everest 2.0(with the ddr400's installed) and was a bit confused with the info.1)everest says my memory bus is 133MHz(DDR266). 2) it show's both DIMM's and all info for both(including brand). 3)says system is using 256MB RAM. 4) in O/C section memory bus is running at 129MHz(133MHz)5) m/board section memory bus properties say "real clock is 133MHz" (core RAM speed) /effective clock 266MHz (DDR) and bandwidth of 2047MB/s (as in pc2100/DDR266?) 6)N/bridge section says i have 2 DIMM's installed @ 128mb each and lastly memory timings are a bit off? In timings of RAM being used it has 3,2,2,6(if DDR266 CS should be 2.5) but other 3 figures line up with DDR266 values not DDR400.
So basically my memory clock is only DDR266 which explains why DDR400 was getting cut down to DDR266(when i set it to "auto" in setup) but it seems both 256mb's are only running @ 128mb each for 256mb combined so is it normal for the size's to get cut down too? when only 1 x 256mb is running it shows full memory but 2 get reduced for some reason?
Newegg look like they have some quality stuff and the prices are pretty decent too + i read the whole return policy and sounds good. Do they ship/post to Australia? i assume so but couldn't find the info on the site.
I don't really want to get more RAM til this is figured out somewhat as the RAM they send may not work due to no fault by them and will waste my time as well as thier's but i can't see any other solution?
Will repost when i get the RAM and see the results!
See less See more
Re: 1GB DIMM installed but only 512mb in windows?

Case Solved!
It's not the board or the RAM it is my CPU.
This morning i switched the Sempron 3100+ with my Athlon64 3200+ out of my ASUS K8V-SE Deluxe and board is doing everything it should. Shows 512mb at POST and in windows for 2 x 256mb and they are running at DDR400. In Everest my memory bus is 200MHz real clock (DDR400). Put in the 1GB chip and it's all there just as it should be.
So i guess i have a dodgy CPU coz it says in Everest "Unknown Processor" but doe's say it's a Sempron and all with the SSE,SSE2,3DNOW etc etc but it says it has the x86-64 extension? I may be wrong but Sempron's aren't 32/64 bit are they? That's why i upgraded to the Athlon64 for 32/64 bit operation for WinXP 64. Sounds pretty dodgy but i did buy it off ebay so i should have guessed(it's what started to make me suspect the CPU).
Anyway verdict is board is fine and has no probs (never did i guess) and the CPU was the culprit all along so it's a new 754 CPU i need as RAM is fine (always was).
On to the next project now, a 478 P4 board with an i865 chipset lets hope this ones good.
Thanks for the help!

p.s. The process of elimination never fails!
See less See more
1 - 7 of 14 Posts
Not open for further replies.