Tech Support banner

Status
Not open for further replies.
1 - 20 of 26 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I wonder if someone can kindly help my worry. My "Shared Documents" folder has automatically renamed itself "Documents". I am now finding that the folder has somehow write-protected itself. I cannot delete pictures in the shared pictures as access is denied. My XP account is as administrator. I am unsure what has happened here. Please would someone advise.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
How would I know about the full control permission set. All I know is that I am set as "administrator". Also if I try and unclear the read-only box, it fills with a solid green square when I check it later. Is my system corrupted?
 

·
Registered
Joined
·
1,097 Posts
MooUK said:
My "Shared Documents" folder has automatically renamed itself "Documents".
That's the name that is given when you share that folder. Right-click the Shared Documents folder, and click Sharing and Security. Now, what does the "Shared Name" say?

MooUK said:
Also if I try and unclear the read-only box, it fills with a solid green square when I check it later.
I already said that XP sets all folders as "read-only". It shouldn't cause you any problems whatsoever. Here is what Microsoft says:

Unlike the Read-only attribute for a file, the Read-only attribute for a folder is typically ignored by Windows, Windows components and accessories, and other programs. For example, you can delete, rename, and change a folder with the Read-only attribute by using Windows Explorer. The Read-only and System attributes is only used by Windows Explorer to determine whether the folder is a special folder, such as a system folder that has its view customized by Windows

MooUK said:
How would I know about the full control permission set. All I know is that I am set as "administrator".
Well, if you want to run as administrator, you should know how to set user permissions. Now, right-click on the "Shared Documents" folder and click Properties. Do you see a tab that says "Security"? If you don't see a Security tab, then open Windows Explorer (or My Computer), and at the top click Tools, and then Folder Options. Click the View tab, and go to the bottom of the list where it says "Use simple file sharing". Remove any check next to this line, then click Apply, then OK.

Once you right-click on "Shared Documents", and click Properties you should the Security tab. Click the tab and you should get a list of Groups, with permissions at the bottom. Highlight the Administrators, and tell me if there is a check by "Full Control" at the bottom.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #7
Thank you Resolution for your patience. In answer to your first question, the shared name is blank. I am not sure if is because I am using XP Home but there is no security tab and there is no entry as described by yourself in the Tools -> Folder Options - to select simple file sharing. I think I am back to the beginning....?!?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #9
Again thanks for your help. The link you have kindly provided me with has a rather scary warning with it; "WARNING: Adjusting the permissions on a drive, file or folder can lock even the Administrator account out of that drive/file/folder. Deny Permissions take precedence over Allow Permissions, regardless of your group membership. Administrators are members of the User's group, by default. Uncheck Allow, rather than using Deny".

As I am relatively PC illiterate, do you think it still wise to continue. Ie. do you have a high suspician than this will help.
 

·
Registered
Joined
·
1,097 Posts
That warning is nothing to worry about. It's just telling you to be careful when setting permissions. Select and deselect the Allow permissions, but only use Deny when you really know what you are doing. This rings true on almost all operating systems.
 

·
Registered
Joined
·
97 Posts
i have this same problem so i don't want to start a new thread. when i download the thing from microsoft it says: 425 can't open data connection

can you help?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #13
OK, I have downloaded and executed the file as you advised. I now have the security tab in the properties of the "shared documents". The security screen is as follows: group or user names: EVERYONE, then for permissions for everyone the following are checked: read and execute, list folder cont., read. The following are UN-checked: full-control, modify, write and special permissions. I am too afraid to experiement without a hand to hold.... Should I just click full-control??. Again thanks for your help with this.
 

·
Registered
Joined
·
1,097 Posts
No, because you don't want everyone to have full control. What you need to do is add the Administrator's group (if they aren't already in the above list on the Security tab) and assign them full control.

If the Administrator group isn't listed, you can add them by clicking Add, which should bring up the Select Users and Groups window. On that window, click Advanced, then click Find. Click/Highlight Administrators and then press OK to close the window, then press OK again to add the Administrators group. Now you should be able to highlight the Administrator's group and assign it the "Full Control" permission. Once you have done that, click Apply, then OK. You should be able to edit files in the "Shared Documents" folder now. If it still doesn't work for the "Shared Pictures", then follow the same steps for that folder as well.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #15
Sorry, when I click on find, there is a large list. But there is both an entry for "administrator" and "administrators". Which should I select.
 

·
Registered
Joined
·
1,097 Posts
"Administrator" is the user, and "Administrators" is the group. You can also tell this by the icons shaped liked heads. One head for a single user, and two heads for a group. You want to click the group, or the Administrators with an "s".
 

·
Registered
Joined
·
25 Posts
Discussion Starter #17
I think I am getting closer. I have set the permissions to full for the administrator. Some of the files/directories are now writeable. The problem is that there are many sub-directories/folders that are still write-protected and when I try the steps before, it will not let me "Add" the administrators group, ie. it is not possible to click the "add" box. It just displays "everyone". Is there a way to carpet bomb everything within "Shared documets" to be covered by the administrator? Also as I mentioned earlier the name of the shared documents folder has renamed itself "documents", would there be a simple way to revert this back.
 

·
Registered
Joined
·
1,097 Posts
The only way I know of is to highlight all the folders in a subdirectory with the mouse, click properties, and apply permissions that would take place on all the folders.

To rename it "Shared Documents", open the desktop.ini file located in that folder. It's hidden so you will have to show hidden files. Once you open the file, delete whatever is in there, and copy/paste the following...

[.ShellClassInfo]
[email protected],-21785

After that, restart the computer.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #19
I am sorry to take up your time with this on-going issue. I have successfully restored the name after creating the desktop.ini file as you stated (there was not one to be found even after showing hidden). I am still a little stuck to delete a few subfolders & contents of a sub folder of "Shared Documents". I have tried to access the security tab but "groups or users names" listed is "everyone" and I am unable to use "Add" as it is in grey. Also I am unable to edit the permissions (also in grey) which shows that full control is not enabled. I have tried the parent folder which appears to have full control. Do you think there may be a corruption problem. Should I format the HD? Is it an issue of XP Home? Again my appologies to take up your time with this.
 
1 - 20 of 26 Posts
Status
Not open for further replies.
Top