Tech Support banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
I have Ubuntu 5.04 and Windows XP Media Center standard with sp2 (shouldn't make a difference though) installed on two different partitions. Mainly I use WIndows since when I decide to go play a game or play media files (on my xp partition) I don't have to reboot and reselect. The problem is by default Ubuntu starts up since it is at the top of the list. Normally I'd just go My Computer>Properties>Advanced>Settings for something on there (I forgot) and change the default, but it seems that only works with other Windows operating systems. How can I change this? It drives me crazy


Additional problem: My USB keyboard(s) never work in DOS and BIOS, only PS2 works. In BIOS I have USB support and USB 2.0 enabled, but it still does not work. USB to PS2 adapters don't help either. Oh, I have Award BIOS by the way.

Help will be VERY appreciated!
 

·
Registered
Joined
·
54 Posts
Are you using a linux boot loader? If so, maybe you should seek help in the linux forum.

If it is the windows one, follow the directions below for editing the boot.ini file

http://support.microsoft.com/default.aspx?scid=kb;en-us;289022

Assume that windows 2000 in the example below is linux.

[boot loader]
timeout=30
default=multi(0)disk(1)rdisk(0)partition(2)\WINNT
[operating systems]
multi(0)disk(1)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\WINNT="Windows 2000 Professional" /fastdetect

Copy the blue section over the red one.

NOTE: Backup your boot.ini file before modding it.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4 (Edited)
Okay, mine already looked like that... I don't even see Linux in here... take a look at my boot.ini

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP Media Center Edition" /noexecute=optin /fastdetect


Also, I went to that MS site and when I typed "bootcfg/defauled/id1" it didn't work and I got a syntax error... what's the deal
-------
Nevermind the above - it was a stupid mistake... lol...
 

·
Registered
Joined
·
22 Posts
Discussion Starter #6
Okay it doesn't seem to be my boot.ini instead it is GNU Grub .95 (or so it said during bootup) and it came with Ubuntu. I set my default boot to XP MC through command prompt, but that didn't help so I assume it is grub that configures this. I have no idea how to access this and since Linux was installed on my secondary partition I assume GNU Grub .95 was too, but I am not very good with Linux as I haave said before and I don't know how to make these changes myself. You cannot remove Grub, but it is possible to replace it with something like lilo or another boot prog. It would make my life much easier if I could simply change a setting or edit a line rather than swap boot progs.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top