Tech Support Forum banner
Status
Not open for further replies.
1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi

I just built my first PC and all games worked great in the first two weeks when I used Vista. However, I just upgraded to Windows 7 and installed all the drivers but i couldn't play games anymore. Whenever I start a game the screen starts detecting which input is used (Digital or Analog) then it stops working. I have a i7 920, SAPPHIRE Radeon HD 5770, GIGABYTE GA-EX58-UD3R, and Samsung SYNCMASTER 2333SW screen. I tried installing the new drivers but it did not fix the problem.
The games I tried so far are:
Left For Dead
Counter Strike 1.6
and World of Goo

Thanks
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
The games did not run because I did not hear anything from my headphones. However I reinstalled windows 7 and all the drivers and now every thing is okay.
Thanks
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
Update!
The problem returned again. Whenever I run a game the computer freeze, and I have no signal on my monitor. The only time the computer lunched a game, besides when I used Vista, was when I tested world of goo just after I reinstalled Windows7 cuz it will not take long time to download from Steam. After it worked I downloaded Team Fortress 2 and when I start the game the machine freeze, it is the same old problem. How can I fix this.
Thanks
 

·
Registered
Joined
·
138 Posts
Update!
The problem returned again. Whenever I run a game the computer freeze, and I have no signal on my monitor. The only time the computer lunched a game, besides when I used Vista, was when I tested world of goo just after I reinstalled Windows7 cuz it will not take long time to download from Steam. After it worked I downloaded Team Fortress 2 and when I start the game the machine freeze, it is the same old problem. How can I fix this.
Thanks
What was the last thing you did before this error happened?
Were you ever able to play TF2 without this error happening?
Could you please give a list of your specs as this will help everyone out.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 · (Edited)
Thanks for the reply

I updated windows7 and installed Microsoft Security Essentials, and I downloaded firefox, that's it. I i was able to play TF2 when I had Vista as an OS.

Processor: Intel Core i7-920 Bloomfield 2.66GHz

Motherboard: GIGABYTE GA-EX58-UD3R

Graphics Card: SAPPHIRE Radeon HD 5770

RAM: OCZ Gold 6GB (3 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600

HDD: Western Digital Caviar Black WD6401AALS 640GB 7200 RPM 32MB Cache

Case: Thermaltake Element S

Optical Reader: LG Black 8X BD-ROM 16X DVD-ROM 40X CD-ROM SATA
Internal Combo LG Blu-ray Reader & 16X LightScribe DVD±R DVD Burner

Power Supply: Antec EarthWatts EA750 750W

Monitor: Samsung SYNCMASTER 2333SW



and thanks again
 

·
Registered
Joined
·
138 Posts
Maybe the other guys can help you better but from what I read on other sites it seems TF2 does not play nice with Windows 7.

I know that one of the games I always play does not work 100% with Windows 7 yet.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
I tried other games and I still have the same problem. The problem happens at the time when the screen turns black then when it is supposed to run the game The screen loses the signal. I don't know if I described that well but in case anyone wants me to shoot a video I will be ready. I also found that when I change the screen resolution I have the same problem, I lose the signal on the monitor and the computer freeze.
Please help
Thanks
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #10 ·
I just uninstalled Microsoft Security Essentials and the games worked perfectly!
I don't know why it prevented them from working. However, I will try a different anti-virus software and I will see if it will prevent the games from working or not.
Thanks
 
1 - 10 of 10 Posts
Status
Not open for further replies.
Top